summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-06-26 14:55:09 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-06-26 14:55:09 +0000
commit07599ff637d35cca3b69013782d88fa6d41318a8 (patch)
treeba8d19aadd43df685e103b2c97af4b69c6a96c7d /net-libs/cyassl
parentrevbumps; add security patches XSA-55,56 to 4.2.1, 4.2.2, remove old ebuilds ... (diff)
downloadgentoo-2-07599ff637d35cca3b69013782d88fa6d41318a8.tar.gz
gentoo-2-07599ff637d35cca3b69013782d88fa6d41318a8.tar.bz2
gentoo-2-07599ff637d35cca3b69013782d88fa6d41318a8.zip
Version bump
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs/cyassl')
-rw-r--r--net-libs/cyassl/ChangeLog8
-rw-r--r--net-libs/cyassl/cyassl-2.7.0.ebuild141
-rw-r--r--net-libs/cyassl/metadata.xml42
3 files changed, 180 insertions, 11 deletions
diff --git a/net-libs/cyassl/ChangeLog b/net-libs/cyassl/ChangeLog
index b35c564a1a3c..73be2b8f0b76 100644
--- a/net-libs/cyassl/ChangeLog
+++ b/net-libs/cyassl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/cyassl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.37 2013/03/07 07:26:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/ChangeLog,v 1.38 2013/06/26 14:55:09 blueness Exp $
+
+*cyassl-2.7.0 (26 Jun 2013)
+
+ 26 Jun 2013; Anthony G. Basile <blueness@gentoo.org> +cyassl-2.7.0.ebuild,
+ metadata.xml:
+ Version bump
07 Mar 2013; Mike Frysinger <vapier@gentoo.org> cyassl-2.5.0.ebuild:
Add s390 lovin.
diff --git a/net-libs/cyassl/cyassl-2.7.0.ebuild b/net-libs/cyassl/cyassl-2.7.0.ebuild
new file mode 100644
index 000000000000..1112da538f0c
--- /dev/null
+++ b/net-libs/cyassl/cyassl-2.7.0.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/cyassl/cyassl-2.7.0.ebuild,v 1.1 2013/06/26 14:55:09 blueness Exp $
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Lightweight SSL/TLS library targeted at embedded and RTOS environments"
+HOMEPAGE="http://www.yassl.com/yaSSL/Home.html"
+SRC_URI="http://dev.gentoo.org/~blueness/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~s390 ~x86"
+
+#Add CRYPTO_OPTS=ecc when fixed
+CACHE_SIZE="small big +huge"
+CRYPTO_OPTS="+aes aes-gcm aes-ccm aes-ni +arc4 +asn blake2 camellia +coding +dh dsa +des3 ecc +hc128 md2 md4 +md5 nullcipher +psk leanpsk rabbit +ripemd +rsa +sha sha512"
+CERT_OPTS="ocsp crl crl-monitor savesession savecert +sessioncerts +testcert"
+DEBUG="debug +errorstrings +memory test"
+IUSE="-dtls examples extra fortress ipv6 +httpd mcapi pwdbased sni sniffer static-libs threads +zlib cyassl-hardening ${CACHE_SIZE} ${CRYPTO_OPTS} ${CERT_OPTS} ${DEBUG}"
+
+#You can only pick one cach size
+#sha512 is broken on x86
+#Testing freezes with dtls
+REQUIRED_USE="^^ ( small big huge )
+ leanpsk? ( psk )
+ fortress? ( extra sha512 )
+ pwdbased? ( extra )
+ test? ( !dtls )"
+
+DEPEND="app-arch/unzip
+ sniffer? ( net-libs/libpcap )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.0.8-disable-testsuit-ifnothreads.patch
+}
+
+src_configure() {
+ local myconf=()
+
+ if use threads; then
+ myconf+=( --disable-singlethreaded )
+ else
+ myconf+=( --enable-singlethreaded )
+ fi
+
+ if use amd64; then
+ myconf+=( --enable-fastmath --enable-fasthugemath --enable-bump )
+ elif use x86; then
+ #not pie friendly, sorry x86, no fast math for you :(
+ myconf+=( --disable-fastmath --disable-fasthugemath --disable-bump )
+ fi
+
+ #Bug #454300
+ export C_EXTRA_FLAGS=${CFLAGS}
+
+ econf \
+ --disable-silent-rules \
+ --enable-keygen \
+ --enable-certgen \
+ --disable-stacksize \
+ --disable-ntru \
+ --enable-filesystem \
+ --enable-inline \
+ --disable-oldtls \
+ --disable-valgrind \
+ \
+ $(use_enable small smallcache) \
+ $(use_enable big bigcache) \
+ $(use_enable huge hugecache) \
+ \
+ $(use_enable aes) \
+ $(use_enable aes-gcm aesgcm) \
+ $(use_enable aes-ccm aesccm) \
+ $(use_enable aes-ni aesni) \
+ $(use_enable arc4) \
+ $(use_enable asn) \
+ $(use_enable blake2) \
+ $(use_enable camellia) \
+ $(use_enable coding) \
+ $(use_enable dh) \
+ $(use_enable dsa) \
+ $(use_enable des3) \
+ $(use_enable ecc) \
+ $(use_enable hc128) \
+ $(use_enable md2) \
+ $(use_enable md4) \
+ $(use_enable md5) \
+ $(use_enable nullcipher) \
+ $(use_enable psk) \
+ $(use_enable leanpsk) \
+ $(use_enable rabbit) \
+ $(use_enable ripemd) \
+ $(use_enable rsa) \
+ $(use_enable sha) \
+ $(use_enable sha512) \
+ \
+ $(use_enable ocsp) \
+ $(use_enable crl) \
+ $(use_enable crl-monitor) \
+ $(use_enable savesession) \
+ $(use_enable savecert) \
+ $(use_enable sessioncerts) \
+ $(use_enable testcert) \
+ \
+ $(use_enable debug) \
+ $(use_enable errorstrings) \
+ $(use_enable memory) \
+ \
+ $(use_enable dtls) \
+ $(use_enable examples) \
+ $(use_enable extra opensslextra) \
+ $(use_enable fortress) \
+ $(use_enable ipv6) \
+ $(use_enable httpd webserver) \
+ $(use_enable mcapi) \
+ $(use_enable pwdbased) \
+ $(use_enable sni) \
+ $(use_enable sniffer) \
+ $(use_enable static-libs static) \
+ $(use_with zlib libz) \
+ $(use_enable cyassl-hardening gcc-hardening) \
+ "${myconf[@]}"
+}
+
+src_test() {
+ "${S}"/tests/unit
+ "${S}"/ctaocrypt/benchmark/benchmark
+}
+
+src_install() {
+ default
+
+ mv "${D}"/usr/share/doc/"${PN}"/* \
+ "${D}"/usr/share/doc/"${P}"/
+ rmdir "${D}"/usr/share/doc/"${PN}"/
+}
diff --git a/net-libs/cyassl/metadata.xml b/net-libs/cyassl/metadata.xml
index 935a6dbcfcc7..d57493191e40 100644
--- a/net-libs/cyassl/metadata.xml
+++ b/net-libs/cyassl/metadata.xml
@@ -6,30 +6,52 @@
<name>Anthony G. Basile</name>
</maintainer>
<use>
+ <flag name="small">Choose small cache size (excludes big or huge)</flag>
+ <flag name="big">Choose big cache size (excludes small or huge)</flag>
+ <flag name="huge">Choose big cache size (excludes small or big)</flag>
+ <flag name="aes">Enable AES cipher support</flag>
<flag name="aes-gcm">Enable AES Galois/Counter mode</flag>
- <flag name="aes-ccm">Eanble AES Counter with CBC-MAC mode </flag>
+ <flag name="aes-ccm">Eanble AES Counter with CBC-MAC mode</flag>
<flag name="aes-ni">Enable Intel AES instruction support</flag>
- <flag name="camellia">Enable Camellia-CBC cipher support </flag>
- <!-- add this when ecc is fixed
+ <flag name="arc4">Enable ARC4 cipher support</flag>
+ <flag name="asn">Enable ASN cipher support</flag>
+ <flag name="blake2">Enable CyaSSL BLAKE2 support</flag>
+ <flag name="camellia">Enable Camellia-CBC cipher support</flag>
+ <flag name="coding">Enable Coding base 16/64</flag>
+ <flag name="dh">Enable DH cipher support</flag>
+ <flag name="dsa">Enable DSA cipher support</flag>
+ <flag name="des3">Enable triple DES support</flag>
<flag name="ecc">Enable Elliptic Curve support</flag>
- -->
<flag name="hc128">Enable HC-128 support</flag>
<flag name="md2">Enable MD2 support</flag>
+ <flag name="md4">Enable MD4 support</flag>
+ <flag name="md5">Enable MD5 support</flag>
+ <flag name="nullcipher">Enable nullcipher support</flag>
<flag name="psk">Enable Pre-Shared Key support</flag>
+ <flag name="leanpsk">Enable lean PSK support (requires psk)</flag>
+ <flag name="rabbit">Enable RABBIT cipher support</flag>
<flag name="ripemd">Enable RIPEMD-160 support</flag>
+ <flag name="rsa">Enable RSA cihper support</flag>
+ <flag name="sha">Enable SHA cipher support</flag>
<flag name="sha512">Enable SHA-160 support</flag>
- <flag name="small">Choose small cache size (excludes big or huge)</flag>
- <flag name="big">Choose big cache size (excludes small or huge)</flag>
- <flag name="huge">Choose big cache size (excludes small or big)</flag>
- <flag name="dtls">Enable datagram TLS</flag>
- <flag name="httpd">Enable features for yaSSL web server</flag>
<flag name="ocsp">Enable Online Certificate Status Protocol</flag>
<flag name="crl">Enable Certificate Revocation List</flag>
<flag name="crl-monitor">Enable Certificate Revocation List Directory Monitoring</flag>
+ <flag name="savesession">Support session saving</flag>
+ <flag name="savecert">Support certificate saving</flag>
<flag name="sessioncerts">Store session certificates</flag>
+ <flag name="testcert">Enable certificate testing</flag>
+ <flag name="errorstrings">Enable error strings table</flag>
+ <flag name="memory">Enable memory callbacks</flag>
+ <flag name="dtls">Enable datagram TLS (must be disabled for tests)</flag>
+ <flag name="extra">Enable extra OpenSSL API</flag>
+ <flag name="fortress">Enable fortress SSL build (requires extra and SHA512)</flag>
+ <flag name="httpd">Enable features for yaSSL web server</flag>
+ <flag name="mcapi">Enable Microchip API</flag>
+ <flag name="pwdbased">Enable PWDBASED (requires extra)</flag>
+ <flag name="sni">Enable server name indication</flag>
<flag name="sniffer">Allow collection/decryption of SSL traffic</flag>
<flag name="sniffer">Allow collection/decryption of SSL traffic</flag>
- <flag name="testcert">Enable certificate testing</flag>
<flag name="cyassl-hardening">Add hardening flags to CFLAGS/LDFLAGS</flag>
</use>
</pkgmetadata>