summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-12-20 13:48:24 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-12-20 13:48:24 +0000
commiteb51c5a0584c148cf839e6ccff231ddc64557d14 (patch)
tree58da1435c945e606a2163fda956c88bc8102ea2f /net-libs/dslib
parentx86 stable, see bug 435976. Thanks Myckel Habets for testing. (diff)
downloadgentoo-2-eb51c5a0584c148cf839e6ccff231ddc64557d14.tar.gz
gentoo-2-eb51c5a0584c148cf839e6ccff231ddc64557d14.tar.bz2
gentoo-2-eb51c5a0584c148cf839e6ccff231ddc64557d14.zip
Version bump to latest.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 8EEE3BE8)
Diffstat (limited to 'net-libs/dslib')
-rw-r--r--net-libs/dslib/ChangeLog7
-rw-r--r--net-libs/dslib/dslib-3.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/net-libs/dslib/ChangeLog b/net-libs/dslib/ChangeLog
index 22f26730ffac..7741a09f07c6 100644
--- a/net-libs/dslib/ChangeLog
+++ b/net-libs/dslib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/dslib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/dslib/ChangeLog,v 1.13 2012/11/30 09:34:35 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/dslib/ChangeLog,v 1.14 2012/12/20 13:48:24 scarabeus Exp $
+
+*dslib-3.0 (20 Dec 2012)
+
+ 20 Dec 2012; Tomáš Chvátal <scarabeus@gentoo.org> +dslib-3.0.ebuild:
+ Version bump to latest.
*dslib-2.1.2 (30 Nov 2012)
diff --git a/net-libs/dslib/dslib-3.0.ebuild b/net-libs/dslib/dslib-3.0.ebuild
new file mode 100644
index 000000000000..0935914766e8
--- /dev/null
+++ b/net-libs/dslib/dslib-3.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/dslib/dslib-3.0.ebuild,v 1.1 2012/12/20 13:48:24 scarabeus Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="*"
+
+inherit distutils
+
+DESCRIPTION="Library to access Czech eGov system \"Datove schranky\""
+HOMEPAGE="http://labs.nic.cz/page/969/datovka/"
+SRC_URI="http://www.nic.cz/public_media/datove_schranky/releases//src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-python/pyasn1
+ dev-python/pyopenssl
+ >=dev-python/sudsds-1.0.1
+"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 "${WORKDIR}"
+}