summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2005-04-16 13:14:40 +0000
committerJoseph Jezak <josejx@gentoo.org>2005-04-16 13:14:40 +0000
commit18bd92cc7ef6f624565a010e2459315ebb3f6d2a (patch)
tree2c59e869a24ee1c6391864aa31d050284ab1841a /net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild
parentStable on x86. (diff)
downloadgentoo-2-18bd92cc7ef6f624565a010e2459315ebb3f6d2a.tar.gz
gentoo-2-18bd92cc7ef6f624565a010e2459315ebb3f6d2a.tar.bz2
gentoo-2-18bd92cc7ef6f624565a010e2459315ebb3f6d2a.zip
Updated build to mozilla 1.7.6-r1 to fix compilation bugs, kept the same version # as it doesn't make sense to force users to recompile.
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild')
-rw-r--r--net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild100
1 files changed, 83 insertions, 17 deletions
diff --git a/net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild b/net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild
index b876f326cc8c..5e429c345818 100644
--- a/net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild
+++ b/net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild
@@ -1,38 +1,45 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild,v 1.3 2005/03/23 16:18:40 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gecko-sdk/gecko-sdk-1.7.5.ebuild,v 1.4 2005/04/16 13:14:40 josejx Exp $
unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
-inherit flag-o-matic gcc eutils nsplugins mozilla-launcher mozconfig makeedit
+inherit flag-o-matic gcc eutils nsplugins mozilla-launcher mozconfig makeedit multilib
-IUSE=""
+IUSE="java crypt ssl moznomail postgres"
-EMVER="0.89.6"
+EMVER="0.90.2"
IPCVER="1.1.2"
# handle _rc versions
-MY_PV=${PV/_alpha/a} # handle alpha
-MY_PV=${MY_PV/_beta/b} # handle beta
-MY_PV=${MY_PV/_rc/rc} # handle rc
+MY_PV="1.7.6"
-DESCRIPTION="Mozilla Application Suite - web browser, email, HTML editor, IRC"
+DESCRIPTION="Gecko Engine SDK"
HOMEPAGE="http://www.mozilla.org"
-SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla${MY_PV}/source/mozilla-source-${MY_PV}.tar.bz2"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/mozilla/releases/mozilla${MY_PV}/source/mozilla-source-${MY_PV}.tar.bz2
+ crypt? ( !moznomail? (
+ http://www.mozilla-enigmail.org/downloads/src/ipc-${IPCVER}.tar.gz
+ http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz
+ ) )"
-KEYWORDS="x86 ppc amd64"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86"
SLOT="0"
LICENSE="MPL-1.1 NPL-1.1"
# xrender.pc appeared for the first time in xorg-x11-6.7.0-r2
# and is required to build with support for cairo. #71504
-RDEPEND="
+RDEPEND="java? ( virtual/jre )
mozsvg? (
>=x11-base/xorg-x11-6.7.0-r2
x11-libs/cairo
- )"
+ )
+ crypt? ( !moznomail? ( >=app-crypt/gnupg-1.2.1 ) )
+ >=www-client/mozilla-launcher-1.28"
DEPEND="${RDEPEND}
- dev-lang/perl"
+ ~sys-devel/autoconf-2.13
+ java? ( >=dev-java/java-config-0.2.0 )
+ dev-lang/perl
+ pgsql? ( >=dev-db/postgresql-7.2.0 )"
S="${WORKDIR}/mozilla"
@@ -50,7 +57,7 @@ src_unpack() {
fi
# Fix stack growth logic
- epatch ${PORTDIR}/www-client/mozilla/files/mozilla-${PV}-stackgrowth.patch
+ epatch ${PORTDIR}/www-client/mozilla/files/mozilla-stackgrowth.patch
# Fix logic error when using RAW target
# <azarah@gentoo.org> (23 Feb 2003)
@@ -67,10 +74,24 @@ src_unpack() {
# Patch for newer versions of cairo ( bug #80301)
if has_version '>=x11-libs/cairo-0.3.0'; then
- epatch ${FILESDIR}/svg-cairo-0.3.0-fix.patch
+ epatch ${PORTDIR}/www-client/mozilla/files/svg-cairo-0.3.0-fix.patch
fi
+ # Fix scripts that call for /usr/local/bin/perl #51916
+ ebegin "Patching smime to call perl from /usr/bin"
+ sed -i -e '1s,usr/local/bin,usr/bin,' security/nss/cmd/smimetools/smime
+ eend || die "sed failed"
+
WANT_AUTOCONF=2.1 autoconf || die "WANT_AUTOCONF failed"
+
+ # Unpack the enigmail plugin
+ if use crypt && ! use moznomail; then
+ for x in ipc enigmail; do
+ mv ${WORKDIR}/${x} ${S}/extensions || die "mv failed"
+ cd ${S}/extensions/${x} || die "cd failed"
+ makemake # from mozilla.eclass
+ done
+ fi
}
src_compile() {
@@ -94,13 +115,14 @@ src_compile() {
mozconfig_use_extension gnome gnomevfs
mozconfig_use_extension !moznoirc irc
mozconfig_use_extension mozxmlterm xmlterm
+ mozconfig_use_extension postgres sql
mozconfig_use_enable mozcalendar calendar
mozconfig_use_enable ldap
mozconfig_use_enable ldap ldap-experimental
mozconfig_use_enable mozsvg svg
mozconfig_use_enable mozsvg svg-renderer-cairo
- mozconfig_annotate '' --prefix=/usr/lib/mozilla
- mozconfig_annotate '' --with-default-mozilla-five-home=/usr/lib/mozilla
+ mozconfig_annotate '' --prefix=/usr/$(get_libdir)/mozilla
+ mozconfig_annotate '' --with-default-mozilla-five-home=/usr/$(get_libdir)/mozilla
if use moznomail && ! use mozcalendar; then
mozconfig_annotate "+moznomail -mozcalendar" --disable-mailnews
@@ -112,6 +134,12 @@ src_compile() {
# Finalize and report settings
mozconfig_final
+ if use postgres ; then
+ export MOZ_ENABLE_PGSQL=1
+ export MOZ_PGSQL_INCLUDES=/usr/include
+ export MOZ_PGSQL_LIBS=/usr/$(get_libdir)
+ fi
+
####################################
#
# Configure and build Mozilla
@@ -119,6 +147,7 @@ src_compile() {
####################################
# ./configure picks up the mozconfig stuff
+ CC="$(tc-getCC)" CXX="$(tc-getCXX)" LD="$(tc-getLD)" \
./configure || die "configure failed"
# This removes extraneous CFLAGS from the Makefiles to reduce RAM
@@ -126,6 +155,43 @@ src_compile() {
edit_makefiles
emake || die "emake failed"
+
+ ####################################
+ #
+ # Build Mozilla NSS
+ #
+ ####################################
+
+ # Build the NSS/SSL support
+ if use ssl; then
+ einfo "Building Mozilla NSS..."
+
+ # Fix #include problem
+ cd ${S}/security/coreconf || die "cd coreconf failed"
+ echo 'INCLUDES += -I$(DIST)/include/nspr -I$(DIST)/include/dbm'\
+ >>headers.mk
+ emake -j1 || die "make security headers failed"
+
+ cd ${S}/security/nss || die "cd nss failed"
+ emake -j1 moz_import || die "make moz_import failed"
+ emake -j1 || die "make nss failed"
+ fi
+
+ ####################################
+ #
+ # Build Enigmail plugin
+ #
+ ####################################
+
+ # Build the enigmail plugin
+ if use crypt && ! use moznomail; then
+ einfo "Building Enigmail plugin..."
+ cd ${S}/extensions/ipc || die "cd ipc failed"
+ emake || die "make ipc failed"
+
+ cd ${S}/extensions/enigmail || die "cd enigmail failed"
+ emake || die "make enigmail failed"
+ fi
}
src_install() {