summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-03-18 21:15:43 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-03-18 21:15:43 +0000
commit036bd44363132ddd57c079231e1101469e226728 (patch)
tree0016cb90defab7a2c0bfe97f72a024013ee6c8a0 /net-libs/gloox/gloox-0.9.9.4.ebuild
parentAdded ~ppc wrt bug 204813 (diff)
downloadgentoo-2-036bd44363132ddd57c079231e1101469e226728.tar.gz
gentoo-2-036bd44363132ddd57c079231e1101469e226728.tar.bz2
gentoo-2-036bd44363132ddd57c079231e1101469e226728.zip
Version bump wrt bug #213404 thanks to Steffen Stramm for the new ebuild and David Watzke for the patch
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs/gloox/gloox-0.9.9.4.ebuild')
-rw-r--r--net-libs/gloox/gloox-0.9.9.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-libs/gloox/gloox-0.9.9.4.ebuild b/net-libs/gloox/gloox-0.9.9.4.ebuild
new file mode 100644
index 000000000000..7dfddc0d035a
--- /dev/null
+++ b/net-libs/gloox/gloox-0.9.9.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-0.9.9.4.ebuild,v 1.1 2008/03/18 21:15:42 jokey Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gnutls idn ssl zlib"
+
+DEPEND="idn? ( >=net-dns/libidn-0.5.0 )
+ gnutls? ( >=net-libs/gnutls-1.2.0 )
+ ssl? ( >=dev-libs/openssl-0.9.8 )
+ zlib? ( >=sys-libs/zlib-1.2.3 )"
+
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-res_query-check.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_with idn libidn) \
+ $(use_with gnutls gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with zlib zlib) \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}