summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-01-31 21:33:45 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-01-31 21:33:45 +0000
commitae5fe4d982b85ba4dff36c1355bd13a6c4ee6254 (patch)
tree1500247213cf21314730e27d4091ba2cb43519e0 /net-libs/gloox/gloox-1.0_beta4.ebuild
parentUpdate copyright years. (diff)
downloadgentoo-2-ae5fe4d982b85ba4dff36c1355bd13a6c4ee6254.tar.gz
gentoo-2-ae5fe4d982b85ba4dff36c1355bd13a6c4ee6254.tar.bz2
gentoo-2-ae5fe4d982b85ba4dff36c1355bd13a6c4ee6254.zip
Fix glibc 2.8 build, thanks to Gene Seto for the required patch. Version bump as well
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gloox/gloox-1.0_beta4.ebuild')
-rw-r--r--net-libs/gloox/gloox-1.0_beta4.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/gloox/gloox-1.0_beta4.ebuild b/net-libs/gloox/gloox-1.0_beta4.ebuild
new file mode 100644
index 000000000000..54b6ac9a2e7e
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0_beta4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gloox/gloox-1.0_beta4.ebuild,v 1.1 2009/01/31 21:33:45 jokey Exp $
+
+EAPI=2
+
+inherit autotools
+
+MY_P=${P/_/-}
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gnutls idn ssl zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_with idn libidn) \
+ $(use_with gnutls gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with zlib zlib) \
+ || die "econf failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}