summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-15 23:03:04 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-15 23:03:04 +0000
commit0a6086cbf4a5ff3a0c1985659c68b79d753946c8 (patch)
tree6c81b79f28f812433d1f6ccedde6d1bec8a81dbc /net-libs/gnutls
parentVersion bump (bug #431572). (diff)
downloadgentoo-2-0a6086cbf4a5ff3a0c1985659c68b79d753946c8.tar.gz
gentoo-2-0a6086cbf4a5ff3a0c1985659c68b79d753946c8.tar.bz2
gentoo-2-0a6086cbf4a5ff3a0c1985659c68b79d753946c8.zip
Version bump; disable TPM support for now until it can be tested by somebody with a TPM device.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/ChangeLog8
-rw-r--r--net-libs/gnutls/gnutls-3.1.0.ebuild114
2 files changed, 121 insertions, 1 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index 1610f6c1ee40..f9074565972e 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.375 2012/08/05 02:43:59 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.376 2012/08/15 23:03:04 flameeyes Exp $
+
+*gnutls-3.1.0 (15 Aug 2012)
+
+ 15 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +gnutls-3.1.0.ebuild:
+ Version bump; disable TPM support for now until it can be tested by somebody
+ with a TPM device.
*gnutls-3.0.22 (05 Aug 2012)
diff --git a/net-libs/gnutls/gnutls-3.1.0.ebuild b/net-libs/gnutls/gnutls-3.1.0.ebuild
new file mode 100644
index 000000000000..abf63dfa5524
--- /dev/null
+++ b/net-libs/gnutls/gnutls-3.1.0.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-3.1.0.ebuild,v 1.1 2012/08/15 23:03:04 flameeyes Exp $
+
+EAPI=4
+
+inherit autotools libtool eutils
+
+DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+
+if [[ "${PV}" == *pre* ]]; then
+ SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
+fi
+
+# LGPL-3 for libgnutls library and GPL-3 for libgnutls-extra library.
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+cxx doc examples guile nls pkcs11 static-libs test zlib"
+
+RDEPEND=">=dev-libs/libtasn1-0.3.4
+ >=dev-libs/nettle-2.5[gmp]
+ sys-devel/autogen
+ guile? ( >=dev-scheme/guile-1.8[networking] )
+ nls? ( virtual/libintl )
+ pkcs11? ( >=app-crypt/p11-kit-0.11 )
+ zlib? ( >=sys-libs/zlib-1.2.3.1 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )
+ test? ( app-misc/datefudge )"
+
+S=${WORKDIR}/${P%_pre*}
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS doc/TODO )
+
+src_prepare() {
+ local dir file
+
+ # tests/suite directory is not distributed.
+ sed -i \
+ -e ':AC_CONFIG_FILES(\[tests/suite/Makefile\]):d' \
+ -e '/^AM_INIT_AUTOMAKE/s/-Werror//' \
+ configure.ac || die
+
+ sed -i \
+ -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' \
+ doc/Makefile.am || die
+
+ for dir in m4 gl/m4; do
+ rm -f "${dir}/lt"* "${dir}/libtool.m4"
+ done
+ find . -name ltmain.sh -exec rm {} \;
+
+ # use system libopts
+ sed -i -e "/^enable_local_libopts/s/yes/no/" configure.ac || die
+
+ # force regeneration of autogen-ed files
+ for file in $(grep -l AutoGen-ed src/*.c) ; do
+ rm src/$(basename ${file} .c).{c,h} || die
+ done
+
+ # support user patches
+ epatch_user
+
+ eautoreconf
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+}
+
+src_configure() {
+ # TPM needs to be tested before being enabled
+ econf \
+ --htmldir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ --disable-silent-rules \
+ --disable-valgrind-tests \
+ $(use_enable cxx) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable doc gtk-doc-pdf) \
+ $(use_enable guile) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_with pkcs11 p11-kit) \
+ $(use_with zlib) \
+ ${myconf} \
+ --without-tpm
+}
+
+src_test() {
+ # let it build in parallel
+ emake check
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps}
+ dohtml doc/gnutls.html
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c
+ fi
+}