summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-09 23:26:12 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-09 23:26:12 +0000
commit3a666e68ad67ade35044e4b3073d804158349ce0 (patch)
tree206574a15cf078b72dcd39406ee1035bce11ba3b /net-libs/gnutls
parentDelete older ebuilds. (diff)
downloadgentoo-2-3a666e68ad67ade35044e4b3073d804158349ce0.tar.gz
gentoo-2-3a666e68ad67ade35044e4b3073d804158349ce0.tar.bz2
gentoo-2-3a666e68ad67ade35044e4b3073d804158349ce0.zip
Version bump.
(Portage version: 2.2.0_alpha26_p10/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/gnutls')
-rw-r--r--net-libs/gnutls/ChangeLog10
-rw-r--r--net-libs/gnutls/gnutls-2.11.7.ebuild114
2 files changed, 123 insertions, 1 deletions
diff --git a/net-libs/gnutls/ChangeLog b/net-libs/gnutls/ChangeLog
index a70f3d8d8b30..f38a82b14566 100644
--- a/net-libs/gnutls/ChangeLog
+++ b/net-libs/gnutls/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/gnutls
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.294 2011/02/28 23:10:11 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/ChangeLog,v 1.295 2011/03/09 23:26:12 arfrever Exp $
+
+*gnutls-2.11.7 (09 Mar 2011)
+
+ 09 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -gnutls-2.10.2.ebuild, -gnutls-2.10.2-r1.ebuild, -gnutls-2.10.3.ebuild,
+ -gnutls-2.11.4.ebuild, -gnutls-2.11.4-r1.ebuild, -gnutls-2.11.5.ebuild,
+ +gnutls-2.11.7.ebuild:
+ Version bump.
28 Feb 2011; Brent Baude <ranger@gentoo.org> gnutls-2.10.4.ebuild:
Marking gnutls-2.10.4 ppc64 for bug 352744
diff --git a/net-libs/gnutls/gnutls-2.11.7.ebuild b/net-libs/gnutls/gnutls-2.11.7.ebuild
new file mode 100644
index 000000000000..dc9874d368cf
--- /dev/null
+++ b/net-libs/gnutls/gnutls-2.11.7.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gnutls/gnutls-2.11.7.ebuild,v 1.1 2011/03/09 23:26:12 arfrever Exp $
+
+EAPI="3"
+
+inherit autotools libtool
+
+DESCRIPTION="A TLS 1.2 and SSL 3.0 implementation for the GNU project"
+HOMEPAGE="http://www.gnutls.org/"
+
+if [[ "${PV}" == *pre* ]]; then
+ SRC_URI="http://daily.josefsson.org/${P%.*}/${P%.*}-${PV#*pre}.tar.gz"
+else
+ MINOR_VERSION="${PV#*.}"
+ MINOR_VERSION="${MINOR_VERSION%.*}"
+ if [[ $((MINOR_VERSION % 2)) == 0 ]]; then
+ #SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+ else
+ SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2"
+ fi
+ unset MINOR_VERSION
+fi
+
+# GPL-3 for the gnutls-extras library and LGPL for the gnutls library.
+LICENSE="LGPL-2.1 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="bindist +cxx doc examples guile lzo +nettle nls test zlib"
+
+# lib/m4/hooks.m4 says that GnuTLS uses a fork of PaKChoiS.
+RDEPEND=">=dev-libs/libtasn1-0.3.4
+ nls? ( virtual/libintl )
+ guile? ( >=dev-scheme/guile-1.8[networking] )
+ nettle? ( >=dev-libs/nettle-2.1[gmp] )
+ !nettle? ( >=dev-libs/libgcrypt-1.4.0 )
+ zlib? ( >=sys-libs/zlib-1.1 )
+ !bindist? ( lzo? ( >=dev-libs/lzo-2 ) )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ doc? ( dev-util/gtk-doc )
+ nls? ( sys-devel/gettext )
+ test? ( app-misc/datefudge )"
+
+S="${WORKDIR}/${P%_pre*}"
+
+pkg_setup() {
+ if use lzo && use bindist; then
+ ewarn "lzo support is disabled for binary distribution of GnuTLS due to licensing issues."
+ fi
+}
+
+src_prepare() {
+ # tests/suite directory is not distributed.
+ sed -e 's|AC_CONFIG_FILES(\[tests/suite/Makefile\])|:|' -i configure.ac
+
+ sed -e 's/imagesdir = $(infodir)/imagesdir = $(htmldir)/' -i doc/Makefile.am
+
+ local dir
+ for dir in m4 lib/m4 libextra/m4; do
+ rm -f "${dir}/lt"* "${dir}/libtool.m4"
+ done
+ find . -name ltmain.sh -exec rm {} \;
+ for dir in . lib libextra; do
+ pushd "${dir}" > /dev/null
+ eautoreconf
+ popd > /dev/null
+ done
+
+ # Use sane .so versioning on FreeBSD.
+ elibtoolize
+}
+
+src_configure() {
+ local myconf
+ use bindist && myconf="--without-lzo" || myconf="$(use_with lzo)"
+ [[ "${VALGRIND_TESTS}" != "1" ]] && myconf+=" --disable-valgrind-tests"
+
+ econf --htmldir=/usr/share/doc/${P}/html \
+ $(use_enable cxx) \
+ $(use_enable doc gtk-doc) \
+ $(use_enable guile) \
+ $(use_with !nettle libgcrypt) \
+ $(use_enable nls) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_test() {
+ if has_version dev-util/valgrind && [[ "${VALGRIND_TESTS}" != "1" ]]; then
+ elog
+ elog "You can set VALGRIND_TESTS=\"1\" to enable Valgrind tests."
+ elog
+ fi
+
+ default
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS doc/TODO || die "dodoc failed"
+
+ if use doc; then
+ dodoc doc/gnutls.{pdf,ps} || die "dodoc failed"
+ dohtml doc/gnutls.html || die "dohtml failed"
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc doc/examples/*.c || die "dodoc failed"
+ fi
+}