summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-03-23 00:32:31 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-03-23 00:32:31 +0000
commit833d3a37eddc66f92c6455d5b5e9eff10a752822 (patch)
treefec6f65f08c8d7f96298b18b5cc6f925d69eab69 /net-libs/gtk-vnc
parentNew version for GNOME-2.22. Adds a GIO filechooser backend until gtk+-2.14 it... (diff)
downloadgentoo-2-833d3a37eddc66f92c6455d5b5e9eff10a752822.tar.gz
gentoo-2-833d3a37eddc66f92c6455d5b5e9eff10a752822.tar.bz2
gentoo-2-833d3a37eddc66f92c6455d5b5e9eff10a752822.zip
bump to 0.3.4, fix dependencies a bit, bug #211958
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs/gtk-vnc')
-rw-r--r--net-libs/gtk-vnc/ChangeLog7
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.3.4.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index dee661c331a9..43cb4dae4cf8 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.6 2008/02/26 12:15:46 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.7 2008/03/23 00:32:31 eva Exp $
+
+*gtk-vnc-0.3.4 (23 Mar 2008)
+
+ 23 Mar 2008; Gilles Dartiguelongue <eva@gentoo.org> +gtk-vnc-0.3.4.ebuild:
+ bump to 0.3.4, fix dependencies a bit, bug #211958
*gtk-vnc-0.3.3 (26 Feb 2008)
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.3.4.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.3.4.ebuild
new file mode 100644
index 000000000000..a29deb27551c
--- /dev/null
+++ b/net-libs/gtk-vnc/gtk-vnc-0.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.3.4.ebuild,v 1.1 2008/03/23 00:32:31 eva Exp $
+
+inherit gnome2
+
+DESCRIPTION="VNC viewer widget for GTK."
+HOMEPAGE="http://gtk-vnc.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug python opengl"
+
+# what shall we do about libview
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=net-libs/gnutls-1.4
+ python? ( >=dev-python/pygtk-2 )
+ opengl? ( >=x11-libs/gtkglext-1.2 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_with python)
+ $(use_with opengl gtkglext)
+ --with-coroutine=gthread
+ --without-libview"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}