summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-06-10 18:02:51 +0000
committerMichał Górny <mgorny@gentoo.org>2014-06-10 18:02:51 +0000
commitd5d0898b898afd693eefe3bc863b803cab115d22 (patch)
treeacadbf8abdc9061c0cddb34e21cc1f2008f3d25e /net-libs/gupnp-igd
parentEnable multilib support. (diff)
downloadgentoo-2-d5d0898b898afd693eefe3bc863b803cab115d22.tar.gz
gentoo-2-d5d0898b898afd693eefe3bc863b803cab115d22.tar.bz2
gentoo-2-d5d0898b898afd693eefe3bc863b803cab115d22.zip
Enable multilib support.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs/gupnp-igd')
-rw-r--r--net-libs/gupnp-igd/ChangeLog7
-rw-r--r--net-libs/gupnp-igd/gupnp-igd-0.2.3-r1.ebuild112
2 files changed, 118 insertions, 1 deletions
diff --git a/net-libs/gupnp-igd/ChangeLog b/net-libs/gupnp-igd/ChangeLog
index fd6fe07c79fe..8bbc377f51fc 100644
--- a/net-libs/gupnp-igd/ChangeLog
+++ b/net-libs/gupnp-igd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gupnp-igd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.56 2014/04/26 06:35:33 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/ChangeLog,v 1.57 2014/06/10 18:02:51 mgorny Exp $
+
+*gupnp-igd-0.2.3-r1 (10 Jun 2014)
+
+ 10 Jun 2014; Michał Górny <mgorny@gentoo.org> +gupnp-igd-0.2.3-r1.ebuild:
+ Enable multilib support.
26 Apr 2014; Pacho Ramos <pacho@gentoo.org> gupnp-igd-0.2.2-r1.ebuild:
Move to testing in some arches due other gupnp dependencies
diff --git a/net-libs/gupnp-igd/gupnp-igd-0.2.3-r1.ebuild b/net-libs/gupnp-igd/gupnp-igd-0.2.3-r1.ebuild
new file mode 100644
index 000000000000..f9a6c3f236f4
--- /dev/null
+++ b/net-libs/gupnp-igd/gupnp-igd-0.2.3-r1.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gupnp-igd/gupnp-igd-0.2.3-r1.ebuild,v 1.1 2014/06/10 18:02:51 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+AUTOTOOLS_AUTORECONF=true
+
+inherit eutils gnome.org multilib-minimal python-r1
+
+DESCRIPTION="Library to handle UPnP IGD port mapping for GUPnP"
+HOMEPAGE="http://gupnp.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+introspection python"
+
+RDEPEND="
+ >=dev-libs/glib-2.26:2[${MULTILIB_USEDEP}]
+ net-libs/gssdp[${MULTILIB_USEDEP}]
+ >=net-libs/gupnp-0.18[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-0.10 )
+ python? (
+ >=dev-libs/gobject-introspection-0.10
+ >=dev-python/pygobject-2.16:2[${PYTHON_USEDEP}]
+ )"
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+# The only existing test is broken
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.1.11-disable_static_modules.patch
+)
+
+src_prepare() {
+ # Python bindings are built/installed manually.
+ if use python; then
+ sed -e "/PYTHON_SUBDIR =/s/ python//" -i Makefile.am Makefile.in || die
+ fi
+}
+
+multilib_src_configure() {
+ local myconf=(
+ --disable-static
+ --disable-gtk-doc
+ $(multilib_native_use_enable introspection)
+ # python is built separately
+ --disable-python
+ )
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}"
+
+ if multilib_is_native_abi; then
+ ln -s "${S}"/doc/html doc/html || die
+
+ python_configure() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ ECONF_SOURCE=${S} \
+ econf "${myconf[@]}" \
+ --enable-python
+ }
+
+ python_parallel_foreach_impl python_configure
+ fi
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use python; then
+ local native_builddir=${BUILD_DIR}
+
+ python_compile() {
+ emake -C "${BUILD_DIR}"/python \
+ VPATH="${S}/python:${native_builddir}/python" \
+ igd_la_LIBADD="\$(PYGUPNP_IGD_LIBS) ${native_builddir}/libgupnp-igd/libgupnp-igd-1.0.la"
+ }
+
+ python_foreach_impl python_compile
+ fi
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi && use python; then
+ local native_builddir=${BUILD_DIR}
+
+ python_install() {
+ emake -C "${BUILD_DIR}"/python \
+ VPATH="${S}/python:${native_builddir}/python" \
+ DESTDIR="${D}" install
+ }
+
+ python_foreach_impl python_install
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files
+}