summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2012-10-08 19:01:54 +0000
committerRick Farina <zerochaos@gentoo.org>2012-10-08 19:01:54 +0000
commit9468e57ad449d86684dd7b847489ab8e60e0406b (patch)
tree14044367835c03e9ef9d11650011f601b2153e29 /net-libs/libbtbb
parentRemove unneeded libtool files (diff)
downloadgentoo-2-9468e57ad449d86684dd7b847489ab8e60e0406b.tar.gz
gentoo-2-9468e57ad449d86684dd7b847489ab8e60e0406b.tar.bz2
gentoo-2-9468e57ad449d86684dd7b847489ab8e60e0406b.zip
bump and add wireshark plugin
(Portage version: 2.1.11.24/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libbtbb')
-rw-r--r--net-libs/libbtbb/ChangeLog8
-rw-r--r--net-libs/libbtbb/libbtbb-2012.10.1.ebuild60
-rw-r--r--net-libs/libbtbb/metadata.xml3
3 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/libbtbb/ChangeLog b/net-libs/libbtbb/ChangeLog
index 176cd420cf49..fe8c965cd67a 100644
--- a/net-libs/libbtbb/ChangeLog
+++ b/net-libs/libbtbb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libbtbb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libbtbb/ChangeLog,v 1.7 2012/07/11 21:42:13 zerochaos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libbtbb/ChangeLog,v 1.8 2012/10/08 19:01:54 zerochaos Exp $
+
+*libbtbb-2012.10.1 (08 Oct 2012)
+
+ 08 Oct 2012; Rick Farina <zerochaos@gentoo.org> +libbtbb-2012.10.1.ebuild,
+ metadata.xml:
+ bump and add wireshark plugin
11 Jul 2012; Rick Farina <zerochaos@gentoo.org>
-files/wireshark-1.8-btbb.patch, -libbtbb-0.8-r1.ebuild, libbtbb-0.8.ebuild,
diff --git a/net-libs/libbtbb/libbtbb-2012.10.1.ebuild b/net-libs/libbtbb/libbtbb-2012.10.1.ebuild
new file mode 100644
index 000000000000..a21ec964de22
--- /dev/null
+++ b/net-libs/libbtbb/libbtbb-2012.10.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libbtbb/libbtbb-2012.10.1.ebuild,v 1.1 2012/10/08 19:01:54 zerochaos Exp $
+
+EAPI=4
+
+inherit multilib cmake-utils
+
+DESCRIPTION="A library to decode Bluetooth baseband packets"
+HOMEPAGE="http://libbtbb.sourceforge.net/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="http://git.code.sf.net/p/libbtbb/code"
+ SRC_URI=""
+ inherit git-2
+ KEYWORDS=""
+else
+ MY_P=${P/\./-}
+ MY_P=${MY_P/./-R}
+ S=${WORKDIR}/${MY_P}
+ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+wireshark"
+
+RDEPEND="
+ wireshark? (
+ dev-libs/glib
+ >=net-analyzer/wireshark-1.8.3-r1
+ )
+"
+DEPEND="${RDEPEND}
+ wireshark? ( virtual/pkgconfig )"
+
+get_PV() { local pv=$(best_version "$1"); pv=${pv#"$1-"}; echo "${pv%-r[0-9]*}"; }
+
+CMAKE_USE_DIR="${S}"/wireshark/plugins/btbb
+
+src_prepare() {
+ sed -i \
+ -e '/set(CMAKE_INSTALL_LIBDIR/ d' \
+ -e "s:R} N:R}/wireshark/plugins/$(get_PV net-analyzer/wireshark) N:" \
+ ${CMAKE_USE_DIR}/CMakeLists.txt || die
+}
+
+src_compile() {
+ default_src_compile
+ use wireshark && cmake-utils_src_compile
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)
+ dodir /usr/include
+ emake LDCONFIG=true DESTDIR="${D}" INSTALL_DIR="${ED}/usr/$(get_libdir)" INCLUDE_DIR="${ED}/usr/include" install
+
+ use wireshark && cmake-utils_src_install
+}
diff --git a/net-libs/libbtbb/metadata.xml b/net-libs/libbtbb/metadata.xml
index 9cca7a80e628..485953a791ab 100644
--- a/net-libs/libbtbb/metadata.xml
+++ b/net-libs/libbtbb/metadata.xml
@@ -5,4 +5,7 @@
<email>zerochaos@gentoo.org</email>
<name>Rick Farina</name>
</maintainer>
+ <use>
+ <flag name="wireshark">Build the wireshark plugin for bluetooth baseband sniffing</flag>
+ </use>
</pkgmetadata>