summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-05-25 11:30:15 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-05-25 11:30:15 +0000
commitc8627c7d5e587d39a22d456f2734e7d1ca46fae6 (patch)
tree78b789ab3cc8c79d1805ffaa9408fc6c128a248c /net-libs/libesmtp/libesmtp-1.0-r1.ebuild
parentadjust keywords and removed cruft (diff)
downloadgentoo-2-c8627c7d5e587d39a22d456f2734e7d1ca46fae6.tar.gz
gentoo-2-c8627c7d5e587d39a22d456f2734e7d1ca46fae6.tar.bz2
gentoo-2-c8627c7d5e587d39a22d456f2734e7d1ca46fae6.zip
Closes #20199
Diffstat (limited to 'net-libs/libesmtp/libesmtp-1.0-r1.ebuild')
-rw-r--r--net-libs/libesmtp/libesmtp-1.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/libesmtp/libesmtp-1.0-r1.ebuild b/net-libs/libesmtp/libesmtp-1.0-r1.ebuild
new file mode 100644
index 000000000000..fada2d8101e0
--- /dev/null
+++ b/net-libs/libesmtp/libesmtp-1.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libesmtp/libesmtp-1.0-r1.ebuild,v 1.1 2003/05/25 11:30:15 aliz Exp $
+
+
+inherit gcc eutils gnuconfig libtool
+
+IUSE="ssl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="libESMTP is a library that implements the client side of the SMTP protocol"
+SRC_URI="http://www.stafford.uklinux.net/libesmtp/${P}.tar.bz2"
+HOMEPAGE="http://www.stafford.uklinux.net/libesmtp/"
+
+DEPEND=">=sys-devel/libtool-1.4.1
+ ssl? ( >=dev-libs/openssl-0.9.6b )"
+
+RDEPEND=""
+
+SLOT="0"
+LICENSE="LGPL-2.1 GPL-2"
+KEYWORDS="~x86 ~sparc ~ppc"
+
+src_compile() {
+ gnuconfig_update
+
+ elibtoolize
+
+ local myconf
+
+ use ssl || myconf="${myconf} --without-openssl"
+
+ if [ "`gcc-major-version`" -eq "2" ]; then
+ myconf="${myconf} --disable-isoc"
+ fi
+
+ ./configure --prefix=/usr \
+ --enable-all \
+ --enable-threads \
+ ${myconf} || die "configure failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ make prefix=${D}/usr install || die "make install failed"
+ dodoc AUTHORS COPYING COPYING.GPL INSTALL ChangeLog NEWS Notes README TODO
+ dohtml doc/api.xml
+}
+