summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-10-13 21:08:49 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-10-13 21:08:49 +0000
commitef35b9ae9347cc23e2e8cfb4a9d28cb10f807c7c (patch)
tree96cca827209e209dae3ac1903ce0abb9e496c776 /net-libs/libetpan
parentBrown paper bag fix: a crasher was introduced in 2.8.1, this includes the ups... (diff)
downloadgentoo-2-ef35b9ae9347cc23e2e8cfb4a9d28cb10f807c7c.tar.gz
gentoo-2-ef35b9ae9347cc23e2e8cfb4a9d28cb10f807c7c.tar.bz2
gentoo-2-ef35b9ae9347cc23e2e8cfb4a9d28cb10f807c7c.zip
Version bump. Add ipv6 USE flag.
(Portage version: 2.1.2_pre2-r8)
Diffstat (limited to 'net-libs/libetpan')
-rw-r--r--net-libs/libetpan/ChangeLog7
-rw-r--r--net-libs/libetpan/files/digest-libetpan-0.473
-rw-r--r--net-libs/libetpan/libetpan-0.47.ebuild57
3 files changed, 66 insertions, 1 deletions
diff --git a/net-libs/libetpan/ChangeLog b/net-libs/libetpan/ChangeLog
index 75df3dfa5001..9a384ce6a4dd 100644
--- a/net-libs/libetpan/ChangeLog
+++ b/net-libs/libetpan/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libetpan
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.35 2006/09/21 23:46:22 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/ChangeLog,v 1.36 2006/10/13 21:08:49 ticho Exp $
+
+*libetpan-0.47 (13 Oct 2006)
+
+ 13 Oct 2006; <ticho@gentoo.org> +libetpan-0.47.ebuild:
+ Version bump. Add ipv6 USE flag.
*libetpan-0.46-r1 (21 Sep 2006)
diff --git a/net-libs/libetpan/files/digest-libetpan-0.47 b/net-libs/libetpan/files/digest-libetpan-0.47
new file mode 100644
index 000000000000..2597c26af642
--- /dev/null
+++ b/net-libs/libetpan/files/digest-libetpan-0.47
@@ -0,0 +1,3 @@
+MD5 bdbe010dcd70fa358d7184b998c3228a libetpan-0.47.tar.gz 1013894
+RMD160 4338b50854c73c3fafb0905fc2379f29123d5142 libetpan-0.47.tar.gz 1013894
+SHA256 65e289e2e95bcaac2dcf2d1731a4174293811842ee5fae24cfe3a317a375d032 libetpan-0.47.tar.gz 1013894
diff --git a/net-libs/libetpan/libetpan-0.47.ebuild b/net-libs/libetpan/libetpan-0.47.ebuild
new file mode 100644
index 000000000000..764f68550cfb
--- /dev/null
+++ b/net-libs/libetpan/libetpan-0.47.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libetpan/libetpan-0.47.ebuild,v 1.1 2006/10/13 21:08:49 ticho Exp $
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access."
+HOMEPAGE="http://libetpan.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="berkdb debug gnutls sasl ssl ipv6"
+
+DEPEND="virtual/libc
+ berkdb? ( sys-libs/db )
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )
+ sasl? ( dev-libs/cyrus-sasl )"
+
+src_compile() {
+ local sslconf
+
+ if use ssl; then
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --with-openssl"
+ fi
+ else
+ if use gnutls; then
+ sslconf="--with-gnutls --without-openssl"
+ else
+ sslconf="--without-gnutls --without-openssl"
+ fi
+ fi
+
+ econf \
+ `use_enable debug` \
+ `use_enable berkdb db` \
+ `use_with sasl` \
+ `use_enable ipv6` \
+ ${sslconf} \
+ || die "econf failed"
+
+ # build system is broken, we need -j1 (bug #126848) - Ticho, 2006-05-02
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc NEWS TODO ChangeLog
+}
+
+pkg_postinst() {
+ ewarn "The soname for libetpan has changed after libetpan-0.45."
+ ewarn "If you have upgraded from that or earlier version, it is recommended to run"
+ ewarn "revdep-rebuild to fix any linking errors caused by this change."
+}