summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2013-01-29 12:40:19 +0000
committerMichael Palimaka <kensington@gentoo.org>2013-01-29 12:40:19 +0000
commitb7786d91601a4f85474e1deec0df7b5dfa6fe3cb (patch)
tree02ef28ec3986fbbfdce6c9d8afd1c005b72bf086 /net-libs/libktorrent
parentnitpick: no direct linkage to drm (diff)
downloadgentoo-2-b7786d91601a4f85474e1deec0df7b5dfa6fe3cb.tar.gz
gentoo-2-b7786d91601a4f85474e1deec0df7b5dfa6fe3cb.tar.bz2
gentoo-2-b7786d91601a4f85474e1deec0df7b5dfa6fe3cb.zip
Version bump wrt bug #453676.
(Portage version: 2.1.11.50/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'net-libs/libktorrent')
-rw-r--r--net-libs/libktorrent/ChangeLog10
-rw-r--r--net-libs/libktorrent/libktorrent-1.3.1.ebuild52
2 files changed, 60 insertions, 2 deletions
diff --git a/net-libs/libktorrent/ChangeLog b/net-libs/libktorrent/ChangeLog
index 066d51adbb89..af7f73f01d6a 100644
--- a/net-libs/libktorrent/ChangeLog
+++ b/net-libs/libktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libktorrent
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.46 2012/12/23 11:31:19 maekke Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.47 2013/01/29 12:40:19 kensington Exp $
+
+*libktorrent-1.3.1 (29 Jan 2013)
+
+ 29 Jan 2013; Michael Palimaka <kensington@gentoo.org>
+ +libktorrent-1.3.1.ebuild:
+ Version bump wrt bug #453676.
23 Dec 2012; Markus Meier <maekke@gentoo.org> libktorrent-1.3.0.ebuild:
add ~arm
diff --git a/net-libs/libktorrent/libktorrent-1.3.1.ebuild b/net-libs/libktorrent/libktorrent-1.3.1.ebuild
new file mode 100644
index 000000000000..1275b3c796a0
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-1.3.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.3.1.ebuild,v 1.1 2013/01/29 12:40:19 kensington Exp $
+
+EAPI=5
+
+KDE_SCM="git"
+if [[ ${PV} != 9999* ]]; then
+ inherit versionator
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ KTORRENT_VERSION=$(($(get_major_version)+3)).$(get_version_component_range 2-3 ${MY_PV})
+ MY_P="${PN}-${MY_PV}"
+ KDE_HANDBOOK="optional"
+ KDE_DOC_DIRS="doc"
+
+ KDE_LINGUAS="ar ast be bg bs ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km ku lt lv ms nb nds nl nn oc pl
+ pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr ug uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${KTORRENT_VERSION}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+
+ KEYWORDS="~amd64 ~arm ~ppc ~x86"
+else
+ KEYWORDS=""
+fi
+VIRTUALX_REQUIRED="test"
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent library based on KDE Platform"
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+ dev-libs/libgcrypt
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+ # do not build non-installed example binary
+ sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt || die
+}