summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-07 21:42:02 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-07 21:42:02 +0000
commit8caf407ed98c403ce6525b9fbdcb70539087dfaa (patch)
tree19e017f5da5869b306806187837d270b09eef33c /net-libs/libkvkontakte/libkvkontakte-2.4.1.ebuild
parentDrop mask on sys-apps/hwloc[numa] wrt #381313 (diff)
downloadgentoo-2-8caf407ed98c403ce6525b9fbdcb70539087dfaa.tar.gz
gentoo-2-8caf407ed98c403ce6525b9fbdcb70539087dfaa.tar.bz2
gentoo-2-8caf407ed98c403ce6525b9fbdcb70539087dfaa.zip
Version bump; remove old
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libkvkontakte/libkvkontakte-2.4.1.ebuild')
-rw-r--r--net-libs/libkvkontakte/libkvkontakte-2.4.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/libkvkontakte/libkvkontakte-2.4.1.ebuild b/net-libs/libkvkontakte/libkvkontakte-2.4.1.ebuild
new file mode 100644
index 000000000000..bc9d8a97f1ac
--- /dev/null
+++ b/net-libs/libkvkontakte/libkvkontakte-2.4.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libkvkontakte/libkvkontakte-2.4.1.ebuild,v 1.1 2011/12/07 21:42:02 dilfridge Exp $
+
+EAPI=4
+
+DIGIKAMPN=digikam
+
+KDE_LINGUAS=""
+KDE_MINIMAL="4.7"
+
+CMAKE_MIN_VERSION=2.8
+
+inherit kde4-base
+
+MY_P="${DIGIKAMPN}-${PV/_/-}"
+
+DESCRIPTION="Library for accessing the features of social networking site vkontakte.ru"
+HOMEPAGE="http://www.digikam.org/"
+SRC_URI="mirror://sourceforge/${DIGIKAMPN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+SLOT=4
+
+DEPEND=">=dev-libs/qjson-0.7.0"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}/extra/${PN}
+
+PATCHES=( "${FILESDIR}/${PN}-2.2.0-libdir.patch" )
+
+src_configure() {
+ mycmakeargs=(
+ -DFORCED_UNBUNDLE=ON
+ )
+ kde4-base_src_configure
+}