summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-08-19 11:53:57 +0000
committerCédric Krier <cedk@gentoo.org>2007-08-19 11:53:57 +0000
commitbec4867bf639ecead7f328863b51809b9a0698b5 (patch)
treef1009516de7135b2b07897fc51816699a309b2fb /net-libs/libnfnetlink/libnfnetlink-0.0.30.ebuild
parentMoving dev-python/mod_python to www-apache. (diff)
downloadgentoo-2-bec4867bf639ecead7f328863b51809b9a0698b5.tar.gz
gentoo-2-bec4867bf639ecead7f328863b51809b9a0698b5.tar.bz2
gentoo-2-bec4867bf639ecead7f328863b51809b9a0698b5.zip
Version bump
(Portage version: 2.1.2.11)
Diffstat (limited to 'net-libs/libnfnetlink/libnfnetlink-0.0.30.ebuild')
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-0.0.30.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libnfnetlink/libnfnetlink-0.0.30.ebuild b/net-libs/libnfnetlink/libnfnetlink-0.0.30.ebuild
new file mode 100644
index 000000000000..9ebf5b32a055
--- /dev/null
+++ b/net-libs/libnfnetlink/libnfnetlink-0.0.30.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-0.0.30.ebuild,v 1.1 2007/08/19 11:53:57 cedk Exp $
+
+inherit linux-info
+
+DESCRIPTION="the low-level library for netfilter related kernel/userspace communication"
+HOMEPAGE="http://www.netfilter.org/projects/libnfnetlink/"
+SRC_URI="http://www.netfilter.org/projects/${PN}/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if kernel_is lt 2 6 14 ; then
+ die "${PN} requires at least 2.6.14 kernel version"
+ fi
+
+ #netfilter core team has changed some option names with kernel 2.6.20
+ if kernel_is lt 2 6 20 ; then
+ CONFIG_CHECK="IP_NF_CONNTRACK_NETLINK"
+ else
+ CONFIG_CHECK="NF_CT_NETLINK"
+ ERROR_NF_CT_NETLINK="CONFIG_NF_CT_NETLINK:\t is not set when it should be. You can activate it in the Core Netfilter Configuration"
+ fi
+
+ check_extra_config
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}