summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-02-25 00:43:39 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-02-25 00:43:39 +0000
commit8ab5affdf96142bd33b3fe44a097a716bc014c6e (patch)
treee9baccbee13e1b3bd1d5cedd2106915f168ef500 /net-libs/libnids/libnids-1.18.ebuild
parentMention available documentation, #77309. (diff)
downloadgentoo-2-8ab5affdf96142bd33b3fe44a097a716bc014c6e.tar.gz
gentoo-2-8ab5affdf96142bd33b3fe44a097a716bc014c6e.tar.bz2
gentoo-2-8ab5affdf96142bd33b3fe44a097a716bc014c6e.zip
Version bump for bug 81689; also fixed src_install (setting install_prefix to ${D} caused part of ${D} to be installed).
(Portage version: 2.0.51.16)
Diffstat (limited to 'net-libs/libnids/libnids-1.18.ebuild')
-rw-r--r--net-libs/libnids/libnids-1.18.ebuild15
1 files changed, 6 insertions, 9 deletions
diff --git a/net-libs/libnids/libnids-1.18.ebuild b/net-libs/libnids/libnids-1.18.ebuild
index 224c39a70089..698fc42b7f4c 100644
--- a/net-libs/libnids/libnids-1.18.ebuild
+++ b/net-libs/libnids/libnids-1.18.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.18.ebuild,v 1.6 2005/01/29 21:19:57 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnids/libnids-1.18.ebuild,v 1.7 2005/02/25 00:43:39 ka0ttic Exp $
inherit eutils
@@ -19,18 +19,15 @@ DEPEND="virtual/libpcap
src_unpack() {
unpack ${A}
cd ${S}
- epatch ${FILESDIR}/libnids-1.18-chksum.c-ebx.patch
+ epatch ${FILESDIR}/${P}-chksum.c-ebx.patch
}
src_compile() {
- econf --enable-shared || die
- make || die
+ econf --enable-shared || die "econf failed"
+ make || die "emake failed"
}
src_install() {
- einstall install_prefix=${D} || die
- mkdir -p ${D}/usr/include/ ${D}/usr/share/man/man3/
- cp -dpR ${D}/${D}/* ${D}/
- rm -rf ${D}/${D} ${D}/var
+ einstall || die "make install failed"
dodoc CHANGES COPYING CREDITS MISC README
}