summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2014-10-10 01:47:32 +0000
committerYixun Lan <dlan@gentoo.org>2014-10-10 01:47:32 +0000
commit71f47b756ae07fe8b76d3a611f95c26133834345 (patch)
treee4f7435b41b3f694bf3224d88b3818aa068abfaf /net-libs/liboping
parentVersion bump, clean up some old stuff in files. (diff)
downloadgentoo-2-71f47b756ae07fe8b76d3a611f95c26133834345.tar.gz
gentoo-2-71f47b756ae07fe8b76d3a611f95c26133834345.tar.bz2
gentoo-2-71f47b756ae07fe8b76d3a611f95c26133834345.zip
bump per maintainer request, bug 524906
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key 0xAABEFD55)
Diffstat (limited to 'net-libs/liboping')
-rw-r--r--net-libs/liboping/ChangeLog7
-rw-r--r--net-libs/liboping/liboping-1.7.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/net-libs/liboping/ChangeLog b/net-libs/liboping/ChangeLog
index e8c136bd5a75..9ac9b1f3138a 100644
--- a/net-libs/liboping/ChangeLog
+++ b/net-libs/liboping/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/liboping
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liboping/ChangeLog,v 1.13 2014/10/09 19:55:25 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboping/ChangeLog,v 1.14 2014/10/10 01:47:32 dlan Exp $
+
+*liboping-1.7.0 (10 Oct 2014)
+
+ 10 Oct 2014; Yixun Lan <dlan@gentoo.org> +liboping-1.7.0.ebuild:
+ bump per maintainer request, bug 524906
09 Oct 2014; Andreas K. Huettel <dilfridge@gentoo.org> liboping-1.6.1.ebuild,
liboping-1.6.2.ebuild:
diff --git a/net-libs/liboping/liboping-1.7.0.ebuild b/net-libs/liboping/liboping-1.7.0.ebuild
new file mode 100644
index 000000000000..cfb8f9c05cd1
--- /dev/null
+++ b/net-libs/liboping/liboping-1.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liboping/liboping-1.7.0.ebuild,v 1.1 2014/10/10 01:47:32 dlan Exp $
+
+EAPI=5
+
+inherit base autotools
+
+DESCRIPTION="C library and ncurses based program to generate ICMP echo requests and ping multiple hosts at once"
+HOMEPAGE="http://verplant.org/liboping"
+SRC_URI="http://verplant.org/${PN}/files/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="perl"
+
+DEPEND="
+ sys-libs/ncurses
+ perl? ( dev-lang/perl )
+"
+RDEPEND=${DEPEND}
+
+PATCHES=( "${FILESDIR}/${PN}-1.6.2-nouidmagic.patch" )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with perl perl-bindings INSTALLDIRS=vendor) \
+ --disable-static
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+
+ fperms u+s,og-r /usr/bin/oping
+ fperms u+s,og-r /usr/bin/noping
+}