summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-11-16 15:07:50 +0000
committerPeter Volkov <pva@gentoo.org>2008-11-16 15:07:50 +0000
commit41ad5163504e975ca82a6a7f956ae68fb94dcbac (patch)
treebc744c4300a42d1fbbfecb0a6c8837707e803864 /net-libs/libpcap/files
parentFixed multilib issue reported by Tiago Cunha in bug #246765. Nothing else cha... (diff)
downloadgentoo-2-41ad5163504e975ca82a6a7f956ae68fb94dcbac.tar.gz
gentoo-2-41ad5163504e975ca82a6a7f956ae68fb94dcbac.tar.bz2
gentoo-2-41ad5163504e975ca82a6a7f956ae68fb94dcbac.zip
Fixed library soname, added possibility to build with bluetooth support (dropped m68k mips s390 sparc-fbsd x86-fbsd). Removed unused.
(Portage version: 2.2_rc14/cvs/Linux 2.6.26-openvz.git-35f41f1 i686)
Diffstat (limited to 'net-libs/libpcap/files')
-rw-r--r--net-libs/libpcap/files/libpcap-1.0.0-LDFLAGS.patch13
-rw-r--r--net-libs/libpcap/files/libpcap-1.0.0-cross-linux.patch30
-rw-r--r--net-libs/libpcap/files/libpcap-1.0.0-install-bindir.patch13
-rw-r--r--net-libs/libpcap/files/libpcap-1.0.0-install-headers.patch41
-rw-r--r--net-libs/libpcap/files/libpcap-1.0.0-optional-bluetooth.patch151
5 files changed, 248 insertions, 0 deletions
diff --git a/net-libs/libpcap/files/libpcap-1.0.0-LDFLAGS.patch b/net-libs/libpcap/files/libpcap-1.0.0-LDFLAGS.patch
new file mode 100644
index 000000000000..9adcacaefc6f
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.0.0-LDFLAGS.patch
@@ -0,0 +1,13 @@
+=== modified file 'Makefile.in'
+--- Makefile.in 2008-11-04 18:53:20 +0000
++++ Makefile.in 2008-11-04 18:53:49 +0000
+@@ -328,7 +328,7 @@
+ #
+ libpcap.so: $(OBJ)
+ @rm -f $@
+- $(CC) -shared -Wl,-soname,$@.1 -o $@.`cat $(srcdir)/VERSION` $(OBJ) $(DAGLIBS)
++ $(CC) -shared $(LDFLAGS) -Wl,-soname,$@.1 -o $@.`cat $(srcdir)/VERSION` $(OBJ) $(DAGLIBS)
+
+ #
+ # The following rule succeeds, but the result is untested.
+
diff --git a/net-libs/libpcap/files/libpcap-1.0.0-cross-linux.patch b/net-libs/libpcap/files/libpcap-1.0.0-cross-linux.patch
new file mode 100644
index 000000000000..314b58050673
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.0.0-cross-linux.patch
@@ -0,0 +1,30 @@
+=== modified file 'configure.in'
+--- configure.in 2008-11-02 07:39:02 +0000
++++ configure.in 2008-11-02 07:45:33 +0000
+@@ -218,7 +218,12 @@
+ dnl XXX This could be done for cross-compiling, but for now it's not.
+ dnl
+ if test -z "$with_pcap" && test "$cross_compiling" = yes; then
+- AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...)
++ if test -z "$with_pcap" ; then
++ case $host in
++ *-linux*) with_pcap="linux";;
++ *) AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...);;
++ esac
++ fi
+ fi
+ AC_ARG_WITH(pcap, [ --with-pcap=TYPE use packet capture TYPE])
+ AC_MSG_CHECKING(packet capture type)
+@@ -338,8 +343,10 @@
+ linux)
+ AC_MSG_CHECKING(Linux kernel version)
+ if test "$cross_compiling" = yes; then
++ dnl we could check linux/version.h here, but who runs
++ dnl versions of linux older than 2.0.x anymore to bother ?
+ AC_CACHE_VAL(ac_cv_linux_vers,
+- ac_cv_linux_vers=unknown)
++ ac_cv_linux_vers=2)
+ else
+ AC_CACHE_VAL(ac_cv_linux_vers,
+ ac_cv_linux_vers=`uname -r 2>&1 | \
+
diff --git a/net-libs/libpcap/files/libpcap-1.0.0-install-bindir.patch b/net-libs/libpcap/files/libpcap-1.0.0-install-bindir.patch
new file mode 100644
index 000000000000..eafa57041e22
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.0.0-install-bindir.patch
@@ -0,0 +1,13 @@
+=== modified file 'Makefile.in'
+--- Makefile.in 2008-11-02 09:45:33 +0000
++++ Makefile.in 2008-11-02 10:46:03 +0000
+@@ -445,6 +445,8 @@
+ $(DESTDIR)$(includedir)/pcap-bpf.h
+ $(INSTALL_DATA) $(srcdir)/pcap-namedb.h \
+ $(DESTDIR)$(includedir)/pcap-namedb.h
++ [ -d $(DESTDIR)$(bindir) ] || \
++ (mkdir -p $(DESTDIR)$(bindir); chmod 755 $(DESTDIR)$(bindir))
+ $(INSTALL_PROGRAM) pcap-config $(DESTDIR)$(bindir)/pcap-config
+ for i in $(MAN1); do \
+ $(INSTALL_DATA) $(srcdir)/$$i \
+
diff --git a/net-libs/libpcap/files/libpcap-1.0.0-install-headers.patch b/net-libs/libpcap/files/libpcap-1.0.0-install-headers.patch
new file mode 100644
index 000000000000..ebd583d2c1b2
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.0.0-install-headers.patch
@@ -0,0 +1,41 @@
+=== modified file 'Makefile.in'
+--- Makefile.in 2008-11-02 10:49:47 +0000
++++ Makefile.in 2008-11-04 18:03:48 +0000
+@@ -85,6 +85,8 @@
+ GENSRC = scanner.c grammar.c version.c
+ LIBOBJS = @LIBOBJS@
+
++HAVE_LINUX_TPACKET_AUXDATA = @HAVE_LINUX_TPACKET_AUXDATA@
++
+ SRC = $(PSRC) $(FSRC) $(CSRC) $(SSRC) $(GENSRC)
+
+ # We would like to say "OBJ = $(SRC:.c=.o)" but Ultrix's make cannot
+@@ -434,6 +436,14 @@
+ $(DESTDIR)$(includedir)/pcap/pcap.h
+ $(INSTALL_DATA) $(srcdir)/pcap/bpf.h \
+ $(DESTDIR)$(includedir)/pcap/bpf.h
++ if test ! -z "@HAVE_LINUX_TPACKET_AUXDATA@" ; then \
++ $(INSTALL_DATA) $(srcdir)/pcap/vlan.h \
++ $(DESTDIR)$(includedir)/pcap/vlan.h ; \
++ fi
++ if test ! -z "@BT_SRC@" ; then \
++ $(INSTALL_DATA) $(srcdir)/pcap/bluetooth.h \
++ $(DESTDIR)$(includedir)/pcap/bluetooth.h ; \
++ fi
+ $(INSTALL_DATA) $(srcdir)/pcap/namedb.h \
+ $(DESTDIR)$(includedir)/pcap/namedb.h
+ $(INSTALL_DATA) $(srcdir)/pcap/sll.h \
+
+=== modified file 'aclocal.m4'
+--- aclocal.m4 2008-11-02 09:45:33 +0000
++++ aclocal.m4 2008-11-04 18:05:01 +0000
+@@ -930,6 +930,8 @@
+ ac_cv_lbl_linux_tpacket_auxdata_tp_vlan_tci=no))
+ AC_MSG_RESULT($ac_cv_lbl_linux_tpacket_auxdata_tp_vlan_tci)
+ if test $ac_cv_lbl_linux_tpacket_auxdata_tp_vlan_tci = yes ; then
++ HAVE_LINUX_TPACKET_AUXDATA=tp_vlan_tci
++ AC_SUBST(HAVE_LINUX_TPACKET_AUXDATA)
+ AC_DEFINE(HAVE_LINUX_TPACKET_AUXDATA_TP_VLAN_TCI,1,[if tp_vlan_tci exists])
+ fi])
+
+
diff --git a/net-libs/libpcap/files/libpcap-1.0.0-optional-bluetooth.patch b/net-libs/libpcap/files/libpcap-1.0.0-optional-bluetooth.patch
new file mode 100644
index 000000000000..3f7942ad351e
--- /dev/null
+++ b/net-libs/libpcap/files/libpcap-1.0.0-optional-bluetooth.patch
@@ -0,0 +1,151 @@
+=== modified file 'configure.in'
+--- configure.in 2008-11-04 18:26:23 +0000
++++ configure.in 2008-11-04 18:42:51 +0000
+@@ -185,7 +185,8 @@
+
+ dnl to pacify those who hate protochain insn
+ AC_MSG_CHECKING(if --disable-protochain option is specified)
+-AC_ARG_ENABLE(protochain, [ --disable-protochain disable \"protochain\" insn])
++AC_ARG_ENABLE(protochain,
++AS_HELP_STRING([--disable-protochain],[disable \"protochain\" insn]))
+ case "x$enable_protochain" in
+ xyes) enable_protochain=enabled ;;
+ xno) enable_protochain=disabled ;;
+@@ -201,7 +202,8 @@
+ # SITA support is mutually exclusive with native capture support;
+ # "--with-sita" selects SITA support.
+ #
+-AC_ARG_WITH(sita, [ --with-sita include SITA support],
++AC_ARG_WITH(sita,
++AS_HELP_STRING([--with-sita],[include SITA support]),
+ [
+ if test ! "x$withval" = "xno" ; then
+ AC_DEFINE(SITA,1,[include ACN support])
+@@ -222,7 +224,8 @@
+ if test -z "$with_pcap" && test "$cross_compiling" = yes; then
+ AC_MSG_ERROR(pcap type not determined when cross-compiling; use --with-pcap=...)
+ fi
+-AC_ARG_WITH(pcap, [ --with-pcap=TYPE use packet capture TYPE])
++AC_ARG_WITH(pcap,
++AS_HELP_STRING([--with-pcap=TYPE],[use packet capture TYPE]))
+ AC_MSG_CHECKING(packet capture type)
+ if test ! -z "$with_pcap" ; then
+ V_PCAP="$withval"
+@@ -503,7 +506,8 @@
+ fi
+ AC_MSG_RESULT($have_socklen_t)
+
+-AC_ARG_ENABLE(ipv6, [ --enable-ipv6 build IPv6-capable version @<:@default=yes, if getaddrinfo available@:>@],
++AC_ARG_ENABLE(ipv6,
++AS_HELP_STRING([--enable-ipv6],[build IPv6-capable version @<:@default=yes, if getaddrinfo available@:>@]),
+ [],
+ [enable_ipv6=ifavailable])
+ if test "$enable_ipv6" != "no"; then
+@@ -519,14 +523,16 @@
+ fi
+
+ AC_MSG_CHECKING(whether to build optimizer debugging code)
+-AC_ARG_ENABLE(optimizer-dbg, [ --enable-optimizer-dbg build optimizer debugging code])
++AC_ARG_ENABLE(optimizer-dbg,
++AS_HELP_STRING([--enable-optimizer-dbg],[build optimizer debugging code]))
+ if test "$enable_optimizer_dbg" = "yes"; then
+ AC_DEFINE(BDEBUG,1,[Enable optimizer debugging])
+ fi
+ AC_MSG_RESULT(${enable_optimizer_dbg-no})
+
+ AC_MSG_CHECKING(whether to build parser debugging code)
+-AC_ARG_ENABLE(yydebug, [ --enable-yydebug build parser debugging code])
++AC_ARG_ENABLE(yydebug,
++AS_HELP_STRING([--enable-yydebug],[build parser debugging code]))
+ if test "$enable_yydebug" = "yes"; then
+ AC_DEFINE(YYDEBUG,1,[Enable parser debugging])
+ fi
+@@ -544,7 +550,8 @@
+ AC_MSG_RESULT($ac_cv_lbl_proc_net_dev)
+
+ # Check for Endace DAG card support.
+-AC_ARG_WITH([dag], [ --with-dag[[=DIR]] include Endace DAG support ("yes", "no" or DIR; default="yes" on BSD and Linux if present)],
++AC_ARG_WITH([dag],
++AS_HELP_STRING([--with-dag@<:@=DIR@:>@],[include Endace DAG support @<:@"yes", "no" or DIR; default="yes" on BSD and Linux if present@:>@]),
+ [
+ if test "$withval" = no
+ then
+@@ -566,14 +573,16 @@
+ want_dag=ifpresent
+ ])
+
+-AC_ARG_WITH([dag-includes], [ --with-dag-includes=DIR Endace DAG include directory],
++AC_ARG_WITH([dag-includes],
++AS_HELP_STRING([--with-dag-includes=DIR],[Endace DAG include directory]),
+ [
+ # User wants DAG support and has specified a header directory, so use the provided value.
+ want_dag=yes
+ dag_include_dir=$withval
+ ],[])
+
+-AC_ARG_WITH([dag-libraries], [ --with-dag-libraries=DIR Endace DAG library directory],
++AC_ARG_WITH([dag-libraries],
++AS_HELP_STRING([--with-dag-libraries=DIR],[Endace DAG library directory]),
+ [
+ # User wants DAG support and has specified a library directory, so use the provided value.
+ want_dag=yes
+@@ -767,7 +776,8 @@
+ AC_MSG_RESULT(yes)
+ fi
+
+-AC_ARG_WITH(septel, [ --with-septel[[=DIR]] include Septel support (located in directory DIR, if supplied). [default=yes, on Linux, if present]],
++AC_ARG_WITH(septel,
++AS_HELP_STRING([--with-septel@<:@=DIR@:>@],[include Septel support (located in directory DIR, if supplied). @<:@default=yes, on Linux, if present@:>@]),
+ [
+ if test "$withval" = no
+ then
+@@ -1038,24 +1048,30 @@
+ AC_SUBST(PCAP_SUPPORT_USB)
+ AC_SUBST(USB_SRC)
+
+-dnl check for bluetooth sniffing support
+-case "$host_os" in
+-linux*)
+- AC_CHECK_HEADER(bluetooth/bluetooth.h,
+- [
+- AC_DEFINE(PCAP_SUPPORT_BT, 1, [target host supports Bluetooth sniffing])
+- BT_SRC=pcap-bt-linux.c
+- AC_MSG_NOTICE(Bluetooth sniffing is supported)
+- ],
+- AC_MSG_NOTICE(Bluetooth sniffing is not supported; install bluez-lib devel to enable it)
+- )
+- ;;
+-*)
+- AC_MSG_NOTICE(no Bluetooth sniffing support)
+- ;;
+-esac
+-AC_SUBST(PCAP_SUPPORT_BT)
+-AC_SUBST(BT_SRC)
++AC_ARG_ENABLE([bluetooth],
++[AS_HELP_STRING([--enable-bluetooth],[enable bluetooth support @<:@default=yes, if support available@:>@])],
++,enable_bluetooth=yes)
++
++if test "x$enable_bluetooth" != "xno" ; then
++ dnl check for bluetooth sniffing support
++ case "$host_os" in
++ linux*)
++ AC_CHECK_HEADER(bluetooth/bluetooth.h,
++ [
++ AC_DEFINE(PCAP_SUPPORT_BT, 1, [target host supports Bluetooth sniffing])
++ BT_SRC=pcap-bt-linux.c
++ AC_MSG_NOTICE(Bluetooth sniffing is supported)
++ ],
++ AC_MSG_NOTICE(Bluetooth sniffing is not supported; install bluez-lib devel to enable it)
++ )
++ ;;
++ *)
++ AC_MSG_NOTICE(no Bluetooth sniffing support)
++ ;;
++ esac
++ AC_SUBST(PCAP_SUPPORT_BT)
++ AC_SUBST(BT_SRC)
++fi
+
+ AC_PROG_INSTALL
+
+