summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Knoblich <stkn@gentoo.org>2005-05-07 18:16:46 +0000
committerStefan Knoblich <stkn@gentoo.org>2005-05-07 18:16:46 +0000
commit878bc9ca0382f3ff8bed485927f5323cff34a72f (patch)
tree92f0daffa999bf619280f8cddb7368c1eea40fc6 /net-libs/libpri/libpri-1.0.7-r1.ebuild
parentVersion bump (w/o fax patch) (diff)
downloadgentoo-2-878bc9ca0382f3ff8bed485927f5323cff34a72f.tar.gz
gentoo-2-878bc9ca0382f3ff8bed485927f5323cff34a72f.tar.bz2
gentoo-2-878bc9ca0382f3ff8bed485927f5323cff34a72f.zip
Updated to bristuff-0.2.0-RC8a
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-libs/libpri/libpri-1.0.7-r1.ebuild')
-rw-r--r--net-libs/libpri/libpri-1.0.7-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-libs/libpri/libpri-1.0.7-r1.ebuild b/net-libs/libpri/libpri-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..da5d451aa979
--- /dev/null
+++ b/net-libs/libpri/libpri-1.0.7-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/libpri-1.0.7-r1.ebuild,v 1.1 2005/05/07 18:16:46 stkn Exp $
+
+inherit eutils
+
+IUSE="bri"
+
+BRI_VERSION="0.2.0-RC8a"
+
+DESCRIPTION="Primary Rate ISDN (PRI) library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="ftp://ftp.asterisk.org/pub/telephony/libpri/libpri-${PV}.tar.gz
+ bri? ( http://www.junghanns.net/asterisk/downloads/bristuff-${BRI_VERSION}.tar.gz )"
+
+SLOT="0"
+LICENSE="GPL-2"
+#KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+KEYWORDS="-*"
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ if use bri; then
+ einfo "Patching libpri w/ BRI stuff (${BRI_VERSION})"
+ epatch ${WORKDIR}/bristuff-${BRI_VERSION}/patches/libpri.patch
+ fi
+
+ # use system CFLAGS
+ sed -i -e "s:^CFLAGS=:CFLAGS+=:" \
+ -e "/^CFLAGS[\t ]\++=/ d" Makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make INSTALL_PREFIX=${D} install || die
+
+ dodoc ChangeLog README TODO LICENSE
+}