summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-07-16 22:10:00 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-07-16 22:10:00 +0000
commitbed78cc190232400990cc022e2f2c2efe231e424 (patch)
treebd4447b9d1ebe0a29197c3c60ab312c9b2fbc65c /net-libs/libproxy
parentNew package, ebuild written by me (diff)
downloadgentoo-2-bed78cc190232400990cc022e2f2c2efe231e424.tar.gz
gentoo-2-bed78cc190232400990cc022e2f2c2efe231e424.tar.bz2
gentoo-2-bed78cc190232400990cc022e2f2c2efe231e424.zip
Always install the vapi file since it needs no deps and is only 333 bytes in size. See bug 372813.
(Portage version: 2.2.0_alpha39_p14/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libproxy')
-rw-r--r--net-libs/libproxy/ChangeLog6
-rw-r--r--net-libs/libproxy/libproxy-0.4.6-r3.ebuild11
2 files changed, 11 insertions, 6 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index a8cff6767663..090aa47e7e87 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.60 2011/07/14 17:35:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.61 2011/07/16 22:10:00 nirbheek Exp $
+
+ 16 Jul 2011; Nirbheek Chauhan <nirbheek@gentoo.org> libproxy-0.4.6-r3.ebuild:
+ Always install the vapi file since it needs no deps and is only 333 bytes in
+ size. See bug 372813.
14 Jul 2011; Pacho Ramos <pacho@gentoo.org> libproxy-0.4.6-r3.ebuild:
amd64 stable, bug #372813
diff --git a/net-libs/libproxy/libproxy-0.4.6-r3.ebuild b/net-libs/libproxy/libproxy-0.4.6-r3.ebuild
index 43219dcd77eb..ede0ae731e48 100644
--- a/net-libs/libproxy/libproxy-0.4.6-r3.ebuild
+++ b/net-libs/libproxy/libproxy-0.4.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6-r3.ebuild,v 1.3 2011/07/14 17:35:39 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.4.6-r3.ebuild,v 1.4 2011/07/16 22:10:00 nirbheek Exp $
EAPI=3
PYTHON_DEPEND="python? 2:2.6"
@@ -14,7 +14,7 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gnome kde mono networkmanager perl python test vala"
+IUSE="gnome kde mono networkmanager perl python test"
# FIXME: Disable webkit support due problems like bug #366791
# FIXME: Also disable xulrunner support due bug #360893, will be readded
@@ -24,8 +24,7 @@ RDEPEND="gnome? ( gnome-base/gconf:2 )
kde? ( >=kde-base/kdelibs-4.4.5 )
mono? ( dev-lang/mono )
networkmanager? ( net-misc/networkmanager )
- perl? ( dev-lang/perl )
- vala? ( dev-lang/vala:0.10 )"
+ perl? ( dev-lang/perl )"
# xulrunner? ( >=net-libs/xulrunner-1.9.1:1.9 )
# webkit? ( net-libs/webkit-gtk:2 )
DEPEND="${RDEPEND}
@@ -49,6 +48,8 @@ pkg_setup() {
}
src_configure() {
+ # WITH_VALA just copies the .vapi file over and needs no deps,
+ # hence always enable it unconditionally
local mycmakeargs=(
-DPERL_VENDORINSTALL=ON
-DCMAKE_C_FLAGS="${CFLAGS}"
@@ -59,7 +60,7 @@ src_configure() {
$(cmake-utils_use_with networkmanager NM)
$(cmake-utils_use_with perl PERL)
$(cmake-utils_use_with python PYTHON)
- $(cmake-utils_use_with vala VALA)
+ -DWITH_VALA=ON
-DWITH_WEBKIT=OFF
-DWITH_MOZJS=OFF
$(cmake-utils_use test BUILD_TESTING)