summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-08-26 21:17:16 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-08-26 21:17:16 +0000
commit84c90f974720d1e888fe3effb792f5185fb5f5a0 (patch)
tree5ff005bac7b5f57f91ff44e9d56675fde8e8cc2c /net-libs/libtorrent/libtorrent-0.12.2-r4.ebuild
parentNew pretest version. (diff)
downloadgentoo-2-84c90f974720d1e888fe3effb792f5185fb5f5a0.tar.gz
gentoo-2-84c90f974720d1e888fe3effb792f5185fb5f5a0.tar.bz2
gentoo-2-84c90f974720d1e888fe3effb792f5185fb5f5a0.zip
Fixes an interoperability issue in the get_peers handling, now it behaves according to the clarified BEP-0005. Also fixes a minor issue of not being able to generate error packets. Patch by Josef Drexler.
(Portage version: 2.2_rc8/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.12.2-r4.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.2-r4.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.12.2-r4.ebuild b/net-libs/libtorrent/libtorrent-0.12.2-r4.ebuild
new file mode 100644
index 000000000000..be18da686c3b
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.2-r4.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.2-r4.ebuild,v 1.1 2008/08/26 21:17:15 loki_val Exp $
+
+inherit autotools eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug ipv6"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-0.11.9+gcc-4.3.patch
+ epatch "${FILESDIR}"/${P}-dht_bounds_fix.patch
+ epatch "${FILESDIR}"/${P}-fix_cull.patch
+ epatch "${FILESDIR}"/${P}-fix_dht_target.patch
+ epatch "${FILESDIR}"/${P}-fix_have_timer.patch
+ epatch "${FILESDIR}"/${P}-fix_pex_leak.patch
+ epatch "${FILESDIR}"/${P}-fix_write_datagram.patch
+ epatch "${FILESDIR}"/${P}-lt-ver.patch
+ epatch "${FILESDIR}"/${P}-tracker_timer_fix.patch
+ epatch "${FILESDIR}"/${P}-fix_dht-get_peers.patch
+
+ elibtoolize #Don't remove
+ eautoreconf
+}
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ --enable-aligned \
+ --enable-static \
+ --enable-shared \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README
+}