summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-06 18:18:46 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-06 18:18:46 +0000
commitc0e5dbd80978776646a590cfff25a8779de86792 (patch)
tree313fbfea0df934c5db595d2afcd31e718115527b /net-libs/libyahoo2
parentVersion bump. (diff)
downloadgentoo-2-c0e5dbd80978776646a590cfff25a8779de86792.tar.gz
gentoo-2-c0e5dbd80978776646a590cfff25a8779de86792.tar.bz2
gentoo-2-c0e5dbd80978776646a590cfff25a8779de86792.zip
Version bump.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libyahoo2')
-rw-r--r--net-libs/libyahoo2/ChangeLog10
-rw-r--r--net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch16
-rw-r--r--net-libs/libyahoo2/libyahoo2-0.7.7.ebuild27
-rw-r--r--net-libs/libyahoo2/libyahoo2-1.0.1.ebuild44
4 files changed, 68 insertions, 29 deletions
diff --git a/net-libs/libyahoo2/ChangeLog b/net-libs/libyahoo2/ChangeLog
index aeece21a1427..0a1714bd3f2f 100644
--- a/net-libs/libyahoo2/ChangeLog
+++ b/net-libs/libyahoo2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libyahoo2
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libyahoo2/ChangeLog,v 1.9 2009/04/25 11:33:28 patrick Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libyahoo2/ChangeLog,v 1.10 2011/02/06 18:18:46 ssuominen Exp $
+
+*libyahoo2-1.0.1 (06 Feb 2011)
+
+ 06 Feb 2011; Samuli Suominen <ssuominen@gentoo.org> +libyahoo2-1.0.1.ebuild,
+ +files/libyahoo2-1.0.1-asneeded.patch:
+ Version bump.
*libyahoo2-0.7.7 (25 Apr 2009)
diff --git a/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch b/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch
new file mode 100644
index 000000000000..b05190a02a71
--- /dev/null
+++ b/net-libs/libyahoo2/files/libyahoo2-1.0.1-asneeded.patch
@@ -0,0 +1,16 @@
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -21,11 +21,9 @@
+ noinst_PROGRAMS = yahoo autoresponder
+
+ yahoo_SOURCES = sample_client.c
+-yahoo_LDADD = libyahoo2.la
+-yahoo_LDFLAGS = -lssl
++yahoo_LDADD = libyahoo2.la -lssl
+
+ autoresponder_SOURCES = autoresponder.c
+-autoresponder_LDADD = libyahoo2.la
+-autoresponder_LDFLAGS = -lssl
++autoresponder_LDADD = libyahoo2.la -lssl
+
+ endif
diff --git a/net-libs/libyahoo2/libyahoo2-0.7.7.ebuild b/net-libs/libyahoo2/libyahoo2-0.7.7.ebuild
deleted file mode 100644
index 8ab06ccc43a8..000000000000
--- a/net-libs/libyahoo2/libyahoo2-0.7.7.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libyahoo2/libyahoo2-0.7.7.ebuild,v 1.1 2009/04/25 11:33:28 patrick Exp $
-
-DESCRIPTION="interface to the new Yahoo! Messenger protocol"
-HOMEPAGE="http://libyahoo2.sourceforge.net/"
-SRC_URI="mirror://sourceforge/libyahoo2/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -i 's:-ansi -pedantic::' configure #240912
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- dobin src/yahoo || die
- dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
- dodoc doc/*.txt
- docinto sample
- dodoc src/sample_client.c src/sample_makefile
-}
diff --git a/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild b/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
new file mode 100644
index 000000000000..cffece495db5
--- /dev/null
+++ b/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libyahoo2/libyahoo2-1.0.1.ebuild,v 1.1 2011/02/06 18:18:46 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="interface to the new Yahoo! Messenger protocol"
+HOMEPAGE="http://libyahoo2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/libyahoo2/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static-libs ssl"
+
+RDEPEND="dev-libs/glib:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ sed -i -e 's:-ansi -pedantic::' configure.ac || die #240912
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable ssl sample-client)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ if use ssl; then
+ dobin src/.libs/{autoresponder,yahoo} || die
+ fi
+
+ dodoc AUTHORS ChangeLog doc/*.txt NEWS README TODO
+
+ find "${D}" -name '*.la' -exec rm -f '{}' +
+}