summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2005-02-14 23:31:37 +0000
committerMarinus Schraal <foser@gentoo.org>2005-02-14 23:31:37 +0000
commit4c3632f551707d3a991fbd78967aff70ba4bf313 (patch)
treec41ffe52f0687e3f2e61a843ec53abe7646c5318 /net-libs/loudmouth
parentmacos went away (diff)
downloadgentoo-2-4c3632f551707d3a991fbd78967aff70ba4bf313.tar.gz
gentoo-2-4c3632f551707d3a991fbd78967aff70ba4bf313.tar.bz2
gentoo-2-4c3632f551707d3a991fbd78967aff70ba4bf313.zip
add gnutls symbols patch
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/ChangeLog9
-rw-r--r--net-libs/loudmouth/Manifest5
-rw-r--r--net-libs/loudmouth/files/digest-loudmouth-0.17.2-r11
-rw-r--r--net-libs/loudmouth/files/loudmouth-0.17.2-gnutls_deprecation.patch20
-rw-r--r--net-libs/loudmouth/loudmouth-0.17.2-r1.ebuild38
5 files changed, 70 insertions, 3 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 497c221f2d60..87ee079a76d4 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/loudmouth
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.22 2004/12/18 17:03:51 foser Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.23 2005/02/14 23:31:37 foser Exp $
+
+*loudmouth-0.17.2-r1 (15 Feb 2005)
+
+ 15 Feb 2005; foser <foser@gentoo.org> loudmouth-0.17.2-r1.ebuild :
+ Add patch to fix gnutls deprecated symbol issues (#79309)
*loudmouth-0.17.2 (18 Dec 2004)
diff --git a/net-libs/loudmouth/Manifest b/net-libs/loudmouth/Manifest
index 53d49a7b5c08..79ed5b51ce14 100644
--- a/net-libs/loudmouth/Manifest
+++ b/net-libs/loudmouth/Manifest
@@ -1,8 +1,11 @@
-MD5 b266bb34fcef3783f32a963ecc501ad2 loudmouth-0.17.2.ebuild 795
+MD5 5f306dfe613b0df3b3330be11b1f58bb loudmouth-0.17.2.ebuild 900
MD5 e89c7f9d64ded599dc2950968f7b6ded loudmouth-0.16.ebuild 621
+MD5 c79139e1d437d101135d96fabe47e786 loudmouth-0.17.2-r1.ebuild 884
MD5 a9917b1a3a7ef8955d14a5454fc413c7 ChangeLog 2716
MD5 16064ea4cee1e03c3d626a42da1125ff loudmouth-0.17.1.ebuild 794
MD5 03ad2e6c4ab41244af1015a8bbb0b39f metadata.xml 158
MD5 5c9d9cbecc7012f358b36f0cde4b75a2 files/digest-loudmouth-0.17.1 69
MD5 a556924d584687a8f363eed4bb9c743f files/digest-loudmouth-0.17.2 69
+MD5 3683fa9c59f744e00481d05e55c763cf files/loudmouth-0.17.2-gnutls_deprecation.patch 782
+MD5 a556924d584687a8f363eed4bb9c743f files/digest-loudmouth-0.17.2-r1 69
MD5 1198670c7a9b3819274997b05c6131ca files/digest-loudmouth-0.16 67
diff --git a/net-libs/loudmouth/files/digest-loudmouth-0.17.2-r1 b/net-libs/loudmouth/files/digest-loudmouth-0.17.2-r1
new file mode 100644
index 000000000000..ac92b907b1a2
--- /dev/null
+++ b/net-libs/loudmouth/files/digest-loudmouth-0.17.2-r1
@@ -0,0 +1 @@
+MD5 db5dd069f3c7de18d5347ebaaee4ad61 loudmouth-0.17.2.tar.bz2 286981
diff --git a/net-libs/loudmouth/files/loudmouth-0.17.2-gnutls_deprecation.patch b/net-libs/loudmouth/files/loudmouth-0.17.2-gnutls_deprecation.patch
new file mode 100644
index 000000000000..a07c0b07c062
--- /dev/null
+++ b/net-libs/loudmouth/files/loudmouth-0.17.2-gnutls_deprecation.patch
@@ -0,0 +1,20 @@
+diff -uNr loudmouth-0.17.2/loudmouth/lm-ssl.c loudmouth-0.17.2.patched/loudmouth/lm-ssl.c
+--- loudmouth-0.17.2/loudmouth/lm-ssl.c 2004-10-19 09:52:48.000000000 +0200
++++ loudmouth-0.17.2.patched/loudmouth/lm-ssl.c 2005-02-15 00:20:48.045550968 +0100
+@@ -71,7 +71,6 @@
+ }
+
+ if (status & GNUTLS_CERT_INVALID
+- || status & GNUTLS_CERT_NOT_TRUSTED
+ || status & GNUTLS_CERT_REVOKED) {
+ if (ssl->func (ssl, LM_SSL_STATUS_UNTRUSTED_CERT,
+ ssl->func_data) != LM_SSL_RESPONSE_CONTINUE) {
+@@ -126,7 +125,7 @@
+
+ gnutls_x509_crt_deinit (cert);
+
+- if (gnutls_x509_fingerprint (GNUTLS_DIG_MD5, &cert_list[0],
++ if (gnutls_fingerprint (GNUTLS_DIG_MD5, &cert_list[0],
+ ssl->fingerprint,
+ &digest_size) >= 0) {
+ if (ssl->expected_fingerprint &&
diff --git a/net-libs/loudmouth/loudmouth-0.17.2-r1.ebuild b/net-libs/loudmouth/loudmouth-0.17.2-r1.ebuild
new file mode 100644
index 000000000000..76ea06fdfb8e
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-0.17.2-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-0.17.2-r1.ebuild,v 1.1 2005/02/14 23:31:37 foser Exp $
+
+inherit gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://loudmouth.imendio.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~ppc ~amd64"
+
+IUSE="doc ssl"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS COPYING ChangeLog INSTALL NEWS README"
+
+G2CONF="${G2CONF} `use_with ssl` --disable-mono"
+# FIXME : We probably want to add a local mono use flag. However, I have no chance to -test- the monobindings, so I'm just disabling it right now.
+
+USE_DESTDIR="1"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gnutls_deprecations.patch
+
+}
+