summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-08-28 21:52:51 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-08-28 21:52:51 +0000
commit8d9fa31706dcc02658b0a511d94b34dd35ca476b (patch)
treec88c67f533b7adcad8c9b7033167549c10d5f652 /net-libs/loudmouth
parentRemove forced -j1 as it doesn't seem to be necessary anymore (bug #235995). (diff)
downloadgentoo-2-8d9fa31706dcc02658b0a511d94b34dd35ca476b.tar.gz
gentoo-2-8d9fa31706dcc02658b0a511d94b34dd35ca476b.tar.bz2
gentoo-2-8d9fa31706dcc02658b0a511d94b34dd35ca476b.zip
bump to 1.4.2, leak & build fixes.
(Portage version: 2.2_rc8/cvs/Linux 2.6.24-gentoo-r8 i686)
Diffstat (limited to 'net-libs/loudmouth')
-rw-r--r--net-libs/loudmouth/ChangeLog8
-rw-r--r--net-libs/loudmouth/loudmouth-1.4.2.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/net-libs/loudmouth/ChangeLog b/net-libs/loudmouth/ChangeLog
index 23aa4c9b8768..ee99855bb497 100644
--- a/net-libs/loudmouth/ChangeLog
+++ b/net-libs/loudmouth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/loudmouth
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.70 2008/08/03 00:35:57 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/ChangeLog,v 1.71 2008/08/28 21:52:51 eva Exp $
+
+*loudmouth-1.4.2 (28 Aug 2008)
+
+ 28 Aug 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +loudmouth-1.4.2.ebuild:
+ bump to 1.4.2, leak & build fixes.
03 Aug 2008; Mart Raudsepp <leio@gentoo.org> loudmouth-1.4.1.ebuild:
Default enable USE=asyncns - you most likely want this feature for the UI to
diff --git a/net-libs/loudmouth/loudmouth-1.4.2.ebuild b/net-libs/loudmouth/loudmouth-1.4.2.ebuild
new file mode 100644
index 000000000000..e0d6d49d15e5
--- /dev/null
+++ b/net-libs/loudmouth/loudmouth-1.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/loudmouth/loudmouth-1.4.2.ebuild,v 1.1 2008/08/28 21:52:51 eva Exp $
+
+EAPI=1
+
+inherit gnome2
+
+DESCRIPTION="Lightweight C Jabber library"
+HOMEPAGE="http://www.loudmouth-project.org/"
+SRC_URI="http://ftp.imendio.com/pub/imendio/${PN}/src/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="+asyncns doc ssl debug test"
+
+RDEPEND=">=dev-libs/glib-2.4
+ ssl? ( >=net-libs/gnutls-1.4.0 )"
+# FIXME: can't build against system lib
+# asyncns? ( net-libs/libasyncns )"
+# openssl dropped because of bug #216705
+
+DEPEND="${RDEPEND}
+ test? ( dev-libs/check )
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable debug)
+ $(use_with asyncns)"
+
+ if use ssl; then
+ G2CONF="${G2CONF} --with-ssl=gnutls"
+ else
+ G2CONF="${G2CONF} --with-ssl=no"
+ fi
+}