summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-11-14 18:47:48 +0000
committerDon Seiler <rizzo@gentoo.org>2005-11-14 18:47:48 +0000
commit6e0af4e0ccd38ffaa3bb327df0c2b15b85245999 (patch)
tree3c04c57d8a1c5e18124176c7f5779498622ba7fc /net-libs/meanwhile/meanwhile-0.5.0.ebuild
parentSimplify multilib building logic. Other cleanups. (diff)
downloadgentoo-2-6e0af4e0ccd38ffaa3bb327df0c2b15b85245999.tar.gz
gentoo-2-6e0af4e0ccd38ffaa3bb327df0c2b15b85245999.tar.bz2
gentoo-2-6e0af4e0ccd38ffaa3bb327df0c2b15b85245999.zip
Version bump. Closes bug #111271
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'net-libs/meanwhile/meanwhile-0.5.0.ebuild')
-rw-r--r--net-libs/meanwhile/meanwhile-0.5.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-libs/meanwhile/meanwhile-0.5.0.ebuild b/net-libs/meanwhile/meanwhile-0.5.0.ebuild
new file mode 100644
index 000000000000..35563c982549
--- /dev/null
+++ b/net-libs/meanwhile/meanwhile-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/meanwhile/meanwhile-0.5.0.ebuild,v 1.1 2005/11/14 18:44:55 rizzo Exp $
+
+inherit debug
+
+IUSE="doc debug"
+
+DESCRIPTION="Meanwhile (Sametime protocol) library"
+HOMEPAGE="http://meanwhile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2"
+
+DEPEND="${RDEPEND}
+ dev-libs/gmp
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_compile() {
+
+ local myconf
+ use doc || myconf="${myconf} --enable-doxygen=no"
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf} || die "Configuration failed"
+ emake || die "Make failed"
+
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}