summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-12-20 13:54:45 +0000
committerPeter Volkov <pva@gentoo.org>2010-12-20 13:54:45 +0000
commit7e2519e9707f6e35463612431825dcacc0a4e24e (patch)
treebebd86d21c0593a6c77873c8c3a8fdff8734b7dc /net-libs/miniupnpc
parentRemove old. Fix tests and use autotools-utils eclass. (diff)
downloadgentoo-2-7e2519e9707f6e35463612431825dcacc0a4e24e.tar.gz
gentoo-2-7e2519e9707f6e35463612431825dcacc0a4e24e.tar.bz2
gentoo-2-7e2519e9707f6e35463612431825dcacc0a4e24e.zip
Version bump, thank Nikoli for this job.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/miniupnpc')
-rw-r--r--net-libs/miniupnpc/ChangeLog7
-rw-r--r--net-libs/miniupnpc/miniupnpc-1.4.20101209.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/net-libs/miniupnpc/ChangeLog b/net-libs/miniupnpc/ChangeLog
index 4813e8996b95..459efe127ec9 100644
--- a/net-libs/miniupnpc/ChangeLog
+++ b/net-libs/miniupnpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/miniupnpc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/ChangeLog,v 1.3 2010/10/22 11:19:43 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/ChangeLog,v 1.4 2010/12/20 13:54:45 pva Exp $
+
+*miniupnpc-1.4.20101209 (20 Dec 2010)
+
+ 20 Dec 2010; Peter Volkov <pva@gentoo.org> +miniupnpc-1.4.20101209.ebuild:
+ Version bump, thank Nikoli for this job.
22 Oct 2010; Michał Górny <mgorny@gentoo.org> metadata.xml:
Adding myself as a co-maintainer.
diff --git a/net-libs/miniupnpc/miniupnpc-1.4.20101209.ebuild b/net-libs/miniupnpc/miniupnpc-1.4.20101209.ebuild
new file mode 100644
index 000000000000..38f5310b0548
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-1.4.20101209.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/miniupnpc-1.4.20101209.ebuild,v 1.1 2010/12/20 13:54:45 pva Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils toolchain-funcs
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+
+DEPEND="sys-apps/lsb-release"
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e 's/^CFLAGS ?= -O -Wall /CFLAGS += /' \
+ -i Makefile || die
+
+ if use !static-libs; then
+ sed \
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(INSTALLDIRLIB)/d' \
+ -i Makefile || die
+ fi
+
+ use python && distutils_src_prepare
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+
+ use python && distutils_src_compile
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}" \
+ INSTALLDIRLIB="${D}usr/$(get_libdir)" \
+ install || die
+
+ dodoc README Changelog.txt || die
+ doman man3/* || die
+
+ use python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}