summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2005-02-04 23:32:05 +0000
committerAron Griffis <agriffis@gentoo.org>2005-02-04 23:32:05 +0000
commit03b8fb6dabce56b600cd0d7b69f902d340b9d2c4 (patch)
tree214e25bb823f4bd6f9230b6789e88e64f840f4c3 /net-libs/nfsidmap/nfsidmap-0.9.ebuild
parentstable on amd64 (diff)
downloadgentoo-2-03b8fb6dabce56b600cd0d7b69f902d340b9d2c4.tar.gz
gentoo-2-03b8fb6dabce56b600cd0d7b69f902d340b9d2c4.tar.bz2
gentoo-2-03b8fb6dabce56b600cd0d7b69f902d340b9d2c4.zip
Bump to version 0.9
(Portage version: 2.0.51-r13)
Diffstat (limited to 'net-libs/nfsidmap/nfsidmap-0.9.ebuild')
-rw-r--r--net-libs/nfsidmap/nfsidmap-0.9.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-libs/nfsidmap/nfsidmap-0.9.ebuild b/net-libs/nfsidmap/nfsidmap-0.9.ebuild
new file mode 100644
index 000000000000..4f7ee27ac163
--- /dev/null
+++ b/net-libs/nfsidmap/nfsidmap-0.9.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nfsidmap/nfsidmap-0.9.ebuild,v 1.1 2005/02/04 23:32:05 agriffis Exp $
+
+inherit eutils flag-o-matic
+
+DESCRIPTION="NFSv4 ID <-> name mapping library"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="ldap"
+
+DEPEND="ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ !net-fs/idmapd"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/0.7-optional-ldap.patch
+
+ use ldap \
+ && append-flags -DENABLE_LDAP \
+ || sed -i '/^LIBS/s:-lldap::' Makefile.in
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+}