summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-05-26 07:24:38 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-05-26 07:24:38 +0000
commit18741045fa8002ba1c227dae2d9a49d8c67254e1 (patch)
tree7d567535094569e204f33500f87f15aadf663d8f /net-libs/nodejs
parentStable for ppc, wrt bug #470294 (diff)
downloadgentoo-2-18741045fa8002ba1c227dae2d9a49d8c67254e1.tar.gz
gentoo-2-18741045fa8002ba1c227dae2d9a49d8c67254e1.tar.bz2
gentoo-2-18741045fa8002ba1c227dae2d9a49d8c67254e1.zip
Bump
(Portage version: 2.2.0_alpha176/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/ChangeLog7
-rw-r--r--net-libs/nodejs/nodejs-0.10.8.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index 59b08ffe1fd0..7cfced8c08e4 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.87 2013/05/21 05:23:40 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.88 2013/05/26 07:24:38 patrick Exp $
+
+*nodejs-0.10.8 (26 May 2013)
+
+ 26 May 2013; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.8.ebuild:
+ Bump
*nodejs-0.11.2 (21 May 2013)
diff --git a/net-libs/nodejs/nodejs-0.10.8.ebuild b/net-libs/nodejs/nodejs-0.10.8.ebuild
new file mode 100644
index 000000000000..54bd54bd0236
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.10.8.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.8.ebuild,v 1.1 2013/05/26 07:24:38 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/python-json"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --openssl-use-sys --shared-zlib --without-dtrace || die
+}
+
+src_compile() {
+ emake out/Makefile
+ emake -C out mksnapshot
+ pax-mark m out/Release/mksnapshot
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}"
+
+ dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}