summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-08-23 09:12:21 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-08-23 09:12:21 +0000
commit342838051e575d68715852c1457d478089716555 (patch)
tree24b102e0dfe059db7767daff72170ce55d1bb9ea /net-libs/nodejs
parentStable for x86, wrt bug #447354 (diff)
downloadgentoo-2-342838051e575d68715852c1457d478089716555.tar.gz
gentoo-2-342838051e575d68715852c1457d478089716555.tar.bz2
gentoo-2-342838051e575d68715852c1457d478089716555.zip
Bump
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/ChangeLog9
-rw-r--r--net-libs/nodejs/nodejs-0.10.17.ebuild69
-rw-r--r--net-libs/nodejs/nodejs-0.11.5.ebuild84
3 files changed, 161 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index 908050ec6b26..aaed176d968b 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.98 2013/08/17 09:35:58 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.99 2013/08/23 09:12:21 patrick Exp $
+
+*nodejs-0.10.17 (23 Aug 2013)
+*nodejs-0.11.5 (23 Aug 2013)
+
+ 23 Aug 2013; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.17.ebuild,
+ +nodejs-0.11.5.ebuild:
+ Bump
*nodejs-0.10.16-r1 (17 Aug 2013)
diff --git a/net-libs/nodejs/nodejs-0.10.17.ebuild b/net-libs/nodejs/nodejs-0.10.17.ebuild
new file mode 100644
index 000000000000..aa8526c15147
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.10.17.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.17.ebuild,v 1.1 2013/08/23 09:12:21 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{5,6,7} )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm +snapshot"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}
+ virtual/python-json"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+ ! use snapshot && myconf="${myconf} --without-snapshot"
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ emake out/Makefile
+ emake -C out mksnapshot
+ pax-mark m out/Release/mksnapshot
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}"
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}
diff --git a/net-libs/nodejs/nodejs-0.11.5.ebuild b/net-libs/nodejs/nodejs-0.11.5.ebuild
new file mode 100644
index 000000000000..11a728e6e398
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.11.5.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.11.5.ebuild,v 1.1 2013/08/23 09:12:21 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+
+ # Use target arch detection logic, see v8-3.18 ebuilds
+ case ${CHOST} in
+ i?86-*)
+ myarch="ia32"
+ myconf+=" -Dv8_target_arch=ia32" ;;
+ x86_64-*)
+ if [[ $ABI = x86 ]] ; then
+ myarch="ia32"
+ else
+ myarch="x64"
+ fi ;;
+ arm*-*)
+ myarch="arm"
+ ;;
+ *) die "Unrecognized CHOST: ${CHOST}"
+ esac
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ emake out/Makefile
+ emake -C out "mksnapshot.${myarch}"
+ pax-mark m "out/Release/mksnapshot.${myarch}"
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}" /usr
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}