summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2010-02-28 10:43:10 +0000
committerPeter Volkov <pva@gentoo.org>2010-02-28 10:43:10 +0000
commit64520147dc71fd039e658bcc91c4538aea3815f7 (patch)
tree0f7e3f462938180977197fe31027650381c6d095 /net-libs/opal
parentRemove old. (diff)
downloadgentoo-2-64520147dc71fd039e658bcc91c4538aea3815f7.tar.gz
gentoo-2-64520147dc71fd039e658bcc91c4538aea3815f7.tar.bz2
gentoo-2-64520147dc71fd039e658bcc91c4538aea3815f7.zip
Fixed build issue with newer celt codec, #300629 thank Matti Nykyri for report and Stefan Knoblich for this fix. Updated ptlib dep, bug #306141, thank Andrey Grozin for report.
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/opal')
-rw-r--r--net-libs/opal/ChangeLog8
-rw-r--r--net-libs/opal/files/opal-3.6.7-celt-0.7-update.patch103
-rw-r--r--net-libs/opal/opal-3.6.7.ebuild4
3 files changed, 113 insertions, 2 deletions
diff --git a/net-libs/opal/ChangeLog b/net-libs/opal/ChangeLog
index eec26d52521d..7ba668c3d99e 100644
--- a/net-libs/opal/ChangeLog
+++ b/net-libs/opal/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/opal
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.61 2010/02/25 00:22:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/ChangeLog,v 1.62 2010/02/28 10:43:09 pva Exp $
+
+ 28 Feb 2010; Peter Volkov <pva@gentoo.org> opal-3.6.7.ebuild,
+ +files/opal-3.6.7-celt-0.7-update.patch:
+ Fixed build issue with newer celt codec, #300629 thank Matti Nykyri for
+ report and Stefan Knoblich for this fix. Updated ptlib dep, bug #306141,
+ thank Andrey Grozin for report.
25 Feb 2010; Robin H. Johnson <robbat2@gentoo.org> opal-3.6.7.ebuild:
Latest opal requires a new ptlib during configure phase: Package
diff --git a/net-libs/opal/files/opal-3.6.7-celt-0.7-update.patch b/net-libs/opal/files/opal-3.6.7-celt-0.7-update.patch
new file mode 100644
index 000000000000..045a20081034
--- /dev/null
+++ b/net-libs/opal/files/opal-3.6.7-celt-0.7-update.patch
@@ -0,0 +1,103 @@
+--- a/plugins/audio/celt/celtcodec.c
++++ b/plugins/audio/celt/celtcodec.c
+@@ -52,7 +52,12 @@ static int init_mode(CELTContext *celt, const struct PluginCodec_Definition * co
+ {
+ int error = 0;
+
+- celt->mode = celt_mode_create(codec->sampleRate, 1, codec->parm.audio.samplesPerFrame, &error);
++ celt->mode = celt_mode_create(codec->sampleRate,
++#if !defined(HAVE_CELT_0_7_0_OR_LATER)
++ 1,
++#endif
++ codec->parm.audio.samplesPerFrame,
++ &error);
+ if (celt->mode == NULL) {
+ return FALSE;
+ }
+@@ -65,6 +70,9 @@ static int init_mode(CELTContext *celt, const struct PluginCodec_Definition * co
+
+ static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
+ {
++#if defined(HAVE_CELT_0_7_0_OR_LATER)
++ int error = 0;
++#endif
+ CELTContext * celt = malloc(sizeof(CELTContext));
+ if (celt == NULL)
+ return NULL;
+@@ -73,8 +81,12 @@ static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
+ free(celt);
+ return NULL;
+ }
+-
++
++#if defined(HAVE_CELT_0_7_0_OR_LATER)
++ celt->encoder_state = celt_encoder_create(celt->mode, 1, &error);
++#else
+ celt->encoder_state = celt_encoder_create(celt->mode);
++#endif
+ if (celt->encoder_state == NULL ) {
+ celt_mode_destroy(celt->mode);
+ free(celt);
+@@ -87,6 +99,9 @@ static void * celt_create_encoder(const struct PluginCodec_Definition * codec)
+
+ static void * celt_create_decoder(const struct PluginCodec_Definition * codec)
+ {
++#if defined(HAVE_CELT_0_7_0_OR_LATER)
++ int error = 0;
++#endif
+ CELTContext * celt = malloc(sizeof(CELTContext));
+ if (celt == NULL)
+ return NULL;
+@@ -96,7 +111,11 @@ static void * celt_create_decoder(const struct PluginCodec_Definition * codec)
+ return NULL;
+ }
+
++#if defined(HAVE_CELT_0_7_0_OR_LATER)
++ celt->decoder_state = celt_decoder_create(celt->mode, 1, &error);
++#else
+ celt->decoder_state = celt_decoder_create(celt->mode);
++#endif
+ if (celt->decoder_state == NULL ) {
+ celt_mode_destroy(celt->mode);
+ free(celt);
+@@ -142,7 +161,9 @@ static int celt_codec_encoder(const struct PluginCodec_Definition * codec,
+ if (*toLen < celt->bytes_per_packet)
+ return FALSE;
+
+-#ifdef HAVE_CELT_0_5_0_OR_LATER
++#if defined(HAVE_CELT_0_7_0_OR_LATER)
++ byteCount = celt_encode(celt->encoder_state, (celt_int16 *)fromPtr, NULL, (char *)toPtr, celt->bytes_per_packet);
++#elif defined(HAVE_CELT_0_5_0_OR_LATER)
+ byteCount = celt_encode(celt->encoder_state, (celt_int16_t *)fromPtr, NULL, (char *)toPtr, celt->bytes_per_packet);
+ #else
+ byteCount = celt_encode(celt->encoder_state, (celt_int16_t *)fromPtr, (char *)toPtr, celt->bytes_per_packet);
+--- a/plugins/configure.ac
++++ b/plugins/configure.ac
+@@ -313,9 +313,12 @@
+ AC_SUBST(CELT_LIBS)
+ AC_DEFINE([HAVE_CELT], [1], [celt])
+ HAVE_CELT=yes
+- PKG_CHECK_EXISTS([celt >= 0.5.0],
+- [
+- AC_DEFINE([HAVE_CELT_0_5_0_OR_LATER], [1], [celt 0.5.0 or later found])
++ PKG_CHECK_EXISTS([celt >= 0.7.0], [
++ AC_DEFINE([HAVE_CELT_0_7_0_OR_LATER], [1], [celt 0.7.0 or later found])
++ ],
++ [PKG_CHECK_EXISTS([celt >= 0.5.0], [
++ AC_DEFINE([HAVE_CELT_0_5_0_OR_LATER], [1], [celt 0.5.0 or later found])
++ ])
+ ])
+ ],
+ [
+--- a/plugins/plugin-config.h.in 2010-02-14 16:07:28.000000000 +0100
++++ b/plugins/plugin-config.h.in 2010-02-14 16:07:42.000000000 +0100
+@@ -15,6 +15,9 @@
+ /* celt 0.5.0 or later found */
+ #undef HAVE_CELT_0_5_0_OR_LATER
+
++/* celt 0.7.0 or later found */
++#undef HAVE_CELT_0_7_0_OR_LATER
++
+ /* Define to 1 if you have the <dlfcn.h> header file. */
+ #undef HAVE_DLFCN_H
+
diff --git a/net-libs/opal/opal-3.6.7.ebuild b/net-libs/opal/opal-3.6.7.ebuild
index 9c1489ec277d..3cfe43543718 100644
--- a/net-libs/opal/opal-3.6.7.ebuild
+++ b/net-libs/opal/opal-3.6.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-3.6.7.ebuild,v 1.2 2010/02/25 00:22:30 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/opal/opal-3.6.7.ebuild,v 1.3 2010/02/28 10:43:09 pva Exp $
EAPI="2"
@@ -87,6 +87,8 @@ src_prepare() {
# upstream patch 2808915
epatch "${FILESDIR}"/${PN}-3.6.4-jdkroot.patch
+ epatch "${FILESDIR}/${P}-celt-0.7-update.patch"
+
# h224 really needs h323 ?
# TODO: get a confirmation in ml
sed -i -e "s:\(.*HAS_H224.*\), \[OPAL_H323\]:\1:" configure.ac \