summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-03-27 14:02:02 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-03-27 14:02:02 +0000
commit4965f7410fc2df8dcf18fdf0de0998d19dd59d5d (patch)
tree100f7ec880db5087380434a405051f5a410930cf /net-libs/qxmpp
parentVersion bump. (diff)
downloadgentoo-2-4965f7410fc2df8dcf18fdf0de0998d19dd59d5d.tar.gz
gentoo-2-4965f7410fc2df8dcf18fdf0de0998d19dd59d5d.tar.bz2
gentoo-2-4965f7410fc2df8dcf18fdf0de0998d19dd59d5d.zip
Bump to 0.8.0, set new SRC_URI. Thanks to 0xd34df00d.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'net-libs/qxmpp')
-rw-r--r--net-libs/qxmpp/ChangeLog9
-rw-r--r--net-libs/qxmpp/qxmpp-0.8.0.ebuild57
2 files changed, 64 insertions, 2 deletions
diff --git a/net-libs/qxmpp/ChangeLog b/net-libs/qxmpp/ChangeLog
index d2ac20232775..767cb36317ce 100644
--- a/net-libs/qxmpp/ChangeLog
+++ b/net-libs/qxmpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/qxmpp
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/qxmpp/ChangeLog,v 1.37 2013/08/19 16:33:28 maksbotan Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/qxmpp/ChangeLog,v 1.38 2014/03/27 14:02:02 maksbotan Exp $
+
+*qxmpp-0.8.0 (27 Mar 2014)
+
+ 27 Mar 2014; Maxim Koltsov <maksbotan@gentoo.org> +qxmpp-0.8.0.ebuild:
+ Bump to 0.8.0, set new SRC_URI. Thanks to 0xd34df00d.
*qxmpp-0.7.6-r1 (19 Aug 2013)
diff --git a/net-libs/qxmpp/qxmpp-0.8.0.ebuild b/net-libs/qxmpp/qxmpp-0.8.0.ebuild
new file mode 100644
index 000000000000..f75d8e3c5271
--- /dev/null
+++ b/net-libs/qxmpp/qxmpp-0.8.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/qxmpp/qxmpp-0.8.0.ebuild,v 1.1 2014/03/27 14:02:02 maksbotan Exp $
+
+EAPI=5
+
+inherit qt4-r2 multilib
+
+DESCRIPTION="A cross-platform C++ XMPP client library based on the Qt framework."
+HOMEPAGE="http://code.google.com/p/qxmpp/"
+SRC_URI="http://download.qxmpp.org/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="debug doc +speex test theora vpx"
+
+RDEPEND="dev-qt/qtcore:4
+ speex? ( media-libs/speex )
+ theora? ( media-libs/libtheora )
+ vpx? ( media-libs/libvpx )"
+DEPEND="${RDEPEND}
+ test? ( dev-qt/qttest:4 )"
+
+src_prepare(){
+ if ! use doc; then
+ sed -i \
+ -e '/SUBDIRS/s/doc//' \
+ -e '/INSTALLS/d' \
+ qxmpp.pro || die "sed for removing docs failed"
+ fi
+ if ! use test; then
+ sed -i -e '/SUBDIRS/s/tests//' \
+ qxmpp.pro || die "sed for removing tests failed"
+ fi
+ qt4-r2_src_prepare
+}
+
+src_configure(){
+ local conf_speex
+ local conf_theora
+ local conf_vpx
+
+ use speex && conf_speex="QXMPP_USE_SPEEX=1"
+ use theora && conf_theora="QXMPP_USE_THEORA=1"
+ use vpx && conf_vpx="QXMPP_USE_VPX=1"
+
+ eqmake4 "${S}"/qxmpp.pro "PREFIX=${EPREFIX}/usr" "LIBDIR=$(get_libdir)" "${conf_speex}" "${conf_theora}" "${conf_vpx}"
+}
+
+src_install() {
+ qt4-r2_src_install
+ if use doc; then
+ # Use proper path for documentation
+ mv "${ED}"/usr/share/doc/${PN} "${ED}"/usr/share/doc/${PF} || die "doc mv failed"
+ fi
+}