summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-31 11:54:42 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-31 11:54:42 +0000
commit0e130c935ce9986ae6a44afc8b235fcaecda2ac2 (patch)
tree9bc0945dcf123f20c5b8fcd898a41bce327801c6 /net-libs/rb_libtorrent
parentVersion bump (diff)
downloadgentoo-2-0e130c935ce9986ae6a44afc8b235fcaecda2ac2.tar.gz
gentoo-2-0e130c935ce9986ae6a44afc8b235fcaecda2ac2.tar.bz2
gentoo-2-0e130c935ce9986ae6a44afc8b235fcaecda2ac2.zip
Make it build against dev-libs/boost-1.45. Bug #352001
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog6
-rw-r--r--net-libs/rb_libtorrent/files/rb_libtorrent-0.14.12_boost-1.45.patch13
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild5
3 files changed, 21 insertions, 3 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index f3e2adc82dc0..84564ee19ef3 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.101 2011/01/13 20:51:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.102 2011/01/31 11:54:42 hwoarang Exp $
+
+ 31 Jan 2011; Markos Chandras <hwoarang@gentoo.org>
+ rb_libtorrent-0.14.12.ebuild, +files/rb_libtorrent-0.14.12_boost-1.45.patch:
+ Make it build against dev-libs/boost-1.45. Bug #352001
13 Jan 2011; Kacper Kowalik <xarthisius@gentoo.org>
rb_libtorrent-0.15.1.ebuild:
diff --git a/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.12_boost-1.45.patch b/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.12_boost-1.45.patch
new file mode 100644
index 000000000000..7dbf2304df2b
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/rb_libtorrent-0.14.12_boost-1.45.patch
@@ -0,0 +1,13 @@
+Index: libtorrent-rasterbar-0.14.12/include/libtorrent/udp_socket.hpp
+===================================================================
+--- libtorrent-rasterbar-0.14.12.orig/include/libtorrent/udp_socket.hpp
++++ libtorrent-rasterbar-0.14.12/include/libtorrent/udp_socket.hpp
+@@ -37,7 +37,7 @@ POSSIBILITY OF SUCH DAMAGE.
+ #include "libtorrent/buffer.hpp"
+ #include "libtorrent/session_settings.hpp"
+
+-#include <vector>
++#include <list>
+ #include <boost/function.hpp>
+ #include <boost/thread/mutex.hpp>
+
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild
index 046c3907afae..7e5b51324e79 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild,v 1.2 2010/11/11 15:27:23 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild,v 1.3 2011/01/31 11:54:42 hwoarang Exp $
EAPI="2"
inherit autotools eutils flag-o-matic versionator
@@ -30,6 +30,7 @@ RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.14.9-as-needed-fix.patch #276873
epatch "${FILESDIR}"/${PN}-0.14.8-boost-detect.patch #295474
+ epatch "${FILESDIR}"/${P}_boost-1.45.patch #352001
rm ltmain.sh #298069
eautoreconf
}