summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-08-02 14:18:30 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-08-02 14:18:30 +0000
commit8f442ea2eb7f297c7c3bccbdf83da59d4b6fbef4 (patch)
treee5fd37ab51393aa17b86dd8680b53f2fdb0e0c1b /net-libs/rb_libtorrent
parentVersion bump (diff)
downloadgentoo-2-8f442ea2eb7f297c7c3bccbdf83da59d4b6fbef4.tar.gz
gentoo-2-8f442ea2eb7f297c7c3bccbdf83da59d4b6fbef4.tar.bz2
gentoo-2-8f442ea2eb7f297c7c3bccbdf83da59d4b6fbef4.zip
Version bump. remove old ebuilds
(Portage version: 2.2.0_alpha46/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog9
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.14.9-r1.ebuild77
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.15.7.ebuild (renamed from net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild)41
3 files changed, 27 insertions, 100 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 5994823049e8..8d7a0421e7bd 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.112 2011/05/30 14:22:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.113 2011/08/02 14:18:30 hwoarang Exp $
+
+*rb_libtorrent-0.15.7 (02 Aug 2011)
+
+ 02 Aug 2011; Markos Chandras <hwoarang@gentoo.org>
+ -rb_libtorrent-0.14.9-r1.ebuild, -rb_libtorrent-0.14.12.ebuild,
+ +rb_libtorrent-0.15.7.ebuild:
+ Version bump. remove old ebuilds
30 May 2011; Markos Chandras <hwoarang@gentoo.org>
rb_libtorrent-0.14.12.ebuild:
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.9-r1.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.14.9-r1.ebuild
deleted file mode 100644
index b4e344661bb8..000000000000
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.9-r1.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.9-r1.ebuild,v 1.4 2010/11/11 15:27:23 ssuominen Exp $
-
-EAPI="2"
-inherit autotools eutils flag-o-matic versionator
-
-MY_P=${P/rb_/}
-MY_P=${MY_P/torrent/torrent-rasterbar}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
-HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
-SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~x86-fbsd"
-IUSE="debug doc examples python test"
-RESTRICT="test"
-
-DEPEND="|| ( >=dev-libs/boost-1.35
- ( ~dev-libs/boost-1.34.1 dev-cpp/asio ) )
- python? ( >=dev-libs/boost-1.35.0-r5[python] dev-lang/python:2.6[threads] )
- >=sys-devel/libtool-2.2
- sys-libs/zlib
- examples? ( !net-p2p/mldonkey )" #292998
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.14.9-as-needed-fix.patch #276873
- epatch "${FILESDIR}"/${PN}-0.14.8-boost-detect.patch #295474
- rm ltmain.sh #298069
- eautoreconf
-}
-
-src_configure() {
- append-ldflags -pthread
-
- # use multi-threading versions of boost libs
- local BOOST_LIBS="--with-boost-system=boost_system-mt \
- --with-boost-asio=boost_system-mt \
- --with-boost-filesystem=boost_filesystem-mt \
- --with-boost-thread=boost_thread-mt \
- --with-boost-regex=boost_regex-mt \
- --with-boost-python=boost_python-mt \
- --with-boost-program_options=boost_program_options-mt"
-
- # detect boost version and location, bug 295474
- BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
- BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
- BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
- BOOST_INC="/usr/include/boost-${BOOST_VER}"
- BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
-
- local LOGGING
- use debug && LOGGING="--with-logging=verbose"
-
- econf $(use_enable debug) \
- $(use_enable test tests) \
- $(use_enable examples) \
- $(use_enable python python-binding) \
- --with-zlib=system \
- --with-asio=system \
- ${LOGGING} \
- --with-boost=${BOOST_INC} \
- --with-boost-libdir=${BOOST_LIB} \
- ${BOOST_LIBS}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die 'emake install failed'
- dodoc ChangeLog AUTHORS NEWS README || die 'dodoc failed'
- if use doc ; then
- dohtml docs/* || die "Could not install HTML documentation"
- fi
-}
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.15.7.ebuild
index fa78183658d4..f3c29d23b35b 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.15.7.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.14.12.ebuild,v 1.5 2011/05/30 14:22:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.15.7.ebuild,v 1.1 2011/08/02 14:18:30 hwoarang Exp $
EAPI="2"
-inherit autotools eutils flag-o-matic versionator
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="threads"
+
+inherit eutils versionator python
MY_P=${P/rb_/}
MY_P=${MY_P/torrent/torrent-rasterbar}
@@ -15,38 +18,32 @@ SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd"
-IUSE="debug doc examples python test"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl"
RESTRICT="test"
-DEPEND="|| ( >=dev-libs/boost-1.35
- ( ~dev-libs/boost-1.34.1 dev-cpp/asio ) )
- python? ( >=dev-libs/boost-1.35.0-r5[python] dev-lang/python:2.6[threads] )
+DEPEND=">=dev-libs/boost-1.36[python?]
>=sys-devel/libtool-2.2
sys-libs/zlib
- examples? ( !net-p2p/mldonkey )" #292998
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl )"
+
RDEPEND="${DEPEND}"
+pkg_setup() {
+ use python && python_set_active_version 2
+}
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.14.9-as-needed-fix.patch #276873
- epatch "${FILESDIR}"/${PN}-0.14.8-boost-detect.patch #295474
- epatch "${FILESDIR}"/${P}_boost-1.45.patch #352001
- rm ltmain.sh #298069
- eautoreconf
+ use python && python_convert_shebangs -r 2 .
}
src_configure() {
- append-ldflags -pthread
-
# use multi-threading versions of boost libs
local BOOST_LIBS="--with-boost-system=boost_system-mt \
- --with-boost-asio=boost_system-mt \
--with-boost-filesystem=boost_filesystem-mt \
--with-boost-thread=boost_thread-mt \
- --with-boost-regex=boost_regex-mt \
- --with-boost-python=boost_python-mt \
- --with-boost-program_options=boost_program_options-mt"
-
+ --with-boost-python=boost_python-mt"
# detect boost version and location, bug 295474
BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
@@ -55,14 +52,14 @@ src_configure() {
BOOST_LIB="/usr/$(get_libdir)/boost-${BOOST_VER}"
local LOGGING
- use debug && LOGGING="--with-logging=verbose"
+ use debug && LOGGING="--enable-logging=verbose"
econf $(use_enable debug) \
$(use_enable test tests) \
$(use_enable examples) \
$(use_enable python python-binding) \
+ $(use_enable ssl encryption) \
--with-zlib=system \
- --with-asio=system \
${LOGGING} \
--with-boost=${BOOST_INC} \
--with-boost-libdir=${BOOST_LIB} \