summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-10-13 21:49:50 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-10-13 21:49:50 +0000
commitb20a68a296d9f58462aa7bb4eadfebdff859e99b (patch)
treecf26d45f1232fde4c9f0c2decee9d3cd66c3642b /net-libs/telepathy-glib
parentCreate .keepinfodir file to prevent portage from rebuilding the Info dir, (diff)
downloadgentoo-2-b20a68a296d9f58462aa7bb4eadfebdff859e99b.tar.gz
gentoo-2-b20a68a296d9f58462aa7bb4eadfebdff859e99b.tar.bz2
gentoo-2-b20a68a296d9f58462aa7bb4eadfebdff859e99b.zip
Fix build with multiple python installation, bug #315323. Add support for vala bindings needed for gnome 2.32.
(Portage version: 2.2_rc89/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog7
-rw-r--r--net-libs/telepathy-glib/metadata.xml1
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.12.0.ebuild32
3 files changed, 32 insertions, 8 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 4d5e9318168f..a813ce213df9 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.53 2010/10/09 15:21:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.54 2010/10/13 21:49:50 eva Exp $
+
+ 13 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ telepathy-glib-0.12.0.ebuild, metadata.xml:
+ Fix build with multiple python installation, bug #315323. Add support for
+ vala bindings needed for gnome 2.32.
09 Oct 2010; Samuli Suominen <ssuominen@gentoo.org>
telepathy-glib-0.10.1.ebuild:
diff --git a/net-libs/telepathy-glib/metadata.xml b/net-libs/telepathy-glib/metadata.xml
index f8f82209b104..0a84fc951f34 100644
--- a/net-libs/telepathy-glib/metadata.xml
+++ b/net-libs/telepathy-glib/metadata.xml
@@ -11,6 +11,7 @@
<use>
<flag name="introspection">Use <pkg>dev-libs/gobject-introspection</pkg>
for introspection</flag>
+ <flag name="vala">Enable bindings for <pkg>dev-lang/vala</pkg></flag>
</use>
</pkgmetadata>
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.12.0.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.12.0.ebuild
index 73be431a4bb1..e1222974d8b9 100644
--- a/net-libs/telepathy-glib/telepathy-glib-0.12.0.ebuild
+++ b/net-libs/telepathy-glib/telepathy-glib-0.12.0.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.12.0.ebuild,v 1.2 2010/10/06 21:01:10 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.12.0.ebuild,v 1.3 2010/10/13 21:49:50 eva Exp $
EAPI="2"
+PYTHON_DEPEND="2:2.5"
+
+inherit python
DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
HOMEPAGE="http://telepathy.freedesktop.org"
@@ -11,25 +14,40 @@ SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="debug +introspection"
+IUSE="debug +introspection vala"
RDEPEND=">=dev-libs/glib-2.24
>=dev-libs/dbus-glib-0.82
- >=dev-lang/python-2.5
- introspection? ( >=dev-libs/gobject-introspection-0.6.14 )"
-
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14 )
+ vala? (
+ dev-lang/vala:0.10[vapigen]
+ >=dev-libs/gobject-introspection-0.9.6 )
+"
DEPEND="${RDEPEND}
dev-libs/libxslt
>=dev-util/pkgconfig-0.21"
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
src_configure() {
- # configure help says vala-bindings are experimental
+ local myconf
+
+ if use vala; then
+ myconf="--enable-introspection
+ VALAC=$(type -p valac-0.10)
+ VAPIGEN=$(type -p vapigen-0.10)"
+ fi
+
econf \
$(use_enable debug) \
$(use_enable debug backtrace) \
$(use_enable debug handle-leak-debug) \
$(use_enable introspection) \
- --disable-vala-bindings
+ $(use_enable vala vala-bindings) \
+ ${myconf}
}
src_test() {