summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-07-24 15:13:00 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-07-24 15:13:00 +0000
commitd2e68b4c818167dd0ef877f6a84b7ea2722c0164 (patch)
tree2b06585615d4b798df1e1ca512d1ef94ff1296a8 /net-libs/webkit-gtk
parentRevbump N. 2 for all testing versions of Python wrt bug #374579 and linux-3 (diff)
downloadgentoo-2-d2e68b4c818167dd0ef877f6a84b7ea2722c0164.tar.gz
gentoo-2-d2e68b4c818167dd0ef877f6a84b7ea2722c0164.tar.bz2
gentoo-2-d2e68b4c818167dd0ef877f6a84b7ea2722c0164.zip
Clean up old revisions, due to various security bugs.
(Portage version: 2.2.0_alpha43/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog6
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild112
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.2.6.ebuild117
3 files changed, 5 insertions, 230 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index fd8469c033a7..dca98539edd7 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.113 2011/07/15 13:46:35 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.114 2011/07/24 15:13:00 eva Exp $
+
+ 24 Jul 2011; Gilles Dartiguelongue <eva@gentoo.org> -webkit-gtk-1.2.5.ebuild,
+ -webkit-gtk-1.2.6.ebuild:
+ Clean up old revisions, due to various security bugs.
15 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org>
webkit-gtk-1.4.1-r200.ebuild, webkit-gtk-1.4.1-r300.ebuild:
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild
deleted file mode 100644
index ed0ef01cd04f..000000000000
--- a/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild,v 1.10 2011/01/09 14:25:43 ranger Exp $
-
-EAPI="3"
-
-inherit autotools flag-o-matic eutils virtualx
-
-MY_P="webkit-${PV}"
-DESCRIPTION="Open source web browser engine"
-HOMEPAGE="http://www.webkitgtk.org/"
-SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2 LGPL-2.1 BSD"
-SLOT="2"
-KEYWORDS="alpha amd64 arm ia64 ppc sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-# geoclue is missing
-IUSE="aqua coverage debug doc +gstreamer introspection"
-
-# use sqlite, svg by default
-# dependency on >=x11-libs/gtk+-2.13 for gail
-# XXX: Quartz patch does not apply
-RDEPEND="
- dev-libs/libxml2
- dev-libs/libxslt
- virtual/jpeg
- >=media-libs/libpng-1.4
- x11-libs/cairo
- >=x11-libs/gtk+-2.13:2[aqua=]
- >=dev-libs/glib-2.21.3:2
- >=dev-libs/icu-3.8.1-r1
- >=net-libs/libsoup-2.29.90:2.4
- >=dev-db/sqlite-3
- >=app-text/enchant-0.22
- >=x11-libs/pango-1.12
-
- gstreamer? (
- media-libs/gstreamer:0.10
- >=media-libs/gst-plugins-base-0.10.25:0.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.6.2 )"
-
-DEPEND="${RDEPEND}
- >=sys-devel/flex-2.5.33
- sys-devel/gettext
- dev-util/gperf
- dev-util/pkgconfig
- dev-util/gtk-doc-am
- doc? ( >=dev-util/gtk-doc-1.10 )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
- # https://bugs.webkit.org/show_bug.cgi?id=19775
- use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
-
- # intermediate MacPorts hack while upstream bug is not fixed properly
- # https://bugs.webkit.org/show_bug.cgi?id=28727
- use aqua && epatch "${FILESDIR}"/${P}-darwin-quartz.patch
-
- # Fix build on Darwin8 (10.4 Tiger)
- epatch "${FILESDIR}"/${P}-darwin8.patch
-
- # Don't force -O2
- sed -i 's/-O2//g' "${S}"/configure.ac || die "sed failed"
-
- # Don't build tests if not needed, part of bug #343249
- epatch "${FILESDIR}/${PN}-1.2.5-tests-build.patch"
-
- # Prevent maintainer mode from being triggered during make
- AT_M4DIR=autotools eautoreconf
-}
-
-src_configure() {
- # It doesn't compile on alpha without this in LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- # Sigbuses on SPARC with mcpu
- use sparc && filter-flags "-mcpu=*" "-mtune=*"
-
- local myconf
-
- myconf="
- --disable-introspection
- --disable-web_sockets
- $(use_enable coverage)
- $(use_enable debug)
- $(use_enable gstreamer video)
- $(use_enable introspection)
- $(use aqua && echo "--with-font-backend=pango --with-target=quartz")"
- # Disable web-sockets per bug #326547
-
- econf ${myconf}
-}
-
-src_compile() {
- # Fix sandbox error with USE="introspection"
- # https://bugs.webkit.org/show_bug.cgi?id=35471
- emake XDG_DATA_HOME="${T}/.local" || die "Compile failed"
-}
-
-src_test() {
- unset DISPLAY
- # Tests need virtualx, bug #294691, bug #310695
- # Set XDG_DATA_HOME for introspection tools, bug #323669
- Xemake check XDG_DATA_HOME="${T}/.local" || die "Test phase failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
- dodoc WebKit/gtk/{NEWS,ChangeLog} || die "dodoc failed"
-}
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.2.6.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.2.6.ebuild
deleted file mode 100644
index 90e8839b0dbf..000000000000
--- a/net-libs/webkit-gtk/webkit-gtk-1.2.6.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.2.6.ebuild,v 1.9 2011/01/23 14:42:06 armin76 Exp $
-
-EAPI="3"
-
-inherit autotools flag-o-matic eutils virtualx
-
-MY_P="webkit-${PV}"
-DESCRIPTION="Open source web browser engine"
-HOMEPAGE="http://www.webkitgtk.org/"
-SRC_URI="http://www.webkitgtk.org/${MY_P}.tar.gz"
-
-LICENSE="LGPL-2 LGPL-2.1 BSD"
-SLOT="2"
-KEYWORDS="alpha amd64 arm ia64 ppc ~ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
-# geoclue is missing
-IUSE="aqua coverage debug doc +gstreamer introspection +jit test"
-
-# use sqlite, svg by default
-# dependency on >=x11-libs/gtk+-2.13 for gail
-# XXX: Quartz patch does not apply
-RDEPEND="
- dev-libs/libxml2
- dev-libs/libxslt
- virtual/jpeg
- >=media-libs/libpng-1.4
- x11-libs/cairo
- >=x11-libs/gtk+-2.13:2[aqua=]
- >=dev-libs/glib-2.21.3:2
- >=dev-libs/icu-3.8.1-r1
- >=net-libs/libsoup-2.29.90:2.4
- >=dev-db/sqlite-3
- >=app-text/enchant-0.22
- >=x11-libs/pango-1.12
-
- gstreamer? (
- media-libs/gstreamer:0.10
- >=media-libs/gst-plugins-base-0.10.25:0.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.6.2 )"
-
-DEPEND="${RDEPEND}
- >=sys-devel/flex-2.5.33
- sys-devel/gettext
- dev-util/gperf
- dev-util/pkgconfig
- dev-util/gtk-doc-am
- doc? ( >=dev-util/gtk-doc-1.10 )
- test? ( x11-themes/hicolor-icon-theme )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- # FIXME: Fix unaligned accesses on ARM, IA64 and SPARC
- # https://bugs.webkit.org/show_bug.cgi?id=19775
- use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
-
- # intermediate MacPorts hack while upstream bug is not fixed properly
- # https://bugs.webkit.org/show_bug.cgi?id=28727
- use aqua && epatch "${FILESDIR}"/${PN}-1.2.5-darwin-quartz.patch
-
- # Fix build on Darwin8 (10.4 Tiger)
- epatch "${FILESDIR}"/${PN}-1.2.5-darwin8.patch
-
- # Don't force -O2
- sed -i 's/-O2//g' "${S}"/configure.ac || die "sed failed"
-
- # Don't build tests if not needed, part of bug #343249
- epatch "${FILESDIR}/${PN}-1.2.5-tests-build.patch"
-
- # Prevent maintainer mode from being triggered during make
- AT_M4DIR=autotools eautoreconf
-}
-
-src_configure() {
- # It doesn't compile on alpha without this in LDFLAGS
- use alpha && append-ldflags "-Wl,--no-relax"
-
- # Sigbuses on SPARC with mcpu and co.
- use sparc && filter-flags "-mcpu=*" "-mvis" "-mtune=*"
-
- # https://bugs.webkit.org/show_bug.cgi?id=42070 , #301634
- use ppc64 && append-flags "-mminimal-toc"
-
- local myconf
-
- myconf="
- --disable-introspection
- --disable-web_sockets
- $(use_enable coverage)
- $(use_enable debug)
- $(use_enable gstreamer video)
- $(use_enable introspection)
- $(use_enable jit)
- $(use aqua && echo "--with-font-backend=pango --with-target=quartz")"
- # Disable web-sockets per bug #326547
-
- econf ${myconf}
-}
-
-src_compile() {
- # Fix sandbox error with USE="introspection"
- # https://bugs.webkit.org/show_bug.cgi?id=35471
- emake XDG_DATA_HOME="${T}/.local" || die "Compile failed"
-}
-
-src_test() {
- unset DISPLAY
- # Tests need virtualx, bug #294691, bug #310695
- # Set XDG_DATA_HOME for introspection tools, bug #323669
- Xemake check XDG_DATA_HOME="${T}/.local" || die "Test phase failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Install failed"
- dodoc WebKit/gtk/{NEWS,ChangeLog} || die "dodoc failed"
-}