summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2009-07-21 21:01:23 +0000
committerMarkus Ullmann <jokey@gentoo.org>2009-07-21 21:01:23 +0000
commitdb6c4070c42124865320dd24b4cdf6822f8cdac6 (patch)
treeff7461376b9df553d224fefce786ec1bdc2b37dd /net-libs/webkit-gtk
parentFix webkit names (diff)
downloadgentoo-2-db6c4070c42124865320dd24b4cdf6822f8cdac6.tar.gz
gentoo-2-db6c4070c42124865320dd24b4cdf6822f8cdac6.tar.bz2
gentoo-2-db6c4070c42124865320dd24b4cdf6822f8cdac6.zip
Add webkit nightly with wx support
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog9
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-0_p46126-cxxmissing.patch10
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-0_p46126-wxslot-gentoo.patch12
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild83
4 files changed, 113 insertions, 1 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index ae16b7e43342..a658c3187e40 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.39 2009/06/30 14:45:30 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.40 2009/07/21 21:01:23 jokey Exp $
+
+*webkit-gtk-0_p46126 (21 Jul 2009)
+
+ 21 Jul 2009; Markus Ullmann <jokey@gentoo.org>
+ +webkit-gtk-0_p46126.ebuild, +files/webkit-gtk-0_p46126-cxxmissing.patch,
+ +files/webkit-gtk-0_p46126-wxslot-gentoo.patch:
+ Add webkit nightly with wx support
30 Jun 2009; Mart Raudsepp <leio@gentoo.org> -webkit-gtk-0_p40220.ebuild:
Remove security vulnerable revision
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-cxxmissing.patch b/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-cxxmissing.patch
new file mode 100644
index 000000000000..0f9afdf3baef
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-cxxmissing.patch
@@ -0,0 +1,10 @@
+--- ./configure.ac.orig 2009-07-18 01:39:33.000000000 +0200
++++ ./configure.ac 2009-07-21 21:10:37.286329878 +0200
+@@ -79,6 +79,7 @@
+ AC_DISABLE_STATIC
+ AC_LIBTOOL_WIN32_DLL
+ AC_PROG_LIBTOOL
++AC_PROG_CXX
+ # use dolt to speedup the build
+ DOLT
+
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-wxslot-gentoo.patch b/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-wxslot-gentoo.patch
new file mode 100644
index 000000000000..171be72a51ad
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-0_p46126-wxslot-gentoo.patch
@@ -0,0 +1,12 @@
+diff -urN ./WebKit.orig/wx/wxwk-settings.bkl ./WebKit/wx/wxwk-settings.bkl
+--- ./WebKit.orig/wx/wxwk-settings.bkl 2009-07-13 01:13:26.000000000 +0200
++++ ./WebKit/wx/wxwk-settings.bkl 2009-07-21 22:07:34.182387455 +0200
+@@ -33,7 +33,7 @@
+ <set var="WX_UNICODE">1</set>
+ <set var="WX_SHARED">1</set>
+
+- <include file="presets/wx.bkl"/>
++ <include file="presets/wx28.bkl"/>
+ <include file="presets/wxwebkit.bkl"/>
+ <include file="dependencies.bkl"/>
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild b/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild
new file mode 100644
index 000000000000..9f0b3689ba2a
--- /dev/null
+++ b/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-0_p46126.ebuild,v 1.1 2009/07/21 21:01:23 jokey Exp $
+
+EAPI=2
+
+AT_M4DIR=./autotools
+WX_GTK_VER="2.8"
+inherit autotools flag-o-matic eutils wxwidgets
+
+MY_P="WebKit-r${PV/0\_p}"
+DESCRIPTION="Open source web browser engine"
+HOMEPAGE="http://www.webkit.org/"
+SRC_URI="http://nightly.webkit.org/files/trunk/src/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2 LGPL-2.1 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 -ia64 ~ppc -sparc ~x86 ~x86-fbsd"
+IUSE="coverage debug gstreamer pango soup sqlite svg wxwidgets xslt"
+
+RDEPEND=">=x11-libs/gtk+-2.8
+ >=dev-libs/icu-3.8.1-r1
+ >=net-misc/curl-7.15
+ media-libs/jpeg
+ media-libs/libpng
+ dev-libs/libxml2
+ sqlite? ( >=dev-db/sqlite-3 )
+ gstreamer? (
+ >=media-libs/gst-plugins-base-0.10
+ )
+ soup? ( >=net-libs/libsoup-2.27.4 )
+ xslt? ( dev-libs/libxslt )
+ pango? ( x11-libs/pango )
+ wxwidgets? ( x11-libs/wxGTK dev-util/bakefile )"
+
+DEPEND="${RDEPEND}
+ dev-util/gperf
+ dev-util/pkgconfig
+ virtual/perl-Text-Balanced"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-cxxmissing.patch"
+ epatch "${FILESDIR}/${P}-wxslot-gentoo.patch"
+ gtkdocize
+ eautoreconf
+}
+
+src_configure() {
+ # It doesn't compile on alpha without this LDFLAGS
+ use alpha && append-ldflags "-Wl,--no-relax"
+
+ local myconf
+ use pango && myconf="${myconf} --with-font-backend=pango"
+ use soup && myconf="${myconf} --with-http-backend=soup"
+
+ econf \
+ $(use_enable sqlite database) \
+ $(use_enable sqlite icon-database) \
+ $(use_enable sqlite dom-storage) \
+ $(use_enable sqlite offline-web-applications) \
+ $(use_enable gstreamer video) \
+ $(use_enable svg) \
+ $(use_enable debug) \
+ $(use_enable xslt) \
+ $(use_enable coverage) \
+ ${myconf} \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake || die "emake failed"
+
+ if use wxwidgets ; then
+ cd ${S}/WebKitTools/wx
+ ./build-wxwebkit || die "wxwebkit build failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed"
+}