summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2010-07-11 12:30:17 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2010-07-11 12:30:17 +0000
commit694f3c0549187592b3fd27b7c3debe4eab6a9541 (patch)
tree7d0b6ee1e8f96936b0b72accc3b30ff2bbad6e27 /net-libs/xulrunner
parentstable x86, bug 325149 (diff)
downloadgentoo-2-694f3c0549187592b3fd27b7c3debe4eab6a9541.tar.gz
gentoo-2-694f3c0549187592b3fd27b7c3debe4eab6a9541.tar.bz2
gentoo-2-694f3c0549187592b3fd27b7c3debe4eab6a9541.zip
Add patch for ARM OS detection, bug 327783
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'net-libs/xulrunner')
-rw-r--r--net-libs/xulrunner/ChangeLog7
-rw-r--r--net-libs/xulrunner/files/xulrunner-1.9.2-arm-fixes.patch35
-rw-r--r--net-libs/xulrunner/xulrunner-1.9.2.4.ebuild5
-rw-r--r--net-libs/xulrunner/xulrunner-1.9.2.6.ebuild5
4 files changed, 49 insertions, 3 deletions
diff --git a/net-libs/xulrunner/ChangeLog b/net-libs/xulrunner/ChangeLog
index 32855b000fd4..6a8e6787472a 100644
--- a/net-libs/xulrunner/ChangeLog
+++ b/net-libs/xulrunner/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/xulrunner
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.324 2010/07/08 20:08:24 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/ChangeLog,v 1.325 2010/07/11 12:30:16 nirbheek Exp $
+
+ 11 Jul 2010; Nirbheek Chauhan <nirbheek@gentoo.org>
+ xulrunner-1.9.2.4.ebuild, xulrunner-1.9.2.6.ebuild,
+ +files/xulrunner-1.9.2-arm-fixes.patch:
+ Add patch for ARM OS detection, bug 327783
08 Jul 2010; Brent Baude <ranger@gentoo.org> xulrunner-1.9.2.4.ebuild:
Marking xulrunner-1.9.2.4 ppc64 and ppc for bug 324735
diff --git a/net-libs/xulrunner/files/xulrunner-1.9.2-arm-fixes.patch b/net-libs/xulrunner/files/xulrunner-1.9.2-arm-fixes.patch
new file mode 100644
index 000000000000..a726209e6373
--- /dev/null
+++ b/net-libs/xulrunner/files/xulrunner-1.9.2-arm-fixes.patch
@@ -0,0 +1,35 @@
+Fix arm OS detection
+
+https://bugs.gentoo.org/327783
+https://bugzilla.mozilla.org/show_bug.cgi?id=577319
+---
+--- configure.in
++++ configure.in
+@@ -1424,9 +1424,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac
+--- js/src/configure.in
++++ js/src/configure.in
+@@ -1162,9 +1162,11 @@
+ CPU_ARCH="$OS_TEST"
+ ;;
+
+-arm)
++arm*)
+ if test "$OS_TARGET" = "WINCE"; then
+ CPU_ARCH="$OS_TEST"
++ else
++ CPU_ARCH="arm"
+ fi
+ ;;
+ esac
diff --git a/net-libs/xulrunner/xulrunner-1.9.2.4.ebuild b/net-libs/xulrunner/xulrunner-1.9.2.4.ebuild
index ba404b95260f..dfbc5fe2ad4a 100644
--- a/net-libs/xulrunner/xulrunner-1.9.2.4.ebuild
+++ b/net-libs/xulrunner/xulrunner-1.9.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.9.2.4.ebuild,v 1.6 2010/07/08 20:08:24 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.9.2.4.ebuild,v 1.7 2010/07/11 12:30:16 nirbheek Exp $
EAPI="2"
WANT_AUTOCONF="2.1"
@@ -77,6 +77,9 @@ src_prepare() {
# Ensure we find myspell dict.
epatch "${FILESDIR}/1002_fix-system-hunspell-dict-detections.patch"
+ # ARM fixes, bug 327783
+ epatch "${FILESDIR}/${PN}-1.9.2-arm-fixes.patch"
+
# Allow user to apply additional patches without modifing ebuild
epatch_user
diff --git a/net-libs/xulrunner/xulrunner-1.9.2.6.ebuild b/net-libs/xulrunner/xulrunner-1.9.2.6.ebuild
index d4f9479992e3..8f6589a93bd4 100644
--- a/net-libs/xulrunner/xulrunner-1.9.2.6.ebuild
+++ b/net-libs/xulrunner/xulrunner-1.9.2.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.9.2.6.ebuild,v 1.1 2010/06/27 12:27:27 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xulrunner/xulrunner-1.9.2.6.ebuild,v 1.2 2010/07/11 12:30:16 nirbheek Exp $
EAPI="2"
WANT_AUTOCONF="2.1"
@@ -77,6 +77,9 @@ src_prepare() {
# Ensure we find myspell dict.
epatch "${FILESDIR}/1002_fix-system-hunspell-dict-detections.patch"
+ # ARM fixes, bug 327783
+ epatch "${FILESDIR}/${PN}-1.9.2-arm-fixes.patch"
+
# Allow user to apply additional patches without modifing ebuild
epatch_user