summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Weiler <pylon@gentoo.org>2008-03-29 23:35:06 +0000
committerLars Weiler <pylon@gentoo.org>2008-03-29 23:35:06 +0000
commit82e5f77d5d19b1697a541e6c0cbe1db5d59e9e9b (patch)
treecb0b8ebdd4d6a377b1161714ae768f470c3df8e9 /net-libs/xyssl
parentNew ebuild for bug #142175 (diff)
downloadgentoo-2-82e5f77d5d19b1697a541e6c0cbe1db5d59e9e9b.tar.gz
gentoo-2-82e5f77d5d19b1697a541e6c0cbe1db5d59e9e9b.tar.bz2
gentoo-2-82e5f77d5d19b1697a541e6c0cbe1db5d59e9e9b.zip
Version bump; security bug #214206.
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs/xyssl')
-rw-r--r--net-libs/xyssl/xyssl-0.9.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-libs/xyssl/xyssl-0.9.ebuild b/net-libs/xyssl/xyssl-0.9.ebuild
new file mode 100644
index 000000000000..a87c21044201
--- /dev/null
+++ b/net-libs/xyssl/xyssl-0.9.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/xyssl/xyssl-0.9.ebuild,v 1.1 2008/03/29 23:35:06 pylon Exp $
+
+DESCRIPTION="Cryptographic library for embedded systems"
+HOMEPAGE="http://xyssl.org/"
+SRC_URI="http://xyssl.org/code/download/${P}-gpl.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE="examples sse2"
+
+DEPEND="virtual/libc"
+
+src_compile() {
+ cd "${S}/library"
+ if use sse2 ; then
+ sed -i '15iCFLAGS += -DHAVE_SSE2 -fPIC' Makefile
+ else
+ sed -i '15iCFLAGS += -fPIC' Makefile
+ fi
+ emake libxyssl.a || die "emake failed"
+ emake libxyssl.so || die "emake failed"
+
+ if use examples ; then
+ cd "${S}"/programs
+ emake all
+ fi
+}
+
+src_test() {
+ cd "${S}"/programs
+ emake test/selftest
+ ./test/selftest || die "selftest failed"
+}
+
+src_install() {
+ dodir /usr/include/xyssl
+ insinto /usr/include/xyssl
+ doins include/xyssl/*.h
+ dolib.so library/libxyssl.so
+ dolib.a library/libxyssl.a
+
+ if use examples ; then
+ for p in programs/*/* ; do
+ if [ -x "${p}" ] ; then
+ f=xyssl_`basename "${p}"`
+ newbin "${p}" "${f}"
+ fi
+ done
+ for e in aes hash pkey ssl test ; do
+ docinto "${e}"
+ dodoc programs/"${e}"/*.c
+ dodoc programs/"${e}"/*.txt
+ done
+ fi
+}