summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-03-09 05:40:55 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-03-09 05:40:55 +0000
commit0d7e87669a9f826ba0e71c7768528aa66a370c60 (patch)
treea1d4f95b19de9782b5831cc88ed5d6f930469642 /net-libs
parentVersion bump #357803 by tman. (diff)
downloadgentoo-2-0d7e87669a9f826ba0e71c7768528aa66a370c60.tar.gz
gentoo-2-0d7e87669a9f826ba0e71c7768528aa66a370c60.tar.bz2
gentoo-2-0d7e87669a9f826ba0e71c7768528aa66a370c60.zip
Bump to 0.13.16, all tests pass
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-glib/ChangeLog8
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.13.16.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 9f73333c186c..a560bdde3c1a 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.65 2011/02/27 16:40:15 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.66 2011/03/09 05:40:55 nirbheek Exp $
+
+*telepathy-glib-0.13.16 (09 Mar 2011)
+
+ 09 Mar 2011; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +telepathy-glib-0.13.16.ebuild:
+ Bump to 0.13.16, all tests pass
27 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org>
-telepathy-glib-0.10.7.ebuild, -telepathy-glib-0.12.3.ebuild,
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.13.16.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.13.16.ebuild
new file mode 100644
index 000000000000..24b3a467d4e6
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.13.16.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.13.16.ebuild,v 1.1 2011/03/09 05:40:55 nirbheek Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit python virtualx
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +introspection +vala"
+
+RDEPEND=">=dev-libs/glib-2.25.16
+ >=dev-libs/dbus-glib-0.82
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ vala? (
+ dev-lang/vala:0.12[vapigen]
+ >=dev-libs/gobject-introspection-0.9.6 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+src_prepare() {
+ python_convert_shebangs -r 2 examples tests tools
+ default_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use vala; then
+ myconf="--enable-introspection
+ VALAC=$(type -p valac-0.12)
+ VAPIGEN=$(type -p vapigen-0.12)"
+ fi
+
+ econf --disable-static \
+ PYTHON=$(PYTHON -2 -a) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ $(use_enable debug debug-cache) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings) \
+ ${myconf}
+}
+
+src_test() {
+ # Needs dbus for tests (auto-launched)
+ Xemake -j1 check || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}