summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2002-01-24 19:54:01 +0000
committerDonny Davies <woodchip@gentoo.org>2002-01-24 19:54:01 +0000
commit147ba2285f058d6b9bbb189dac75f54474ba2db7 (patch)
tree301616e3ff494d535a7357fb0acfc84e2e9e7640 /net-libs
parentadded missing dep sys-apps/xfsprogs (it needs the headers) (diff)
downloadgentoo-2-147ba2285f058d6b9bbb189dac75f54474ba2db7.tar.gz
gentoo-2-147ba2285f058d6b9bbb189dac75f54474ba2db7.tar.bz2
gentoo-2-147ba2285f058d6b9bbb189dac75f54474ba2db7.zip
First version for portage. This library is used by
the net-analyzer/lcrzoex toolbox.
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/lcrzo/files/digest-lcrzo-4.031
-rw-r--r--net-libs/lcrzo/lcrzo-4.03.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-libs/lcrzo/files/digest-lcrzo-4.03 b/net-libs/lcrzo/files/digest-lcrzo-4.03
new file mode 100644
index 000000000000..e8049d20b951
--- /dev/null
+++ b/net-libs/lcrzo/files/digest-lcrzo-4.03
@@ -0,0 +1 @@
+MD5 e6e78a925b4a3f737776b42679f96b7c lcrzo-4.03-src.tgz 630784
diff --git a/net-libs/lcrzo/lcrzo-4.03.ebuild b/net-libs/lcrzo/lcrzo-4.03.ebuild
new file mode 100644
index 000000000000..751a5be19146
--- /dev/null
+++ b/net-libs/lcrzo/lcrzo-4.03.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Donny Davies <woodchip@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-libs/lcrzo/lcrzo-4.03.ebuild,v 1.1 2002/01/24 19:54:01 woodchip Exp $
+
+DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
+HOMEPAGE="http://www.laurentconstantin.com/en/lcrzo/"
+SRC_URI="http://www.laurentconstantin.com/common/${PN}/download/v4/${P}-src.tgz"
+S=${WORKDIR}/${P}-src
+
+DEPEND="virtual/glibc net-libs/libpcap"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}/src
+
+ # genemake checks that these directories exist...
+ mv genemake genemake.orig
+ sed -e "s:/usr/local/include:/usr/include:" \
+ -e "s:/usr/local/lib:/usr/lib:" \
+ -e "s:/usr/local/bin:/usr/bin:" \
+ -e "s:/usr/local/man/man1:/usr/share/man/man1:" \
+ -e "s:/usr/local/man/man3:/usr/share/man/man3:" \
+ genemake.orig > genemake
+
+ chmod 755 genemake
+ ./genemake || die "problem creating Makefile"
+
+ # plug in our CFLAGS and make it install into ${D}...
+ mv Makefile Makefile.orig
+ sed -e "s:^GCCOPT=.*:GCCOPT=${CFLAGS}:" \
+ -e "s:^GCCOPTL=.*:GCCOPTL=${CFLAGS}:" \
+ -e "s:^GCCOPTP=.*:GCCOPTP=${CFLAGS}:" \
+ -e "s:^INSTINCLUDE=:INSTINCLUDE=${D}:" \
+ -e "s:^INSTLIB=:INSTLIB=${D}:" \
+ -e "s:^INSTBIN=:INSTBIN=${D}:" \
+ -e "s:^INSTMAN1=:INSTMAN1=${D}:" \
+ -e "s:^INSTMAN3=:INSTMAN3=${D}:" \
+ Makefile.orig > Makefile
+}
+
+src_compile() {
+ make -C src || die "compile problem :("
+}
+
+src_install() {
+ dodir /usr/{bin,include,lib} /usr/share/man/{man1,man3}
+ make -C src install || die
+ dodoc doc/*.txt
+}