summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-04-22 13:55:34 +0000
committerMichał Górny <mgorny@gentoo.org>2015-04-22 13:55:34 +0000
commit207669d1bad1dc24473ff22ab38d4c3dcb0d7328 (patch)
tree7e99de108900837c285fd560c806b06be5ae0735 /net-libs
parentOnly add -finline-limit=1200 to CFLAGS when the compiler supports it to fix b... (diff)
downloadgentoo-2-207669d1bad1dc24473ff22ab38d4c3dcb0d7328.tar.gz
gentoo-2-207669d1bad1dc24473ff22ab38d4c3dcb0d7328.tar.bz2
gentoo-2-207669d1bad1dc24473ff22ab38d4c3dcb0d7328.zip
Version bump with rebaked pkg-config patch. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/106 by Johan Bergström.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/iojs/ChangeLog9
-rw-r--r--net-libs/iojs/files/iojs-1.8.1-pkgconfig.patch39
-rw-r--r--net-libs/iojs/iojs-1.8.1.ebuild125
3 files changed, 172 insertions, 1 deletions
diff --git a/net-libs/iojs/ChangeLog b/net-libs/iojs/ChangeLog
index 066797bd2d71..fbe474e2edaa 100644
--- a/net-libs/iojs/ChangeLog
+++ b/net-libs/iojs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/iojs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/ChangeLog,v 1.15 2015/04/16 09:05:28 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/ChangeLog,v 1.16 2015/04/22 13:55:34 mgorny Exp $
+
+*iojs-1.8.1 (22 Apr 2015)
+
+ 22 Apr 2015; Michał Górny <mgorny@gentoo.org>
+ +files/iojs-1.8.1-pkgconfig.patch, +iojs-1.8.1.ebuild:
+ Version bump with rebaked pkg-config patch. https://github.com/gentoo/gentoo-
+ portage-rsync-mirror/pull/106 by Johan Bergström.
*iojs-1.7.1 (16 Apr 2015)
diff --git a/net-libs/iojs/files/iojs-1.8.1-pkgconfig.patch b/net-libs/iojs/files/iojs-1.8.1-pkgconfig.patch
new file mode 100644
index 000000000000..788195b5821d
--- /dev/null
+++ b/net-libs/iojs/files/iojs-1.8.1-pkgconfig.patch
@@ -0,0 +1,39 @@
+--- configure 2015-04-21 10:37:04.000000000 +1000
++++ configure.new 2015-04-21 12:47:46.340709492 +1000
+@@ -326,12 +326,13 @@
+
+
+ def pkg_config(pkg):
+- cmd = os.popen('pkg-config --libs %s' % pkg, 'r')
++ pkg_config = os.environ.get('PKG_CONFIG', 'pkg-config')
++ cmd = os.popen(pkg_config + ' --libs %s' % pkg, 'r')
+ libs = cmd.readline().strip()
+ ret = cmd.close()
+ if (ret): return None
+
+- cmd = os.popen('pkg-config --cflags %s' % pkg, 'r')
++ cmd = os.popen(pkg_config + ' --cflags %s' % pkg, 'r')
+ cflags = cmd.readline().strip()
+ ret = cmd.close()
+ if (ret): return None
+@@ -657,13 +658,18 @@
+
+ def configure_libz(o):
+ o['variables']['node_shared_zlib'] = b(options.shared_zlib)
++ (libs, cflags) = pkg_config('zlib') or ('-lz', '')
+
+- if options.shared_zlib:
+- o['libraries'] += ['-l%s' % options.shared_zlib_libname]
+ if options.shared_zlib_libpath:
+ o['libraries'] += ['-L%s' % options.shared_zlib_libpath]
+ if options.shared_zlib_includes:
+ o['include_dirs'] += [options.shared_zlib_includes]
++ else:
++ o['cflags'] += cflags.split()
++ if options.shared_zlib_libname:
++ o['libraries'] += ['-l%s' % options.shared_zlib_libname]
++ else:
++ o['libraries'] += libs.split()
+
+
+ def configure_http_parser(o):
diff --git a/net-libs/iojs/iojs-1.8.1.ebuild b/net-libs/iojs/iojs-1.8.1.ebuild
new file mode 100644
index 000000000000..584f34bf1b83
--- /dev/null
+++ b/net-libs/iojs/iojs-1.8.1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/iojs-1.8.1.ebuild,v 1.1 2015/04/22 13:55:34 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+MY_PV="v${PV}"
+MY_P="${PN}-${MY_PV}"
+
+inherit flag-o-matic pax-utils python-single-r1 toolchain-funcs
+
+DESCRIPTION="An npm compatible platform originally based on node.js"
+HOMEPAGE="http://iojs.org/"
+SRC_URI="http://iojs.org/dist/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="bundled-libs debug icu +npm snapshot +ssl"
+
+RDEPEND="icu? ( dev-libs/icu )
+ ${PYTHON_DEPS}
+ !bundled-libs? (
+ >=net-libs/http-parser-2.3
+ >=dev-libs/libuv-1.4.2
+ >=dev-libs/openssl-1.0.1m[-bindist]
+ )"
+DEPEND="${RDEPEND}
+ !!net-libs/nodejs"
+S="${WORKDIR}/${MY_P}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+pkg_pretend() {
+ if ! test-flag-CXX -std=c++11 ; then
+ die "Your compiler doesn't support C++11. Use GCC 4.8, Clang 3.3 or newer."
+ fi
+}
+
+src_prepare() {
+ tc-export CC CXX PKG_CONFIG
+ export V=1 # Verbose build
+ export BUILDTYPE=Release
+
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/${EPYTHON}/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+ sed -i -e "s/|| 'python'/|| '${EPYTHON}'/" deps/npm/node_modules/node-gyp/lib/configure.js || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+
+ # proper libdir, hat tip @ryanpcmcquen https://github.com/iojs/io.js/issues/504
+ local LIBDIR=$(get_libdir)
+ sed -i -e "s|lib/|${LIBDIR}/|g" tools/install.py || die
+ sed -i -e "s/'lib'/'${LIBDIR}'/" lib/module.js || die
+ sed -i -e "s|\"lib\"|\"${LIBDIR}\"|" deps/npm/lib/npm.js || die
+
+ epatch "${FILESDIR}"/${P}-pkgconfig.patch
+
+ # Avoid a test that I've only been able to reproduce from emerge. It doesnt
+ # seem sandbox related either (invoking it from a sandbox works fine).
+ # The issue is that no stdin handle is openened when asked for one.
+ # It doesn't really belong upstream , so it'll just be removed until someone
+ # with more gentoo-knowledge than me (jbergstroem) figures it out.
+ rm test/parallel/test-stdout-close-unref.js || die
+
+ # debug builds. change install path, remove optimisations and override buildtype
+ if use debug; then
+ sed -i -e "s|out/Release/|out/Debug/|g" tools/install.py
+ BUILDTYPE=Debug
+ fi
+}
+
+src_configure() {
+ local myconf=()
+ local myarch=""
+ use bundled-libs || myconf+=( --shared-openssl --shared-libuv --shared-http-parser --shared-zlib )
+ use npm || myconf+=( --without-npm )
+ use icu && myconf+=( --with-intl=system-icu )
+ use snapshot && myconf+=( --with-snapshot )
+ use ssl || myconf+=( --without-ssl )
+ use debug && myconf+=( --debug )
+
+ case ${ABI} in
+ x86) myarch="ia32";;
+ amd64) myarch="x64";;
+ x32) myarch="x32";;
+ arm) myarch="arm";;
+ arm64) myarch="arm64";;
+ *) die "Unrecognized ARCH ${ARCH}";;
+ esac
+
+ "${PYTHON}" configure \
+ --prefix="${EPREFIX}"/usr \
+ --dest-cpu=${myarch} \
+ --without-dtrace \
+ "${myconf[@]}" || die
+}
+
+src_compile() {
+ emake -C out mksnapshot
+ pax-mark m "out/${BUILDTYPE}/mksnapshot"
+ emake -C out
+}
+
+src_install() {
+ local LIBDIR="${ED}/usr/$(get_libdir)"
+ emake install DESTDIR="${ED}"
+ use npm && dodoc -r "${LIBDIR}"/node_modules/npm/html
+ rm -rf "${LIBDIR}"/node_modules/npm/{doc,html} || die
+ find "${LIBDIR}"/node_modules -type f -name "LICENSE" -delete
+
+ pax-mark -m "${ED}"/usr/bin/iojs
+}
+
+src_test() {
+ out/${BUILDTYPE}/cctest || die
+ declare -xl TESTTYPE="${BUILDTYPE}"
+ "${PYTHON}" tools/test.py --mode=${TESTTYPE} -J message parallel sequential || die
+}