summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-02-16 11:48:45 +0000
committerMike Frysinger <vapier@gentoo.org>2015-02-16 11:48:45 +0000
commit33efcdacd14e76d13e2a9f96d4046a13b34a055f (patch)
tree63b0045d60fa2363832c083d0f720d7430d8ea71 /net-libs
parentFix by Paul McClave to respect $PKG_CONFIG. (diff)
downloadgentoo-2-33efcdacd14e76d13e2a9f96d4046a13b34a055f.tar.gz
gentoo-2-33efcdacd14e76d13e2a9f96d4046a13b34a055f.tar.bz2
gentoo-2-33efcdacd14e76d13e2a9f96d4046a13b34a055f.zip
Clean up src_configure: use proper arrays to hold flags, and use $ARCH rather than $CHOST matching to look up the target arch.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/iojs/ChangeLog6
-rw-r--r--net-libs/iojs/iojs-1.2.0.ebuild49
2 files changed, 28 insertions, 27 deletions
diff --git a/net-libs/iojs/ChangeLog b/net-libs/iojs/ChangeLog
index ed2333b7666c..0be11175d356 100644
--- a/net-libs/iojs/ChangeLog
+++ b/net-libs/iojs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/iojs
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/ChangeLog,v 1.7 2015/02/16 11:28:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/ChangeLog,v 1.8 2015/02/16 11:48:45 vapier Exp $
+
+ 16 Feb 2015; Mike Frysinger <vapier@gentoo.org> iojs-1.2.0.ebuild:
+ Clean up src_configure: use proper arrays to hold flags, and use $ARCH rather
+ than $CHOST matching to look up the target arch.
16 Feb 2015; Mike Frysinger <vapier@gentoo.org>
+files/iojs-1.2.0-pkgconfig.patch, iojs-1.2.0.ebuild:
diff --git a/net-libs/iojs/iojs-1.2.0.ebuild b/net-libs/iojs/iojs-1.2.0.ebuild
index da4b514401e7..c504a8e88044 100644
--- a/net-libs/iojs/iojs-1.2.0.ebuild
+++ b/net-libs/iojs/iojs-1.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/iojs-1.2.0.ebuild,v 1.4 2015/02/16 11:28:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/iojs/iojs-1.2.0.ebuild,v 1.5 2015/02/16 11:48:45 vapier Exp $
EAPI=5
@@ -62,43 +62,40 @@ src_prepare() {
# It doesn't really belong upstream , so it'll just be removed until someone
# with more gentoo-knowledge than me (jbergstroem) figures it out.
rm test/parallel/test-stdout-close-unref.js
+}
+src_configure() {
tc-export CC CXX PKG_CONFIG
export V=1
-}
-src_configure() {
- local myconf=""
+ local myconf=()
local myarch=""
- ! use npm && myconf="--without-npm"
- use icu && myconf+=" --with-intl=system-icu"
- use snapshot && myconf+=" --with-snapshot"
-
- case ${CHOST} in
- i?86-*)
- myarch="ia32"
- ;;
- x86_64-*)
- if [[ $ABI = x86 ]]; then
- myarch="ia32"
- elif [[ $ABI = x32 ]]; then
- myarch="x32"
- else
- myarch="x64"
- fi ;;
- arm*-*)
- myarch="arm"
- ;;
- *) die "Unrecognized CHOST: ${CHOST}"
+ ! use npm && myconf+=( --without-npm )
+ use icu && myconf+=( --with-intl=system-icu )
+ use snapshot && myconf+=( --with-snapshot )
+
+ case ${ARCH} in
+ x86) myarch="ia32";;
+ amd64)
+ case ${ABI} in
+ x86) myarch="ia32";;
+ x32) myarch="x32";;
+ *) myarch="x64";;
+ esac
+ ;;
+ arm) myarch="arm";;
+ *) die "Unrecognized ARCH ${ARCH}";;
esac
- "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ "${PYTHON}" configure \
+ --prefix="${EPREFIX}"/usr \
--shared-openssl \
--shared-libuv \
--shared-http-parser \
--shared-zlib \
--dest-cpu=${myarch} \
- --without-dtrace ${myconf} || die
+ --without-dtrace \
+ "${myconf[@]}" || die
}
src_install() {