summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-30 23:02:57 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-12-30 23:02:57 +0000
commit3b3973282d20937cbcf11d58f878cbd60e92180d (patch)
treec5ab6c4de7723d8efb0c86d7e86a8170d196acd6 /net-libs
parentVersion bump (diff)
downloadgentoo-2-3b3973282d20937cbcf11d58f878cbd60e92180d.tar.gz
gentoo-2-3b3973282d20937cbcf11d58f878cbd60e92180d.tar.bz2
gentoo-2-3b3973282d20937cbcf11d58f878cbd60e92180d.zip
Revert accidental removal
(Portage version: 2.1.10.41/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libktorrent/ChangeLog6
-rw-r--r--net-libs/libktorrent/libktorrent-1.1.1.ebuild51
2 files changed, 56 insertions, 1 deletions
diff --git a/net-libs/libktorrent/ChangeLog b/net-libs/libktorrent/ChangeLog
index 61910df8d7c7..060e54cc7ae4 100644
--- a/net-libs/libktorrent/ChangeLog
+++ b/net-libs/libktorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libktorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.25 2011/12/30 22:58:46 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.26 2011/12/30 23:02:56 dilfridge Exp $
+
+ 30 Dec 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +libktorrent-1.1.1.ebuild:
+ Revert accidental removal
*libktorrent-1.1.3 (30 Dec 2011)
diff --git a/net-libs/libktorrent/libktorrent-1.1.1.ebuild b/net-libs/libktorrent/libktorrent-1.1.1.ebuild
new file mode 100644
index 000000000000..0d3fcceb6f3d
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-1.1.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.1.1.ebuild,v 1.7 2011/12/30 23:02:57 dilfridge Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+if [[ ${PV} != 9999* ]]; then
+ inherit versionator
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ KTORRENT_VERSION=$(($(get_major_version)+3)).$(get_version_component_range 2-3 ${MY_PV})
+ MY_P="${PN}-${MY_PV}"
+ KDE_HANDBOOK="optional"
+ KDE_DOC_DIRS="doc"
+
+ KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km ku lt lv ms nb nds nl nn oc pl
+ pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${KTORRENT_VERSION}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+
+ KEYWORDS="amd64 ppc ~ppc64 x86"
+else
+ KEYWORDS=""
+fi
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent library based on KDE Platform"
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+ # do not build non-installed example binary
+ sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt || die
+}