summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2011-11-07 06:09:22 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2011-11-07 06:09:22 +0000
commit3d96b3de91e1d351d83a2aafe36fdd07619ad6dc (patch)
tree36083373d02d1ce3e943a38f8a97af4a10ffe3b5 /net-libs
parentVersion bump. (diff)
downloadgentoo-2-3d96b3de91e1d351d83a2aafe36fdd07619ad6dc.tar.gz
gentoo-2-3d96b3de91e1d351d83a2aafe36fdd07619ad6dc.tar.bz2
gentoo-2-3d96b3de91e1d351d83a2aafe36fdd07619ad6dc.zip
Do a better fix for the out of tree build failure, avoids eautoreconf, works with trunk builds too.
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/gtk-vnc/ChangeLog7
-rw-r--r--net-libs/gtk-vnc/files/gtk-vnc-0.4.3-outoftree-build.patch21
-rw-r--r--net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild12
3 files changed, 12 insertions, 28 deletions
diff --git a/net-libs/gtk-vnc/ChangeLog b/net-libs/gtk-vnc/ChangeLog
index 67093dc95fc0..320698b0a30a 100644
--- a/net-libs/gtk-vnc/ChangeLog
+++ b/net-libs/gtk-vnc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/gtk-vnc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.72 2011/10/30 17:24:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/ChangeLog,v 1.73 2011/11/07 06:09:22 nirbheek Exp $
+
+ 07 Nov 2011; Nirbheek Chauhan <nirbheek@gentoo.org> gtk-vnc-0.4.3-r1.ebuild,
+ -files/gtk-vnc-0.4.3-outoftree-build.patch:
+ Do a better fix for the out of tree build failure, avoids eautoreconf, works
+ with trunk builds too.
30 Oct 2011; Raúl Porcel <armin76@gentoo.org> gtk-vnc-0.4.3-r1.ebuild:
alpha/ia64/sparc stable wrt #385699
diff --git a/net-libs/gtk-vnc/files/gtk-vnc-0.4.3-outoftree-build.patch b/net-libs/gtk-vnc/files/gtk-vnc-0.4.3-outoftree-build.patch
deleted file mode 100644
index 36a3a3a9e158..000000000000
--- a/net-libs/gtk-vnc/files/gtk-vnc-0.4.3-outoftree-build.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-diff --git a/src/Makefile.am b/src/Makefile.am
-index 37f8444..2f72fa6 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -279,14 +279,14 @@ GVNC_INTROSPECTION_SRCS = \
- $(srcdir)/vnccolormap.h $(srcdir)/vnccolormap.c \
- $(srcdir)/vnccursor.h $(srcdir)/vnccursor.c \
- $(srcdir)/vncconnection.h $(srcdir)/vncconnection.c \
-- $(builddir)/vncconnectionenums.h $(builddir)/vncconnectionenums.c \
-+ $(srcdir)/vncconnectionenums.h $(srcdir)/vncconnectionenums.c \
- $(srcdir)/vncutil.h $(srcdir)/vncutil.c
-
- GTK_VNC_INTROSPECTION_SRCS = \
- $(srcdir)/vnccairoframebuffer.h $(srcdir)/vnccairoframebuffer.c \
- $(srcdir)/vncdisplay.h $(srcdir)/vncdisplay.c \
- $(srcdir)/vncgrabsequence.h $(srcdir)/vncgrabsequence.c \
-- $(builddir)/vncdisplayenums.h $(builddir)/vncdisplayenums.c
-+ $(srcdir)/vncdisplayenums.h $(srcdir)/vncdisplayenums.c
-
- if HAVE_GTK_2
- GTK_VNC_INTROSPECTION_SRCS += \
diff --git a/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild b/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild
index 726f8a7ebedc..5a2dbe67ea2b 100644
--- a/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild
+++ b/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild,v 1.6 2011/10/30 17:24:14 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gtk-vnc/gtk-vnc-0.4.3-r1.ebuild,v 1.7 2011/11/07 06:09:22 nirbheek Exp $
EAPI="3"
@@ -45,15 +45,15 @@ src_prepare() {
mkdir "${GTK2_BUILDDIR}" || die
mkdir "${GTK3_BUILDDIR}" || die
- # Fix incorrect rules for out of tree build
- epatch "${FILESDIR}/${PN}-0.4.3-outoftree-build.patch"
+ # Remove a few files that were autogenerated during distcheck.
+ # Having these around in srcdir breaks out of tree build since they're
+ # expected to be in builddir, which is correct for trunk builds since
+ # they're generated files, not source files. Funny false dichotomy.
+ rm -vf "${S}"/src/{vncconnectionenums.[ch],vncdisplayenums.[ch]}
# Fix incorrect codegendir check: h2def.py is in pygobject, not pygtk
sed -e 's/codegendir pygtk-2.0/codegendir pygobject-2.0/g' \
-i src/Makefile.* || die
-
- intltoolize --force --copy --automake || die
- eautoreconf
}
src_configure() {