summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-19 16:46:29 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-05-19 16:46:29 +0000
commit44d10fa593397c79605ece09ea10920e921417d7 (patch)
tree3a5669493169672e30a0f063591743e8acc3d862 /net-libs
parent->=net-irc/xchat-gnome-0.11 (diff)
downloadgentoo-2-44d10fa593397c79605ece09ea10920e921417d7.tar.gz
gentoo-2-44d10fa593397c79605ece09ea10920e921417d7.tar.bz2
gentoo-2-44d10fa593397c79605ece09ea10920e921417d7.zip
Version bump.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.9.23
-rw-r--r--net-libs/libtorrent/libtorrent-0.9.2.ebuild37
3 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 4ff681490023..83d01b13f2ed 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.54 2006/05/05 09:15:29 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.55 2006/05/19 16:46:29 flameeyes Exp $
+
+*libtorrent-0.9.2 (19 May 2006)
+
+ 19 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+ +libtorrent-0.9.2.ebuild:
+ Version bump.
*libtorrent-0.9.1 (05 May 2006)
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.9.2 b/net-libs/libtorrent/files/digest-libtorrent-0.9.2
new file mode 100644
index 000000000000..ca29c49c2bd4
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.9.2
@@ -0,0 +1,3 @@
+MD5 fd2c2f503462ac1c552bc311cf768956 libtorrent-0.9.2.tar.gz 463648
+RMD160 2e084922e979a6f227b9b453e2134998737cba6a libtorrent-0.9.2.tar.gz 463648
+SHA256 196c6437d63b3d1dee5ee10f9fe7900881c5380e5ec0b4d63a9398f7956167df libtorrent-0.9.2.tar.gz 463648
diff --git a/net-libs/libtorrent/libtorrent-0.9.2.ebuild b/net-libs/libtorrent/libtorrent-0.9.2.ebuild
new file mode 100644
index 000000000000..2cb6b19edd43
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.9.2.ebuild,v 1.1 2006/05/19 16:46:29 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ [[ $(tc-arch) = "x86" ]] && filter-flags -fomit-frame-pointer
+ replace-flags -Os -O2
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}