summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2013-05-28 05:23:26 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2013-05-28 05:23:26 +0000
commit516da738e0ec8826d740f6c2ace59ed2dc33d5fc (patch)
treee6ae677c667929bf302486eebbf9dfd897a03b41 /net-libs
parenteverytime you don't quote a variable "" kills a kitten (diff)
downloadgentoo-2-516da738e0ec8826d740f6c2ace59ed2dc33d5fc.tar.gz
gentoo-2-516da738e0ec8826d740f6c2ace59ed2dc33d5fc.tar.bz2
gentoo-2-516da738e0ec8826d740f6c2ace59ed2dc33d5fc.zip
Fix build failure due to underlinking and silence excessive warnings with gcc-4.8 (bug #458164, thanks to Ted Tanberry and Mike Frysinger).
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/ChangeLog8
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.10.2-gcc-4.8.patch55
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch49
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild9
4 files changed, 119 insertions, 2 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 9878e7a2ef0f..5abb04d7f74a 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.204 2013/05/15 11:53:32 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.205 2013/05/28 05:23:26 tetromino Exp $
+
+ 28 May 2013; Alexandre Rostovtsev <tetromino@gentoo.org>
+ webkit-gtk-1.10.2-r300.ebuild, +files/webkit-gtk-1.10.2-gcc-4.8.patch,
+ +files/webkit-gtk-1.10.2-librt.patch:
+ Fix build failure due to underlinking and silence excessive warnings with
+ gcc-4.8 (bug #458164, thanks to Ted Tanberry and Mike Frysinger).
*webkit-gtk-2.0.2 (15 May 2013)
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-gcc-4.8.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-gcc-4.8.patch
new file mode 100644
index 000000000000..656a7b18c012
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-gcc-4.8.patch
@@ -0,0 +1,55 @@
+2013-04-04 Andras Becsi <andras.becsi@digia.com>
+
+ Fix the build with GCC 4.8
+ https://bugs.webkit.org/show_bug.cgi?id=113147
+
+ Initialize JSObject* exception to suppress warnings that make
+ the build fail because of -Werror=maybe-uninitialized.
+
+ * runtime/Executable.cpp:
+ (JSC::FunctionExecutable::compileForCallInternal):
+ (JSC::FunctionExecutable::compileForConstructInternal):
+
+ Fix the build with GCC 4.8
+ https://bugs.webkit.org/show_bug.cgi?id=113147
+
+ Disable diagnostic warning -Wunused-local-typedefs for GCC 4.8
+ since dummy typedefs are commonly used in the codebase.
+
+ * wtf/Compiler.h:
+
+diff --git a/Source/JavaScriptCore/runtime/Executable.cpp b/Source/JavaScriptCore/runtime/Executable.cpp
+index 8b58b62aa3e39a347fae92961af69484de795a07..057bb43c6777bc4b63b23c0cabf32d106ca0243c 100644
+--- a/Source/JavaScriptCore/runtime/Executable.cpp
+@@ -515,7 +515,7 @@
+ UNUSED_PARAM(bytecodeIndex);
+ #endif
+ ASSERT((jitType == JITCode::bottomTierJIT()) == !m_codeBlockForCall);
+- JSObject* exception;
++ JSObject* exception = 0;
+ OwnPtr<FunctionCodeBlock> newCodeBlock = produceCodeBlockFor(scopeChainNode, !!m_codeBlockForCall ? OptimizingCompilation : FirstCompilation, CodeForCall, exception);
+ if (!newCodeBlock)
+ return exception;
+@@ -558,7 +558,7 @@
+ #endif
+
+ ASSERT((jitType == JITCode::bottomTierJIT()) == !m_codeBlockForConstruct);
+- JSObject* exception;
++ JSObject* exception = 0;
+ OwnPtr<FunctionCodeBlock> newCodeBlock = produceCodeBlockFor(scopeChainNode, !!m_codeBlockForConstruct ? OptimizingCompilation : FirstCompilation, CodeForConstruct, exception);
+ if (!newCodeBlock)
+ return exception;
+diff --git a/Source/WTF/wtf/Compiler.h b/Source/WTF/wtf/Compiler.h
+index e11747fb6519fe59560b47aabbe5480e98a9f155..b886f37151292851f311306b90fa5b9bc2880e06 100644
+--- a/Source/WTF/wtf/Compiler.h
++++ b/Source/WTF/wtf/Compiler.h
+@@ -122,6 +122,9 @@
+
+ /* Specific compiler features */
+ #if COMPILER(GCC) && !COMPILER(CLANG)
++#if GCC_VERSION_AT_LEAST(4, 8, 0)
++#pragma GCC diagnostic ignored "-Wunused-local-typedefs"
++#endif
+ #if GCC_VERSION_AT_LEAST(4, 7, 0) && __cplusplus >= 201103L
+ #define WTF_COMPILER_SUPPORTS_CXX_RVALUE_REFERENCES 1
+ #define WTF_COMPILER_SUPPORTS_CXX_DELETED_FUNCTIONS 1
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch
new file mode 100644
index 000000000000..2e0ae62b8673
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.10.2-librt.patch
@@ -0,0 +1,49 @@
+From 3c499aa2a70b06b40a64fb5699622ff458e4ee0f Mon Sep 17 00:00:00 2001
+From: Kalev Lember <kalevlember@gmail.com>
+Date: Sun, 25 Nov 2012 03:26:42 +0100
+Subject: [PATCH] [GTK] Explicitly link against librt
+
+Fixes broken build with undefined references to shm_open / shm_unlink
+symbols. SharedMemoryUnix.cpp uses these so we need to link with -lrt.
+
+https://bugs.webkit.org/show_bug.cgi?id=103194
+---
+ ChangeLog | 12 ++++++++++++
+ Source/WebKit2/ChangeLog | 12 ++++++++++++
+ Source/WebKit2/GNUmakefile.am | 1 +
+ configure.ac | 7 +++++++
+ 4 files changed, 32 insertions(+)
+
+diff --git a/Source/WebKit2/GNUmakefile.am b/Source/WebKit2/GNUmakefile.am
+index 9a02bbd..c775990 100644
+--- a/Source/WebKit2/GNUmakefile.am
++++ b/Source/WebKit2/GNUmakefile.am
+@@ -572,6 +572,7 @@ Programs_WebKitPluginProcess_LDADD += \
+ $(PANGO_LIBS) \
+ $(PNG_LIBS) \
+ $(SHLWAPI_LIBS) \
++ $(SHM_LIBS) \
+ $(SQLITE3_LIBS) \
+ $(UNICODE_LIBS) \
+ $(XRENDER_LIBS) \
+diff --git a/configure.ac b/configure.ac
+index 4e1f0e8..97980e4 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1118,6 +1118,13 @@ if test "$enable_webkit2" = "yes"; then
+ if test "$have_gtk_unix_printing" = "yes"; then
+ AC_DEFINE([HAVE_GTK_UNIX_PRINTING], [1], [Define if GTK+ UNIX Printing is available])
+ fi
++
++ # On some Linux/Unix platforms, shm_* may only be available if linking
++ # against librt
++ if test "$os_win32" = "no"; then
++ AC_SEARCH_LIBS([shm_open], [rt], [SHM_LIBS="-lrt"])
++ AC_SUBST(SHM_LIBS)
++ fi
+ fi
+
+ # Plugin Process
+--
+1.8.0
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild
index 9be721d2ef55..6e00f38dac08 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild,v 1.7 2013/05/01 03:40:59 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.10.2-r300.ebuild,v 1.8 2013/05/28 05:23:26 tetromino Exp $
EAPI="5"
@@ -159,6 +159,13 @@ src_prepare() {
# https://bugs.gentoo.org/show_bug.cgi?id=449220#c17
epatch "${FILESDIR}/${PN}-1.10.2-wifexited.patch"
+ # patch for gcc 4.8, to disable COMPILE_ASSERT warnings; fixed in 2.0.x
+ # https://bugs.webkit.org/show_bug.cgi?id=113147
+ epatch "${FILESDIR}/${P}-gcc-4.8.patch"
+
+ # patch for -lrt underlinking issue, bug #458164; fixed in 2.0.x
+ epatch "${FILESDIR}/${P}-librt.patch"
+
# Respect CC, otherwise fails on prefix #395875
tc-export CC