summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-19 09:44:46 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-19 09:44:46 +0000
commit54e0b50f477e18f1c6ce2e0679a39f0fc14321d1 (patch)
treeccffdffa3cf912476ae1c9d63524830bc618ba74 /net-libs
parentBump (diff)
downloadgentoo-2-54e0b50f477e18f1c6ce2e0679a39f0fc14321d1.tar.gz
gentoo-2-54e0b50f477e18f1c6ce2e0679a39f0fc14321d1.tar.bz2
gentoo-2-54e0b50f477e18f1c6ce2e0679a39f0fc14321d1.zip
Version bump by Michael (kensington) <gentoo@scribeofthenile.com> wrt bug #409847.
(Portage version: 2.2.0_alpha100/cvs/Linux i686)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/telepathy-qt/ChangeLog10
-rw-r--r--net-libs/telepathy-qt/files/telepathy-qt-0.9.1-automagicness.patch109
-rw-r--r--net-libs/telepathy-qt/metadata.xml1
-rw-r--r--net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild63
4 files changed, 182 insertions, 1 deletions
diff --git a/net-libs/telepathy-qt/ChangeLog b/net-libs/telepathy-qt/ChangeLog
index 010072661894..3441bb6cbc0b 100644
--- a/net-libs/telepathy-qt/ChangeLog
+++ b/net-libs/telepathy-qt/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/telepathy-qt4
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.4 2012/04/04 08:54:34 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/ChangeLog,v 1.5 2012/04/19 09:44:46 johu Exp $
+
+*telepathy-qt-0.9.1 (19 Apr 2012)
+
+ 19 Apr 2012; Johannes Huber <johu@gentoo.org>
+ +files/telepathy-qt-0.9.1-automagicness.patch, +telepathy-qt-0.9.1.ebuild,
+ metadata.xml:
+ Version bump by Michael (kensington) <gentoo@scribeofthenile.com> wrt bug
+ #409847.
04 Apr 2012; Johannes Huber <johu@gentoo.org> telepathy-qt-0.9.0.ebuild:
Raise dep.
diff --git a/net-libs/telepathy-qt/files/telepathy-qt-0.9.1-automagicness.patch b/net-libs/telepathy-qt/files/telepathy-qt-0.9.1-automagicness.patch
new file mode 100644
index 000000000000..b34adb3fc971
--- /dev/null
+++ b/net-libs/telepathy-qt/files/telepathy-qt-0.9.1-automagicness.patch
@@ -0,0 +1,109 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index b61c12f..7110d51 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -73,6 +73,13 @@ include(TpQtMacros)
+
+ include(MacroLogFeature)
+
++# options
++option(WITH_Farsight "Enable building with farsight features" ON)
++option(WITH_Farstream "Enable building with farstream features" ON)
++option(ENABLE_DEBUG_OUTPUT "Compile support for printing debug output to stderr" ON)
++option(ENABLE_EXAMPLES "Enable building of examples" ON)
++option(ENABLE_TEST "Enable test suite" ON)
++
+ # external dependencies
+
+ # Required dependencies
+@@ -122,7 +129,6 @@ include_directories(${CMAKE_SOURCE_DIR}
+
+ add_definitions(-DQT_NO_CAST_FROM_ASCII)
+
+-set(ENABLE_DEBUG_OUTPUT ON CACHE BOOL "If activated, compiles support for printing debug output to stderr")
+ if (ENABLE_DEBUG_OUTPUT)
+ add_definitions(-DENABLE_DEBUG)
+ endif (ENABLE_DEBUG_OUTPUT)
+@@ -176,7 +182,9 @@ macro_log_feature(HAVE_TEST_PYTHON "dbus-python"
+ "Needed to build some additional unit tests")
+
+ # Find GLib2, GObject, DBus and LibXml2
+-# Those are needed for the insane include dir dependency hell
++# These packages are not actually required by telepathy-qt
++# Rather, we call these macros to get the include dir required
++# to compile the dependencies of our actual dependencies
+ find_package(GLIB2)
+ find_package(GObject)
+ find_package(GIO)
+@@ -185,29 +193,33 @@ find_package(DBus)
+ find_package(DBusGLib)
+ find_package(LibXml2)
+
+-# Find tp-farsight
+-set(TELEPATHY_FARSIGHT_MIN_VERSION "0.0.4")
+-find_package(TelepathyFarsight)
+-macro_log_feature(TELEPATHYFARSIGHT_FOUND "Telepathy-Farsight"
+- "A Framework for dealing with audio/video conferencing protocols"
+- "http://farsight.freedesktop.org/wiki/" FALSE "${TELEPATHY_FARSIGHT_MIN_VERSION}"
+- "Needed, together with GStreamer, to build telepathy-qt-farsight and some additional examples")
+-
+-# Find tp-farsight
+-set(FARSTREAM_MIN_VERSION "0.1.0")
+-find_package(Farstream)
+-macro_log_feature(FARSTREAM_FOUND "Farstream"
+- "A Framework for dealing with audio/video conferencing protocols"
+- "http://www.freedesktop.org/wiki/Software/Farstream" FALSE "${FARSTREAM_MIN_VERSION}"
+- "Needed, together with GStreamer and Telepathy-Farstream, to build telepathy-qt-farstream")
+-
+-# Find tp-farsight
+-set(TELEPATHY_FARSTREAM_MIN_VERSION "0.2.2")
+-find_package(TelepathyFarstream)
+-macro_log_feature(TELEPATHYFARSTREAM_FOUND "Telepathy-Farstream"
+- "A Framework for dealing with audio/video conferencing protocols"
+- "http://telepathy.freedesktop.org/wiki/" FALSE "${TELEPATHY_FARSTREAM_MIN_VERSION}"
+- "Needed, together with GStreamer and Farstream, to build telepathy-qt-farstream")
++if(WITH_Farsight)
++ # Find tp-farsight
++ set(TELEPATHY_FARSIGHT_MIN_VERSION "0.0.4")
++ find_package(TelepathyFarsight)
++ macro_log_feature(TELEPATHYFARSIGHT_FOUND "Telepathy-Farsight"
++ "A Framework for dealing with audio/video conferencing protocols"
++ "http://farsight.freedesktop.org/wiki/" FALSE "${TELEPATHY_FARSIGHT_MIN_VERSION}"
++ "Needed, together with GStreamer, to build telepathy-qt-farsight and some additional examples")
++endif(WITH_Farsight)
++
++if(WITH_Farstream)
++ # Find farstream
++ set(FARSTREAM_MIN_VERSION "0.1.0")
++ find_package(Farstream)
++ macro_log_feature(FARSTREAM_FOUND "Farstream"
++ "A Framework for dealing with audio/video conferencing protocols"
++ "http://www.freedesktop.org/wiki/Software/Farstream" FALSE "${FARSTREAM_MIN_VERSION}"
++ "Needed, together with GStreamer and Telepathy-Farstream, to build telepathy-qt-farstream")
++
++ # Find tp-farstream
++ set(TELEPATHY_FARSTREAM_MIN_VERSION "0.2.2")
++ find_package(TelepathyFarstream)
++ macro_log_feature(TELEPATHYFARSTREAM_FOUND "Telepathy-Farstream"
++ "A Framework for dealing with audio/video conferencing protocols"
++ "http://telepathy.freedesktop.org/wiki/" FALSE "${TELEPATHY_FARSTREAM_MIN_VERSION}"
++ "Needed, together with GStreamer and Farstream, to build telepathy-qt-farstream")
++endif(WITH_Farstream)
+
+ # Find GStreamer
+ find_package(GStreamer)
+@@ -258,8 +270,12 @@ endif(QT_GLIB_SUPPORT AND TELEPATHYGLIB_FOUND AND GLIB2_FOUND AND DBUS_FOUND)
+
+ # Add the source subdirectories
+ add_subdirectory(TelepathyQt)
+-add_subdirectory(examples)
+-add_subdirectory(tests)
++if(ENABLE_EXAMPLES)
++ add_subdirectory(examples)
++endif(ENABLE_EXAMPLES)
++if(ENABLE_TEST)
++ add_subdirectory(tests)
++endif(ENABLE_TEST)
+ add_subdirectory(tools)
+
+ # Generate config.h and config-version.h
diff --git a/net-libs/telepathy-qt/metadata.xml b/net-libs/telepathy-qt/metadata.xml
index 25afcbce2d8c..5d2ed019f35a 100644
--- a/net-libs/telepathy-qt/metadata.xml
+++ b/net-libs/telepathy-qt/metadata.xml
@@ -5,5 +5,6 @@
<use>
<flag name='glib'>Enable support for various telepathy/glib related packages</flag>
<flag name='farsight'>Enable support for farsight connection manager</flag>
+ <flag name='farstream'>Enable support for audio/video calls via farstream</flag>
</use>
</pkgmetadata>
diff --git a/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild b/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild
new file mode 100644
index 000000000000..e12b984e36ea
--- /dev/null
+++ b/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-qt/telepathy-qt-0.9.1.ebuild,v 1.1 2012/04/19 09:44:46 johu Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.5"
+inherit python base cmake-utils
+
+DESCRIPTION="Qt4 bindings for the Telepathy D-Bus protocol"
+HOMEPAGE="http://telepathy.freedesktop.org/"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug farsight farstream test"
+
+RDEPEND="
+ x11-libs/qt-core:4
+ x11-libs/qt-dbus:4
+ farsight? (
+ net-libs/telepathy-farsight
+ )
+ farstream? (
+ >=net-libs/telepathy-farstream-0.2.2
+ >=net-libs/telepathy-glib-0.17.5
+ )
+ !net-libs/telepathy-qt4
+"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ farsight? (
+ >=net-libs/telepathy-glib-0.17.5
+ )
+ test? (
+ dev-libs/dbus-glib
+ dev-libs/glib
+ dev-python/dbus-python
+ x11-libs/qt-test:4
+ )
+"
+
+REQUIRED_USE="farsight? ( !farstream )"
+
+PATCHES=( "${FILESDIR}/${P}-automagicness.patch" )
+DOCS=( AUTHORS ChangeLog HACKING NEWS README )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with farsight)
+ $(cmake-utils_use_with farstream)
+ $(cmake-utils_use_enable debug DEBUG_OUTPUT)
+ $(cmake-utils_use_enable test)
+ -DENABLE_EXAMPLES=OFF
+ )
+ cmake-utils_src_configure
+}