summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-06-09 01:20:23 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-06-09 01:20:23 +0000
commit784411e9483896f636d706956dadbe1a38818f8b (patch)
tree08f9309397c962c3140cdc7888b5130c5c8056e0 /net-libs
parentVersion bump. (diff)
downloadgentoo-2-784411e9483896f636d706956dadbe1a38818f8b.tar.gz
gentoo-2-784411e9483896f636d706956dadbe1a38818f8b.tar.bz2
gentoo-2-784411e9483896f636d706956dadbe1a38818f8b.zip
Version bump with patch for gcc-4.3 compatibility. bug #219462. Thanks loki_val for doing the hard part on this one!
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libfwbuilder/ChangeLog9
-rw-r--r--net-libs/libfwbuilder/files/libfwbuilder-2.1.18-gcc43.patch13
-rw-r--r--net-libs/libfwbuilder/libfwbuilder-2.1.18.ebuild55
3 files changed, 76 insertions, 1 deletions
diff --git a/net-libs/libfwbuilder/ChangeLog b/net-libs/libfwbuilder/ChangeLog
index 1920fb8b675a..3ae777c76787 100644
--- a/net-libs/libfwbuilder/ChangeLog
+++ b/net-libs/libfwbuilder/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libfwbuilder
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libfwbuilder/ChangeLog,v 1.71 2008/05/29 07:22:48 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libfwbuilder/ChangeLog,v 1.72 2008/06/09 01:20:22 darkside Exp $
+
+*libfwbuilder-2.1.18 (09 Jun 2008)
+
+ 09 Jun 2008; Jeremy Olexa <darkside@gentoo.org>
+ +files/libfwbuilder-2.1.18-gcc43.patch, +libfwbuilder-2.1.18.ebuild:
+ Version bump with patch for gcc-4.3 compatibility. bug #219462. Thanks
+ loki_val for doing the hard part on this one!
29 May 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Carlos Silva (r3pek) from metadata.xml (as per #80351). Assigning
diff --git a/net-libs/libfwbuilder/files/libfwbuilder-2.1.18-gcc43.patch b/net-libs/libfwbuilder/files/libfwbuilder-2.1.18-gcc43.patch
new file mode 100644
index 000000000000..dec71d649b28
--- /dev/null
+++ b/net-libs/libfwbuilder/files/libfwbuilder-2.1.18-gcc43.patch
@@ -0,0 +1,13 @@
+make sure that libfwbuilder builds with gcc-4.3
+
+--- libfwbuilder-2.1.17.orig/src/fwbuilder/IPAddress.h
++++ libfwbuilder-2.1.17/src/fwbuilder/IPAddress.h
+@@ -29,6 +29,8 @@
+
+ #include <string>
+ #include <vector>
++#include <cstdlib>
++#include <cstring>
+
+ #ifndef _WIN32
+ # include <sys/types.h>
diff --git a/net-libs/libfwbuilder/libfwbuilder-2.1.18.ebuild b/net-libs/libfwbuilder/libfwbuilder-2.1.18.ebuild
new file mode 100644
index 000000000000..cf89170b7b9d
--- /dev/null
+++ b/net-libs/libfwbuilder/libfwbuilder-2.1.18.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libfwbuilder/libfwbuilder-2.1.18.ebuild,v 1.1 2008/06/09 01:20:22 darkside Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="Firewall Builder 2.1 API library and compiler framework"
+HOMEPAGE="http://www.fwbuilder.org/"
+SRC_URI="mirror://sourceforge/fwbuilder/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="snmp ssl stlport"
+
+DEPEND=">=dev-libs/libxml2-2.4.10
+ >=dev-libs/libxslt-1.0.7
+ snmp? ( net-analyzer/net-snmp )
+ ssl? ( dev-libs/openssl )
+ stlport? ( dev-libs/STLport )
+ $(qt_min_version 3)"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+}
+
+src_compile() {
+ # we'll use our eqmake instead of bundled script to process qmake files
+ sed -i -e 's:^. ./runqmake.sh$:echo:' configure \
+ || die "sed configure failed"
+
+ econf $(use_with ssl openssl) \
+ $(use_with snmp ucdsnmp) \
+ $(use_with stlport stlport) \
+ || die "configure failed"
+
+ # use eqmake to generate Makefiles
+ eqmake3 ${PN}.pro
+ for subdir in src src/fwbuilder src/fwcompiler src/test src/confscript \
+ etc doc migration; do
+ eqmake3 "${subdir}/${subdir##*/}.pro" -o ${subdir}/Makefile
+ done
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ emake install DDIR="${D}" || die "Install failed"
+
+ cd "${D}"/usr/share/doc/${PF}
+ rm COPYING INSTALL
+ prepalldocs
+}