summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-01-27 15:11:05 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-01-27 15:11:05 +0000
commit7dbee395a5f666460fd1c2be684f4e08f6bb54fd (patch)
treea233c27ceb2335297597bd0dbb4dae7da1af773f /net-libs
parentx11-misc/dmenu: remove old (diff)
downloadgentoo-2-7dbee395a5f666460fd1c2be684f4e08f6bb54fd.tar.gz
gentoo-2-7dbee395a5f666460fd1c2be684f4e08f6bb54fd.tar.bz2
gentoo-2-7dbee395a5f666460fd1c2be684f4e08f6bb54fd.zip
Version bump
(Portage version: 2.1.2-r4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog10
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.11.23
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.2.ebuild45
3 files changed, 56 insertions, 2 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 063b5d8da725..f2c37c3ff280 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.82 2006/12/28 16:10:36 flameeyes Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.83 2007/01/27 15:11:05 drizzt Exp $
+
+*libtorrent-0.11.2 (27 Jan 2007)
+
+ 27 Jan 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +libtorrent-0.11.2.ebuild:
+ Version bump
*libtorrent-0.11.1 (28 Dec 2006)
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.11.2 b/net-libs/libtorrent/files/digest-libtorrent-0.11.2
new file mode 100644
index 000000000000..8107c573a66d
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.11.2
@@ -0,0 +1,3 @@
+MD5 e31a3738b897c9affae6e4893aaa1f0d libtorrent-0.11.2.tar.gz 498588
+RMD160 c2734603c0c39c9ec1050848f960b9d7260d48fd libtorrent-0.11.2.tar.gz 498588
+SHA256 c5b1ab66a47b14758e5843c4ac3e4d3fed42aa8558eeae6f80c72811c865c06f libtorrent-0.11.2.tar.gz 498588
diff --git a/net-libs/libtorrent/libtorrent-0.11.2.ebuild b/net-libs/libtorrent/libtorrent-0.11.2.ebuild
new file mode 100644
index 000000000000..39e9ac1bf38c
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.11.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.2.ebuild,v 1.1 2007/01/27 15:11:05 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}