summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-13 11:27:35 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2006-12-13 11:27:35 +0000
commita9c1f7722653ce495cb170d26735e1a392c42840 (patch)
treeca2d81838e48f2bebdd10433a2c22f4ec8f8e225 /net-libs
parentFix bbgallery typo wrt to request from jakub and add gimp USE flag for dcraw (diff)
downloadgentoo-2-a9c1f7722653ce495cb170d26735e1a392c42840.tar.gz
gentoo-2-a9c1f7722653ce495cb170d26735e1a392c42840.tar.bz2
gentoo-2-a9c1f7722653ce495cb170d26735e1a392c42840.zip
Version bump, and remove old versions.
(Portage version: 2.1.2_rc3-r4)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libtorrent/ChangeLog10
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.11.03
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.0.ebuild45
3 files changed, 57 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 0ff3b3238809..a919d6c5ae3d 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.75 2006/11/21 14:40:51 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.76 2006/12/13 11:27:35 flameeyes Exp $
+
+*libtorrent-0.11.0 (13 Dec 2006)
+
+ 13 Dec 2006; Diego Pettenò <flameeyes@gentoo.org>
+ -libtorrent-0.9.3.ebuild, -libtorrent-0.10.1.ebuild,
+ -libtorrent-0.10.3.ebuild, -libtorrent-0.10.3-r1.ebuild,
+ +libtorrent-0.11.0.ebuild:
+ Version bump, and remove old versions.
21 Nov 2006; Timothy Redaelli <drizzt@gentoo.org> metadata.xml:
Added myself as co-maintainer.
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.11.0 b/net-libs/libtorrent/files/digest-libtorrent-0.11.0
new file mode 100644
index 000000000000..16d1fdee84e4
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.11.0
@@ -0,0 +1,3 @@
+MD5 1dd6d6c7cbb8a44810452c924f27c104 libtorrent-0.11.0.tar.gz 475919
+RMD160 a67017ac522d4acf303fa5e13bfdede03815d47b libtorrent-0.11.0.tar.gz 475919
+SHA256 68c43878a6f283e7fa2538fa113717ed7331251e2b75e04a434352dabdae0061 libtorrent-0.11.0.tar.gz 475919
diff --git a/net-libs/libtorrent/libtorrent-0.11.0.ebuild b/net-libs/libtorrent/libtorrent-0.11.0.ebuild
new file mode 100644
index 000000000000..0037b5ef6042
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.11.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.0.ebuild,v 1.1 2006/12/13 11:27:35 flameeyes Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+
+ # See bug #151221. It seems only to hit on GCC 4.1 and x86 architecture
+ # it could be safer to fallback to -O1, but with the high use of STL in
+ # rtorrent, that could make it too slow.
+ [[ $(gcc-major-version)$(gcc-minor-version) == "41" ]] && replace-flags -O2 -O3
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}